java.lang.NullPointerException

There are no available Samebug tips for this exception. Do you have an idea how to solve this issue? A short tip would help users who saw this issue last week.

  • Downstream failure
    via by teknokrat,
  • Projects constantly breaking
    via by teknokrat,
  • We have a rather full build envoironment where are about 200 jenkins projects are mainly doing several tests and some more jobs doing other thing like deploys etc. everything is chained in an functional manner and works and grows. Now recently i wanted to not hold too many initerresting builds of a certain project in the tree cause it does nothing than aggregate several triggers from other builds and start downstream ones. So i reduced max number of builds to store to 5 and not i get in the downstream build a Started by upstream project "TESTING-upstream" build number 2536 Started by upstream project "TESTING-upstream" build number 2537 Started by upstream project "TESTING-upstream" build number 2538 Started by upstream project "TESTING-upstream" build number 2539 Started by upstream project "TESTING-upstream" build number 2540 Started by upstream project "TESTING-upstream" build number 2541 Started by upstream project "TESTING-upstream" build number 2542 FATAL: null java.lang.NullPointerException at org.jvnet.hudson.plugins.DownstreamBuildViewUpdateListener.onStarted(DownstreamBuildViewUpdateListener.java:87) at org.jvnet.hudson.plugins.DownstreamBuildViewUpdateListener.onStarted(DownstreamBuildViewUpdateListener.java:46) at hudson.model.listeners.RunListener.fireStarted(RunListener.java:148) at hudson.model.Run.run(Run.java:1357) at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:46) at hudson.model.ResourceController.execute(ResourceController.java:88) at hudson.model.Executor.run(Executor.java:145) because e.g.2536 build is not there anymore when this project starts to run because it was delayed due to an restricted shared ressource. i think thats not ok to get an fatal here... the upstream build isnt here, ok but thats due to a large delay in our setup. if i archive 100 of the upstreams my overviews are rather ugly etc. but it works... so for now i changed that back but its a bit annoying
    via by Philipp Mohrenweiser,
    • java.lang.NullPointerException at org.jvnet.hudson.plugins.DownstreamBuildViewUpdateListener.onStarted(DownstreamBuildViewUpdateListener.java:76) at org.jvnet.hudson.plugins.DownstreamBuildViewUpdateListener.onStarted(DownstreamBuildViewUpdateListener.java:48) at hudson.model.listeners.RunListener.fireStarted(RunListener.java:139) at hudson.model.Run.run(Run.java:1219) at hudson.maven.MavenBuild.access$600(MavenBuild.java:71) at hudson.maven.MavenBuild$ProxyImpl2.close(MavenBuild.java:453) at hudson.maven.MavenModuleSetBuild$Builder.end(MavenModuleSetBuild.java:681) at hudson.maven.MavenModuleSetBuild$RunnerImpl.doRun(MavenModuleSetBuild.java:482) at hudson.model.AbstractBuild$AbstractRunner.run(AbstractBuild.java:416) at hudson.model.Run.run(Run.java:1224) at hudson.maven.MavenModuleSetBuild.run(MavenModuleSetBuild.java:304) at hudson.model.ResourceController.execute(ResourceController.java:88) at hudson.model.Executor.run(Executor.java:122)
    No Bugmate found.