play.api.UnexpectedException: Unexpected exception[ConfigurationException: Guice configuration errors: 1) Could not find a suitable constructor in play.modules.swagger.SwaggerPlugin. Classes must have either one (and only one) constructor annotated with @Inject or a zero-argument constructor that is not private.

Google Groups | Unknown author | 5 months ago
  1. 0

    Issue with Scala Swagger-Play - Guice configuration error

    Google Groups | 5 months ago | Unknown author
    play.api.UnexpectedException: Unexpected exception[ConfigurationException: Guice configuration errors: 1) Could not find a suitable constructor in play.modules.swagger.SwaggerPlugin. Classes must have either one (and only one) constructor annotated with @Inject or a zero-argument constructor that is not private.
  2. 0

    GitHub comment 9#139847324

    GitHub | 1 year ago | kbenhdech
    play.api.UnexpectedException: Unexpected exception[ConfigurationException: Guice configuration errors: 1) Could not find a suitable constructor in play.modules.swagger.SwaggerPlugin. Classes must have either one (and only one) constructor annotated with @Inject or a zero-argument constructor that is not private.
  3. 0

    GitHub comment 73#138140088

    GitHub | 1 year ago | thepratt
    play.api.UnexpectedException: Unexpected exception[ConfigurationException: Guice configuration errors: 1) Could not find a suitable constructor in com.github.aselab.activerecord.ActiveRecordPlugin. Classes must have either one (and only one) constructor annotated with @Inject or a zero-argument constructor that is not private.
  4. Speed up your debug routine!

    Automated exception search integrated into your IDE

  5. 0

    Could not find a suitable constructor in play.api.db.slick.plugin.DatabaseManagementPlugin under Play 2.4.0-M1

    GitHub | 2 years ago | jaceklaskowski
    play.api.UnexpectedException: Unexpected exception[ConfigurationException: Guice configuration errors: 1) Could not find a suitable constructor in play.api.db.slick.plugin.DatabaseManagementPlugin. Classes must have either one (and only one) constructor annotated with @Inject or a zero-argument constructor that is not private.
  6. 0

    from 2.3 to 2.4 - guice error

    Google Groups | 8 months ago | Ugo Bourdon
    play.api.UnexpectedException: Unexpected exception[ConfigurationException: Guice configuration errors: 1) Could not find a suitable constructor in play.api.cache.EhCachePlugin. Classes must have either one (and only one) constructor annotated with @Inject or a zero-argument constructor that is not private.

    Not finding the right solution?
    Take a tour to get the most out of Samebug.

    Tired of useless tips?

    Automated exception search integrated into your IDE

    Root Cause Analysis

    1. play.api.UnexpectedException

      Unexpected exception[ConfigurationException: Guice configuration errors: 1) Could not find a suitable constructor in play.modules.swagger.SwaggerPlugin. Classes must have either one (and only one) constructor annotated with @Inject or a zero-argument constructor that is not private.

      at play.modules.swagger.SwaggerPlugin.class()
    2. play.modules.swagger
      SwaggerPlugin.class
      1. play.modules.swagger.SwaggerPlugin.class(SwaggerPlugin.scala:26)
      1 frame