java.lang.UnsupportedClassVersionError

JVMCFRE003 bad major version; class=io/github/benas/randombeans/api/EnhancedRandom, offset=6

Samebug tips2

Update "latest" to Java 8 on DockerHub.

You're using an older version of java with classes compiled for java7

Don't give up yet. Our experts can help. Paste your full stack trace to get a solution.

Solutions on the web4786

  • JVMCFRE003 bad major version; class=io/github/benas/randombeans/api/EnhancedRandom, offset=6
  • JVMCFRE003 bad major version; class=RunExport, offset=6
  • via Coderanch by Suraj Jadhav, 2 months ago
    JVMCFRE003 bad major version; class=com/..., offset=6
  • Stack trace

    • java.lang.UnsupportedClassVersionError: JVMCFRE003 bad major version; class=io/github/benas/randombeans/api/EnhancedRandom, offset=6 at java.lang.ClassLoader.defineClass(ClassLoader.java:324) at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:155) at java.net.URLClassLoader.defineClass(URLClassLoader.java:712) at java.net.URLClassLoader.access$400(URLClassLoader.java:93) at java.net.URLClassLoader$ClassFinder.run(URLClassLoader.java:1164) at java.security.AccessController.doPrivileged(AccessController.java:492) at java.net.URLClassLoader.findClass(URLClassLoader.java:595) at java.lang.ClassLoader.loadClassHelper(ClassLoader.java:777) at java.lang.ClassLoader.loadClass(ClassLoader.java:750) at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:326) at java.lang.ClassLoader.loadClass(ClassLoader.java:731)

    Write tip

    You have a different solution? A short tip here would help you and many other users who saw this issue last week.

    Users with the same issue

    Once, 1 month ago
    Unknown user
    Once, 3 months ago
    2 times, 3 months ago
    Unknown user
    Once, 6 months ago
    Once, 7 months ago
    63 more bugmates