java.lang.IllegalArgumentException: invalid qualifier: 5 (Apple Git-26)

Appcelerator JIRA | Ingo Muschenetz | 5 years ago
  1. Speed up your debug routine!

    Automated exception search integrated into your IDE

  2. 0

    module version number

    terracotta.org | 1 year ago
    org.osgi.framework.BundleException: Invalid module specification: name=my-module, version=2.6.0RC1-SNAPSHOT, groupId=my.project

    Not finding the right solution?
    Take a tour to get the most out of Samebug.

    Tired of useless tips?

    Automated exception search integrated into your IDE

    Root Cause Analysis

    1. java.lang.IllegalArgumentException

      invalid qualifier: 5 (Apple Git-26)

      at org.osgi.framework.Version.validate()
    2. OSGi
      Version.parseVersion
      1. org.osgi.framework.Version.validate(Version.java:195)
      2. org.osgi.framework.Version.<init>(Version.java:161)
      3. org.osgi.framework.Version.parseVersion(Version.java:225)
      3 frames
    3. com.aptana.git
      CloneJob.run
      1. com.aptana.git.core.model.GitExecutable.version(GitExecutable.java:399)
      2. com.aptana.git.core.model.GitExecutable.clone(GitExecutable.java:431)
      3. com.aptana.git.ui.CloneJob.run(CloneJob.java:86)
      3 frames
    4. Eclipse Jobs
      Worker.run
      1. org.eclipse.core.internal.jobs.Worker.run(Worker.java:54)
      1 frame