sbt.ResolveException: unresolved dependency: com.eed3si9n#sbt-assembly;0.9.1: not found unresolved dependency: com.github.mpeltonen#sbt-idea;1.6.0: not found

JIRA | Sean Farrell | 2 years ago
  1. 0

    Hi, I know this is an issue that others have faced a number of times, but none of the posted solutions have worked for me. I am unable to build SparkR behind my proxy with either sbt or maven. I have tried building it in R from github using the devtools library, and have also tried cloning the github repository and building outside of R. I have also tried building it with the USE_MAVEN=1 option. I have installed sbt v0.13.6 via yum and it appears to be running correctly (with SBT_OPTS and JAVA_OPTS set to include my http and https proxy settings and authentication details, and also with http_proxy and https_proxy settings set). I have also modified the build.sbt file to reflect my specific versions of Spark, Hadoop and Scala. I attempt to build SparkR in the SparkR-pkg directory after cloning github: SPARK_VERSION=1.2.0 SPARK_HADOOP_VERSION=2.5.0-cdh5.3.1 ./install-dev.sh * installing *source* package âSparkRâ ... ** libs ** arch - ./sbt/sbt assembly Launching sbt from sbt/sbt-launch-0.13.6.jar [info] Loading project definition from /data/tmp/temp/SparkR-pkg/pkg/src/project [info] Updating {file:/data/tmp/temp/SparkR-pkg/pkg/src/project/}src-build... [info] Resolving com.eed3si9n#sbt-assembly;0.9.1 ... [error] Unable to find credentials for [DISH Corporate Proxy 3 @ proxy03.corp.f7]. [warn] Your proxy requires authentication. [error] Unable to find credentials for [DISH Corporate Proxy 3 @ proxy03.corp.f7]. [warn] Your proxy requires authentication. [error] Unable to find credentials for [DISH Corporate Proxy 3 @ proxy03.corp.f7]. [warn] Your proxy requires authentication. [error] Unable to find credentials for [DISH Corporate Proxy 3 @ proxy03.corp.f7]. [warn] Your proxy requires authentication. [warn] module not found: com.eed3si9n#sbt-assembly;0.9.1 [warn] ==== typesafe-ivy-releases: tried [warn] https://repo.typesafe.com/typesafe/ivy-releases/com.eed3si9n/sbt-assembly/scala_2.10/sbt_0.13/0.9.1/ivys/ivy.xml [warn] ==== sbt-plugin-releases: tried [warn] https://repo.scala-sbt.org/scalasbt/sbt-plugin-releases/com.eed3si9n/sbt-assembly/scala_2.10/sbt_0.13/0.9.1/ivys/ivy.xml [warn] ==== local: tried [warn] /root/.ivy2/local/com.eed3si9n/sbt-assembly/scala_2.10/sbt_0.13/0.9.1/ivys/ivy.xml [warn] ==== public: tried [warn] https://repo1.maven.org/maven2/com/eed3si9n/sbt-assembly_2.10_0.13/0.9.1/sbt-assembly-0.9.1.pom [warn] ==== Sonatype snapshots: tried [warn] http://oss.sonatype.org/content/repositories/snapshots/com/eed3si9n/sbt-assembly_2.10_0.13/0.9.1/sbt-assembly-0.9.1.pom [info] Resolving com.github.mpeltonen#sbt-idea;1.6.0 ... [error] Unable to find credentials for [DISH Corporate Proxy 3 @ proxy03.corp.f7]. [warn] Your proxy requires authentication. [error] Unable to find credentials for [DISH Corporate Proxy 3 @ proxy03.corp.f7]. [warn] Your proxy requires authentication. [error] Unable to find credentials for [DISH Corporate Proxy 3 @ proxy03.corp.f7]. [warn] Your proxy requires authentication. [error] Unable to find credentials for [DISH Corporate Proxy 3 @ proxy03.corp.f7]. [warn] Your proxy requires authentication. [warn] module not found: com.github.mpeltonen#sbt-idea;1.6.0 [warn] ==== typesafe-ivy-releases: tried [warn] https://repo.typesafe.com/typesafe/ivy-releases/com.github.mpeltonen/sbt-idea/scala_2.10/sbt_0.13/1.6.0/ivys/ivy.xml [warn] ==== sbt-plugin-releases: tried [warn] https://repo.scala-sbt.org/scalasbt/sbt-plugin-releases/com.github.mpeltonen/sbt-idea/scala_2.10/sbt_0.13/1.6.0/ivys/ivy.xml [warn] ==== local: tried [warn] /root/.ivy2/local/com.github.mpeltonen/sbt-idea/scala_2.10/sbt_0.13/1.6.0/ivys/ivy.xml [warn] ==== public: tried [warn] https://repo1.maven.org/maven2/com/github/mpeltonen/sbt-idea_2.10_0.13/1.6.0/sbt-idea-1.6.0.pom [warn] ==== Sonatype snapshots: tried [warn] http://oss.sonatype.org/content/repositories/snapshots/com/github/mpeltonen/sbt-idea_2.10_0.13/1.6.0/sbt-idea-1.6.0.pom [info] Resolving org.fusesource.jansi#jansi;1.4 ... [warn] :::::::::::::::::::::::::::::::::::::::::::::: [warn] :: UNRESOLVED DEPENDENCIES :: [warn] :::::::::::::::::::::::::::::::::::::::::::::: [warn] :: com.eed3si9n#sbt-assembly;0.9.1: not found [warn] :: com.github.mpeltonen#sbt-idea;1.6.0: not found [warn] :::::::::::::::::::::::::::::::::::::::::::::: [warn] [warn] Note: Some unresolved dependencies have extra attributes. Check that these dependencies exist with the requested attributes. [warn] com.eed3si9n:sbt-assembly:0.9.1 (sbtVersion=0.13, scalaVersion=2.10) [warn] com.github.mpeltonen:sbt-idea:1.6.0 (sbtVersion=0.13, scalaVersion=2.10) [warn] [warn] Note: Unresolved dependencies path: [warn] com.eed3si9n:sbt-assembly:0.9.1 (sbtVersion=0.13, scalaVersion=2.10) (/data/tmp/temp/SparkR-pkg/pkg/src/project/plugins.sbt#L3-4) [warn] +- default:src-build:0.1-SNAPSHOT (sbtVersion=0.13, scalaVersion=2.10) [warn] com.github.mpeltonen:sbt-idea:1.6.0 (sbtVersion=0.13, scalaVersion=2.10) (/data/tmp/temp/SparkR-pkg/pkg/src/project/plugins.sbt#L5-6) [warn] +- default:src-build:0.1-SNAPSHOT (sbtVersion=0.13, scalaVersion=2.10) sbt.ResolveException: unresolved dependency: com.eed3si9n#sbt-assembly;0.9.1: not found unresolved dependency: com.github.mpeltonen#sbt-idea;1.6.0: not found at sbt.IvyActions$.sbt$IvyActions$$resolve(IvyActions.scala:243) at sbt.IvyActions$$anonfun$updateEither$1.apply(IvyActions.scala:158) at sbt.IvyActions$$anonfun$updateEither$1.apply(IvyActions.scala:156) at sbt.IvySbt$Module$$anonfun$withModule$1.apply(Ivy.scala:147) at sbt.IvySbt$Module$$anonfun$withModule$1.apply(Ivy.scala:147) at sbt.IvySbt$$anonfun$withIvy$1.apply(Ivy.scala:124) at sbt.IvySbt.sbt$IvySbt$$action$1(Ivy.scala:56) at sbt.IvySbt$$anon$3.call(Ivy.scala:64) at xsbt.boot.Locks$GlobalLock.withChannel$1(Locks.scala:93) at xsbt.boot.Locks$GlobalLock.xsbt$boot$Locks$GlobalLock$$withChannelRetries$1(Locks.scala:78) at xsbt.boot.Locks$GlobalLock$$anonfun$withFileLock$1.apply(Locks.scala:97) at xsbt.boot.Using$.withResource(Using.scala:10) at xsbt.boot.Using$.apply(Using.scala:9) at xsbt.boot.Locks$GlobalLock.ignoringDeadlockAvoided(Locks.scala:58) at xsbt.boot.Locks$GlobalLock.withLock(Locks.scala:48) at xsbt.boot.Locks$.apply0(Locks.scala:31) at xsbt.boot.Locks$.apply(Locks.scala:28) at sbt.IvySbt.withDefaultLogger(Ivy.scala:64) at sbt.IvySbt.withIvy(Ivy.scala:119) at sbt.IvySbt.withIvy(Ivy.scala:116) at sbt.IvySbt$Module.withModule(Ivy.scala:147) at sbt.IvyActions$.updateEither(IvyActions.scala:156) at sbt.Classpaths$$anonfun$sbt$Classpaths$$work$1$1.apply(Defaults.scala:1282) at sbt.Classpaths$$anonfun$sbt$Classpaths$$work$1$1.apply(Defaults.scala:1279) at sbt.Classpaths$$anonfun$doWork$1$1$$anonfun$84.apply(Defaults.scala:1309) at sbt.Classpaths$$anonfun$doWork$1$1$$anonfun$84.apply(Defaults.scala:1307) at sbt.Tracked$$anonfun$lastOutput$1.apply(Tracked.scala:35) at sbt.Classpaths$$anonfun$doWork$1$1.apply(Defaults.scala:1312) at sbt.Classpaths$$anonfun$doWork$1$1.apply(Defaults.scala:1306) at sbt.Tracked$$anonfun$inputChanged$1.apply(Tracked.scala:45) at sbt.Classpaths$.cachedUpdate(Defaults.scala:1324) at sbt.Classpaths$$anonfun$updateTask$1.apply(Defaults.scala:1264) at sbt.Classpaths$$anonfun$updateTask$1.apply(Defaults.scala:1242) at scala.Function1$$anonfun$compose$1.apply(Function1.scala:47) at sbt.$tilde$greater$$anonfun$$u2219$1.apply(TypeFunctions.scala:40) at sbt.std.Transform$$anon$4.work(System.scala:63) at sbt.Execute$$anonfun$submit$1$$anonfun$apply$1.apply(Execute.scala:226) at sbt.Execute$$anonfun$submit$1$$anonfun$apply$1.apply(Execute.scala:226) at sbt.ErrorHandling$.wideConvert(ErrorHandling.scala:17) at sbt.Execute.work(Execute.scala:235) at sbt.Execute$$anonfun$submit$1.apply(Execute.scala:226) at sbt.Execute$$anonfun$submit$1.apply(Execute.scala:226) at sbt.ConcurrentRestrictions$$anon$4$$anonfun$1.apply(ConcurrentRestrictions.scala:159) at sbt.CompletionService$$anon$2.call(CompletionService.scala:28) at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303) at java.util.concurrent.FutureTask.run(FutureTask.java:138) at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:441) at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303) at java.util.concurrent.FutureTask.run(FutureTask.java:138) at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886) at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908) at java.lang.Thread.run(Thread.java:662) [error] (*:update) sbt.ResolveException: unresolved dependency: com.eed3si9n#sbt-assembly;0.9.1: not found [error] unresolved dependency: com.github.mpeltonen#sbt-idea;1.6.0: not found Project loading failed: (r)etry, (q)uit, (l)ast, or (i)gnore? make: *** [target/scala-2.10/sparkr-assembly-0.1.jar] Error 1 ERROR: compilation failed for package âSparkRâ * removing â/data/tmp/temp/SparkR-pkg/lib/SparkRâ I then attempted to build with Maven: SPARK_VERSION=1.2.0 SPARK_HADOOP_VERSION=2.5.0-cdh5.3.1 USE_MAVEN=1 ./install-dev.sh * installing *source* package âSparkRâ ... ** libs ** arch - mvn -Dhadoop.version=2.5.0-cdh5.3.1 -Dspark.version=1.2.0 -DskipTests -Dyarn.version=2.4.0 clean package shade:shade [INFO] Scanning for projects... [WARNING] [WARNING] Some problems were encountered while building the effective model for edu.berkeley.cs.amplab:sparkr:jar:0.1 [WARNING] 'build.plugins.plugin.version' for org.apache.maven.plugins:maven-source-plugin-1.0 is missing. @ line 329, column 15 [WARNING] [WARNING] It is highly recommended to fix these problems because they threaten the stability of your build. [WARNING] [WARNING] For this reason, future Maven versions might no longer support building such malformed projects. [WARNING] Downloading: http://scala-tools.org/repo-releases/org/apache/maven/plugins/maven-source-plugin-1.0/maven-metadata.xml Downloading: https://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-source-plugin-1.0/maven-metadata.xml [WARNING] Could not transfer metadata org.apache.maven.plugins:maven-source-plugin-1.0/maven-metadata.xml from/to scala (http://scala-tools.org/repo-releases/): @proxy03.corp.f7 [WARNING] Could not transfer metadata org.apache.maven.plugins:maven-source-plugin-1.0/maven-metadata.xml from/to central (https://repo.maven.apache.org/maven2): @proxy03.corp.f7: Name or service not known [INFO] ------------------------------------------------------------------------ [INFO] BUILD FAILURE [INFO] ------------------------------------------------------------------------ [INFO] Total time: 0.507 s [INFO] Finished at: 2015-02-24T15:08:22+11:00 [INFO] Final Memory: 15M/449M [INFO] ------------------------------------------------------------------------ [ERROR] Error resolving version for plugin 'org.apache.maven.plugins:maven-source-plugin-1.0' from the repositories [local (/root/.m2/repository), scala (http://scala-tools.org/repo-releases/), central (https://repo.maven.apache.org/maven2)]: Plugin not found in any plugin repository -> [Help 1] [ERROR] [ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch. [ERROR] Re-run Maven using the -X switch to enable full debug logging. [ERROR] [ERROR] For more information about the errors and possible solutions, please read the following articles: [ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/PluginVersionResolutionException make: *** [target/sparkr-0.1-assembly.jar] Error 1 ERROR: compilation failed for package âSparkRâ * removing â/data/tmp/temp/SparkR-pkg/lib/SparkRâ Please help, this is driving me nuts.

    JIRA | 2 years ago | Sean Farrell
    sbt.ResolveException: unresolved dependency: com.eed3si9n#sbt-assembly;0.9.1: not found unresolved dependency: com.github.mpeltonen#sbt-idea;1.6.0: not found
  2. 0

    Hi, I know this is an issue that others have faced a number of times, but none of the posted solutions have worked for me. I am unable to build SparkR behind my proxy with either sbt or maven. I have tried building it in R from github using the devtools library, and have also tried cloning the github repository and building outside of R. I have also tried building it with the USE_MAVEN=1 option. I have installed sbt v0.13.6 via yum and it appears to be running correctly (with SBT_OPTS and JAVA_OPTS set to include my http and https proxy settings and authentication details, and also with http_proxy and https_proxy settings set). I have also modified the build.sbt file to reflect my specific versions of Spark, Hadoop and Scala. I attempt to build SparkR in the SparkR-pkg directory after cloning github: SPARK_VERSION=1.2.0 SPARK_HADOOP_VERSION=2.5.0-cdh5.3.1 ./install-dev.sh * installing *source* package âSparkRâ ... ** libs ** arch - ./sbt/sbt assembly Launching sbt from sbt/sbt-launch-0.13.6.jar [info] Loading project definition from /data/tmp/temp/SparkR-pkg/pkg/src/project [info] Updating {file:/data/tmp/temp/SparkR-pkg/pkg/src/project/}src-build... [info] Resolving com.eed3si9n#sbt-assembly;0.9.1 ... [error] Unable to find credentials for [DISH Corporate Proxy 3 @ proxy03.corp.f7]. [warn] Your proxy requires authentication. [error] Unable to find credentials for [DISH Corporate Proxy 3 @ proxy03.corp.f7]. [warn] Your proxy requires authentication. [error] Unable to find credentials for [DISH Corporate Proxy 3 @ proxy03.corp.f7]. [warn] Your proxy requires authentication. [error] Unable to find credentials for [DISH Corporate Proxy 3 @ proxy03.corp.f7]. [warn] Your proxy requires authentication. [warn] module not found: com.eed3si9n#sbt-assembly;0.9.1 [warn] ==== typesafe-ivy-releases: tried [warn] https://repo.typesafe.com/typesafe/ivy-releases/com.eed3si9n/sbt-assembly/scala_2.10/sbt_0.13/0.9.1/ivys/ivy.xml [warn] ==== sbt-plugin-releases: tried [warn] https://repo.scala-sbt.org/scalasbt/sbt-plugin-releases/com.eed3si9n/sbt-assembly/scala_2.10/sbt_0.13/0.9.1/ivys/ivy.xml [warn] ==== local: tried [warn] /root/.ivy2/local/com.eed3si9n/sbt-assembly/scala_2.10/sbt_0.13/0.9.1/ivys/ivy.xml [warn] ==== public: tried [warn] https://repo1.maven.org/maven2/com/eed3si9n/sbt-assembly_2.10_0.13/0.9.1/sbt-assembly-0.9.1.pom [warn] ==== Sonatype snapshots: tried [warn] http://oss.sonatype.org/content/repositories/snapshots/com/eed3si9n/sbt-assembly_2.10_0.13/0.9.1/sbt-assembly-0.9.1.pom [info] Resolving com.github.mpeltonen#sbt-idea;1.6.0 ... [error] Unable to find credentials for [DISH Corporate Proxy 3 @ proxy03.corp.f7]. [warn] Your proxy requires authentication. [error] Unable to find credentials for [DISH Corporate Proxy 3 @ proxy03.corp.f7]. [warn] Your proxy requires authentication. [error] Unable to find credentials for [DISH Corporate Proxy 3 @ proxy03.corp.f7]. [warn] Your proxy requires authentication. [error] Unable to find credentials for [DISH Corporate Proxy 3 @ proxy03.corp.f7]. [warn] Your proxy requires authentication. [warn] module not found: com.github.mpeltonen#sbt-idea;1.6.0 [warn] ==== typesafe-ivy-releases: tried [warn] https://repo.typesafe.com/typesafe/ivy-releases/com.github.mpeltonen/sbt-idea/scala_2.10/sbt_0.13/1.6.0/ivys/ivy.xml [warn] ==== sbt-plugin-releases: tried [warn] https://repo.scala-sbt.org/scalasbt/sbt-plugin-releases/com.github.mpeltonen/sbt-idea/scala_2.10/sbt_0.13/1.6.0/ivys/ivy.xml [warn] ==== local: tried [warn] /root/.ivy2/local/com.github.mpeltonen/sbt-idea/scala_2.10/sbt_0.13/1.6.0/ivys/ivy.xml [warn] ==== public: tried [warn] https://repo1.maven.org/maven2/com/github/mpeltonen/sbt-idea_2.10_0.13/1.6.0/sbt-idea-1.6.0.pom [warn] ==== Sonatype snapshots: tried [warn] http://oss.sonatype.org/content/repositories/snapshots/com/github/mpeltonen/sbt-idea_2.10_0.13/1.6.0/sbt-idea-1.6.0.pom [info] Resolving org.fusesource.jansi#jansi;1.4 ... [warn] :::::::::::::::::::::::::::::::::::::::::::::: [warn] :: UNRESOLVED DEPENDENCIES :: [warn] :::::::::::::::::::::::::::::::::::::::::::::: [warn] :: com.eed3si9n#sbt-assembly;0.9.1: not found [warn] :: com.github.mpeltonen#sbt-idea;1.6.0: not found [warn] :::::::::::::::::::::::::::::::::::::::::::::: [warn] [warn] Note: Some unresolved dependencies have extra attributes. Check that these dependencies exist with the requested attributes. [warn] com.eed3si9n:sbt-assembly:0.9.1 (sbtVersion=0.13, scalaVersion=2.10) [warn] com.github.mpeltonen:sbt-idea:1.6.0 (sbtVersion=0.13, scalaVersion=2.10) [warn] [warn] Note: Unresolved dependencies path: [warn] com.eed3si9n:sbt-assembly:0.9.1 (sbtVersion=0.13, scalaVersion=2.10) (/data/tmp/temp/SparkR-pkg/pkg/src/project/plugins.sbt#L3-4) [warn] +- default:src-build:0.1-SNAPSHOT (sbtVersion=0.13, scalaVersion=2.10) [warn] com.github.mpeltonen:sbt-idea:1.6.0 (sbtVersion=0.13, scalaVersion=2.10) (/data/tmp/temp/SparkR-pkg/pkg/src/project/plugins.sbt#L5-6) [warn] +- default:src-build:0.1-SNAPSHOT (sbtVersion=0.13, scalaVersion=2.10) sbt.ResolveException: unresolved dependency: com.eed3si9n#sbt-assembly;0.9.1: not found unresolved dependency: com.github.mpeltonen#sbt-idea;1.6.0: not found at sbt.IvyActions$.sbt$IvyActions$$resolve(IvyActions.scala:243) at sbt.IvyActions$$anonfun$updateEither$1.apply(IvyActions.scala:158) at sbt.IvyActions$$anonfun$updateEither$1.apply(IvyActions.scala:156) at sbt.IvySbt$Module$$anonfun$withModule$1.apply(Ivy.scala:147) at sbt.IvySbt$Module$$anonfun$withModule$1.apply(Ivy.scala:147) at sbt.IvySbt$$anonfun$withIvy$1.apply(Ivy.scala:124) at sbt.IvySbt.sbt$IvySbt$$action$1(Ivy.scala:56) at sbt.IvySbt$$anon$3.call(Ivy.scala:64) at xsbt.boot.Locks$GlobalLock.withChannel$1(Locks.scala:93) at xsbt.boot.Locks$GlobalLock.xsbt$boot$Locks$GlobalLock$$withChannelRetries$1(Locks.scala:78) at xsbt.boot.Locks$GlobalLock$$anonfun$withFileLock$1.apply(Locks.scala:97) at xsbt.boot.Using$.withResource(Using.scala:10) at xsbt.boot.Using$.apply(Using.scala:9) at xsbt.boot.Locks$GlobalLock.ignoringDeadlockAvoided(Locks.scala:58) at xsbt.boot.Locks$GlobalLock.withLock(Locks.scala:48) at xsbt.boot.Locks$.apply0(Locks.scala:31) at xsbt.boot.Locks$.apply(Locks.scala:28) at sbt.IvySbt.withDefaultLogger(Ivy.scala:64) at sbt.IvySbt.withIvy(Ivy.scala:119) at sbt.IvySbt.withIvy(Ivy.scala:116) at sbt.IvySbt$Module.withModule(Ivy.scala:147) at sbt.IvyActions$.updateEither(IvyActions.scala:156) at sbt.Classpaths$$anonfun$sbt$Classpaths$$work$1$1.apply(Defaults.scala:1282) at sbt.Classpaths$$anonfun$sbt$Classpaths$$work$1$1.apply(Defaults.scala:1279) at sbt.Classpaths$$anonfun$doWork$1$1$$anonfun$84.apply(Defaults.scala:1309) at sbt.Classpaths$$anonfun$doWork$1$1$$anonfun$84.apply(Defaults.scala:1307) at sbt.Tracked$$anonfun$lastOutput$1.apply(Tracked.scala:35) at sbt.Classpaths$$anonfun$doWork$1$1.apply(Defaults.scala:1312) at sbt.Classpaths$$anonfun$doWork$1$1.apply(Defaults.scala:1306) at sbt.Tracked$$anonfun$inputChanged$1.apply(Tracked.scala:45) at sbt.Classpaths$.cachedUpdate(Defaults.scala:1324) at sbt.Classpaths$$anonfun$updateTask$1.apply(Defaults.scala:1264) at sbt.Classpaths$$anonfun$updateTask$1.apply(Defaults.scala:1242) at scala.Function1$$anonfun$compose$1.apply(Function1.scala:47) at sbt.$tilde$greater$$anonfun$$u2219$1.apply(TypeFunctions.scala:40) at sbt.std.Transform$$anon$4.work(System.scala:63) at sbt.Execute$$anonfun$submit$1$$anonfun$apply$1.apply(Execute.scala:226) at sbt.Execute$$anonfun$submit$1$$anonfun$apply$1.apply(Execute.scala:226) at sbt.ErrorHandling$.wideConvert(ErrorHandling.scala:17) at sbt.Execute.work(Execute.scala:235) at sbt.Execute$$anonfun$submit$1.apply(Execute.scala:226) at sbt.Execute$$anonfun$submit$1.apply(Execute.scala:226) at sbt.ConcurrentRestrictions$$anon$4$$anonfun$1.apply(ConcurrentRestrictions.scala:159) at sbt.CompletionService$$anon$2.call(CompletionService.scala:28) at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303) at java.util.concurrent.FutureTask.run(FutureTask.java:138) at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:441) at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303) at java.util.concurrent.FutureTask.run(FutureTask.java:138) at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886) at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908) at java.lang.Thread.run(Thread.java:662) [error] (*:update) sbt.ResolveException: unresolved dependency: com.eed3si9n#sbt-assembly;0.9.1: not found [error] unresolved dependency: com.github.mpeltonen#sbt-idea;1.6.0: not found Project loading failed: (r)etry, (q)uit, (l)ast, or (i)gnore? make: *** [target/scala-2.10/sparkr-assembly-0.1.jar] Error 1 ERROR: compilation failed for package âSparkRâ * removing â/data/tmp/temp/SparkR-pkg/lib/SparkRâ I then attempted to build with Maven: SPARK_VERSION=1.2.0 SPARK_HADOOP_VERSION=2.5.0-cdh5.3.1 USE_MAVEN=1 ./install-dev.sh * installing *source* package âSparkRâ ... ** libs ** arch - mvn -Dhadoop.version=2.5.0-cdh5.3.1 -Dspark.version=1.2.0 -DskipTests -Dyarn.version=2.4.0 clean package shade:shade [INFO] Scanning for projects... [WARNING] [WARNING] Some problems were encountered while building the effective model for edu.berkeley.cs.amplab:sparkr:jar:0.1 [WARNING] 'build.plugins.plugin.version' for org.apache.maven.plugins:maven-source-plugin-1.0 is missing. @ line 329, column 15 [WARNING] [WARNING] It is highly recommended to fix these problems because they threaten the stability of your build. [WARNING] [WARNING] For this reason, future Maven versions might no longer support building such malformed projects. [WARNING] Downloading: http://scala-tools.org/repo-releases/org/apache/maven/plugins/maven-source-plugin-1.0/maven-metadata.xml Downloading: https://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-source-plugin-1.0/maven-metadata.xml [WARNING] Could not transfer metadata org.apache.maven.plugins:maven-source-plugin-1.0/maven-metadata.xml from/to scala (http://scala-tools.org/repo-releases/): @proxy03.corp.f7 [WARNING] Could not transfer metadata org.apache.maven.plugins:maven-source-plugin-1.0/maven-metadata.xml from/to central (https://repo.maven.apache.org/maven2): @proxy03.corp.f7: Name or service not known [INFO] ------------------------------------------------------------------------ [INFO] BUILD FAILURE [INFO] ------------------------------------------------------------------------ [INFO] Total time: 0.507 s [INFO] Finished at: 2015-02-24T15:08:22+11:00 [INFO] Final Memory: 15M/449M [INFO] ------------------------------------------------------------------------ [ERROR] Error resolving version for plugin 'org.apache.maven.plugins:maven-source-plugin-1.0' from the repositories [local (/root/.m2/repository), scala (http://scala-tools.org/repo-releases/), central (https://repo.maven.apache.org/maven2)]: Plugin not found in any plugin repository -> [Help 1] [ERROR] [ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch. [ERROR] Re-run Maven using the -X switch to enable full debug logging. [ERROR] [ERROR] For more information about the errors and possible solutions, please read the following articles: [ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/PluginVersionResolutionException make: *** [target/sparkr-0.1-assembly.jar] Error 1 ERROR: compilation failed for package âSparkRâ * removing â/data/tmp/temp/SparkR-pkg/lib/SparkRâ Please help, this is driving me nuts.

    JIRA | 2 years ago | Sean Farrell
    sbt.ResolveException: unresolved dependency: com.eed3si9n#sbt-assembly;0.9.1: not found unresolved dependency: com.github.mpeltonen#sbt-idea;1.6.0: not found
  3. 0

    Cannot resolve dependency for 0.24 com.rockymadden.stringmetric#stringmetric-core_2.10;0.27.4: not found

    GitHub | 2 years ago | soumyasd
    sbt.ResolveException: unresolved dependency: com.rockymadden.stringmetric#stringmetric-core_2.10;0.27.4: not found
  4. Speed up your debug routine!

    Automated exception search integrated into your IDE

  5. 0

    Can't even use the examples

    GitHub | 3 years ago | NobbZ
    sbt.ResolveException: unresolved dependency: org.seacourt.build#sbt-cpp;0.0.27: not found
  6. 0

    build process of Play requires version

    GitHub | 3 years ago | letnotimitateothers
    sbt.ResolveException: unresolved dependency: com.typesafe.play#sbt-plugin;2.2-TLS: not found

    8 unregistered visitors
    Not finding the right solution?
    Take a tour to get the most out of Samebug.

    Tired of useless tips?

    Automated exception search integrated into your IDE

    Root Cause Analysis

    1. sbt.ResolveException

      unresolved dependency: com.eed3si9n#sbt-assembly;0.9.1: not found unresolved dependency: com.github.mpeltonen#sbt-idea;1.6.0: not found

      at sbt.IvyActions$.sbt$IvyActions$$resolve()
    2. SBT
      IvySbt$$anon$3.call
      1. sbt.IvyActions$.sbt$IvyActions$$resolve(IvyActions.scala:243)
      2. sbt.IvyActions$$anonfun$updateEither$1.apply(IvyActions.scala:158)
      3. sbt.IvyActions$$anonfun$updateEither$1.apply(IvyActions.scala:156)
      4. sbt.IvySbt$Module$$anonfun$withModule$1.apply(Ivy.scala:147)
      5. sbt.IvySbt$Module$$anonfun$withModule$1.apply(Ivy.scala:147)
      6. sbt.IvySbt$$anonfun$withIvy$1.apply(Ivy.scala:124)
      7. sbt.IvySbt.sbt$IvySbt$$action$1(Ivy.scala:56)
      8. sbt.IvySbt$$anon$3.call(Ivy.scala:64)
      8 frames
    3. SBT Launcher
      Locks$.apply
      1. xsbt.boot.Locks$GlobalLock.withChannel$1(Locks.scala:93)
      2. xsbt.boot.Locks$GlobalLock.xsbt$boot$Locks$GlobalLock$$withChannelRetries$1(Locks.scala:78)
      3. xsbt.boot.Locks$GlobalLock$$anonfun$withFileLock$1.apply(Locks.scala:97)
      4. xsbt.boot.Using$.withResource(Using.scala:10)
      5. xsbt.boot.Using$.apply(Using.scala:9)
      6. xsbt.boot.Locks$GlobalLock.ignoringDeadlockAvoided(Locks.scala:58)
      7. xsbt.boot.Locks$GlobalLock.withLock(Locks.scala:48)
      8. xsbt.boot.Locks$.apply0(Locks.scala:31)
      9. xsbt.boot.Locks$.apply(Locks.scala:28)
      9 frames
    4. SBT
      Classpaths$$anonfun$updateTask$1.apply
      1. sbt.IvySbt.withDefaultLogger(Ivy.scala:64)
      2. sbt.IvySbt.withIvy(Ivy.scala:119)
      3. sbt.IvySbt.withIvy(Ivy.scala:116)
      4. sbt.IvySbt$Module.withModule(Ivy.scala:147)
      5. sbt.IvyActions$.updateEither(IvyActions.scala:156)
      6. sbt.Classpaths$$anonfun$sbt$Classpaths$$work$1$1.apply(Defaults.scala:1282)
      7. sbt.Classpaths$$anonfun$sbt$Classpaths$$work$1$1.apply(Defaults.scala:1279)
      8. sbt.Classpaths$$anonfun$doWork$1$1$$anonfun$84.apply(Defaults.scala:1309)
      9. sbt.Classpaths$$anonfun$doWork$1$1$$anonfun$84.apply(Defaults.scala:1307)
      10. sbt.Tracked$$anonfun$lastOutput$1.apply(Tracked.scala:35)
      11. sbt.Classpaths$$anonfun$doWork$1$1.apply(Defaults.scala:1312)
      12. sbt.Classpaths$$anonfun$doWork$1$1.apply(Defaults.scala:1306)
      13. sbt.Tracked$$anonfun$inputChanged$1.apply(Tracked.scala:45)
      14. sbt.Classpaths$.cachedUpdate(Defaults.scala:1324)
      15. sbt.Classpaths$$anonfun$updateTask$1.apply(Defaults.scala:1264)
      16. sbt.Classpaths$$anonfun$updateTask$1.apply(Defaults.scala:1242)
      16 frames
    5. Scala
      Function1$$anonfun$compose$1.apply
      1. scala.Function1$$anonfun$compose$1.apply(Function1.scala:47)
      1 frame
    6. SBT
      $tilde$greater$$anonfun$$u2219$1.apply
      1. sbt.$tilde$greater$$anonfun$$u2219$1.apply(TypeFunctions.scala:40)
      1 frame
    7. sbt Task system
      Transform$$anon$4.work
      1. sbt.std.Transform$$anon$4.work(System.scala:63)
      1 frame
    8. SBT
      CompletionService$$anon$2.call
      1. sbt.Execute$$anonfun$submit$1$$anonfun$apply$1.apply(Execute.scala:226)
      2. sbt.Execute$$anonfun$submit$1$$anonfun$apply$1.apply(Execute.scala:226)
      3. sbt.ErrorHandling$.wideConvert(ErrorHandling.scala:17)
      4. sbt.Execute.work(Execute.scala:235)
      5. sbt.Execute$$anonfun$submit$1.apply(Execute.scala:226)
      6. sbt.Execute$$anonfun$submit$1.apply(Execute.scala:226)
      7. sbt.ConcurrentRestrictions$$anon$4$$anonfun$1.apply(ConcurrentRestrictions.scala:159)
      8. sbt.CompletionService$$anon$2.call(CompletionService.scala:28)
      8 frames
    9. Java RT
      Thread.run
      1. java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
      2. java.util.concurrent.FutureTask.run(FutureTask.java:138)
      3. java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:441)
      4. java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
      5. java.util.concurrent.FutureTask.run(FutureTask.java:138)
      6. java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
      7. java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
      8. java.lang.Thread.run(Thread.java:662)
      8 frames