java.lang.Exception: Could not start bundle mvn:org.opennms.features.vaadin-dashlets/dashlet-charts/1.13.0-SNAPSHOT in feature(s) dashlet-charts-1.13.0-SNAPSHOT: Unresolved constraint in bundle org.opennms.features.vaadin-dashlets.dashlet-charts [95]: Unable to resolve 95.0: missing requirement [95.0] osgi.wiring.package; (&(osgi.wiring.package=org.opennms.web.charts)(version>=1.13.0)(!(version>=2.0.0)))

The OpenNMS Issue Tracker | Markus von Rüden | 3 years ago
  1. 0

    When starting opennms no opennms features will be installed by default. Even if it is configured. The karaf.log is showing an exception: 2013-08-01 09:40:42,977 | ERROR | Thread-54 | FeaturesServiceImpl | ? ? | 40 - org.apache.karaf.features.core - 2.3.1 | Error installing boot features java.lang.Exception: Could not start bundle mvn:org.opennms.features.vaadin-dashlets/dashlet-charts/1.13.0-SNAPSHOT in feature(s) dashlet-charts-1.13.0-SNAPSHOT: Unresolved constraint in bundle org.opennms.features.vaadin-dashlets.dashlet-charts [95]: Unable to resolve 95.0: missing requirement [95.0] osgi.wiring.package; (&(osgi.wiring.package=org.opennms.web.charts)(version>=1.13.0)(!(version>=2.0.0))) at org.apache.karaf.features.internal.FeaturesServiceImpl.installFeatures(FeaturesServiceImpl.java:482)[40:org.apache.karaf.features.core:2.3.1] at org.apache.karaf.features.internal.FeaturesServiceImpl$2.run(FeaturesServiceImpl.java:1150)[40:org.apache.karaf.features.core:2.3.1] Caused by: org.osgi.framework.BundleException: Unresolved constraint in bundle org.opennms.features.vaadin-dashlets.dashlet-charts [95]: Unable to resolve 95.0: missing requirement [95.0] osgi.wiring.package; (&(osgi.wiring.package=org.opennms.web.charts)(version>=1.13.0)(!(version>=2.0.0))) at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:3826)[org.apache.felix.framework-4.0.3.jar:] at org.apache.felix.framework.Felix.startBundle(Felix.java:1868)[org.apache.felix.framework-4.0.3.jar:] at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:944)[org.apache.felix.framework-4.0.3.jar:] at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:931)[org.apache.felix.framework-4.0.3.jar:] at org.apache.karaf.features.internal.FeaturesServiceImpl.installFeatures(FeaturesServiceImpl.java:479)[40:org.apache.karaf.features.core:2.3.1] ... 1 more If you don't get this exception, try removing your local .m2 repository (that is why I get this error now, because I removed my .m2 repository yesterday)

    The OpenNMS Issue Tracker | 3 years ago | Markus von Rüden
    java.lang.Exception: Could not start bundle mvn:org.opennms.features.vaadin-dashlets/dashlet-charts/1.13.0-SNAPSHOT in feature(s) dashlet-charts-1.13.0-SNAPSHOT: Unresolved constraint in bundle org.opennms.features.vaadin-dashlets.dashlet-charts [95]: Unable to resolve 95.0: missing requirement [95.0] osgi.wiring.package; (&(osgi.wiring.package=org.opennms.web.charts)(version>=1.13.0)(!(version>=2.0.0)))
  2. 0

    When starting opennms no opennms features will be installed by default. Even if it is configured. The karaf.log is showing an exception: 2013-08-01 09:40:42,977 | ERROR | Thread-54 | FeaturesServiceImpl | ? ? | 40 - org.apache.karaf.features.core - 2.3.1 | Error installing boot features java.lang.Exception: Could not start bundle mvn:org.opennms.features.vaadin-dashlets/dashlet-charts/1.13.0-SNAPSHOT in feature(s) dashlet-charts-1.13.0-SNAPSHOT: Unresolved constraint in bundle org.opennms.features.vaadin-dashlets.dashlet-charts [95]: Unable to resolve 95.0: missing requirement [95.0] osgi.wiring.package; (&(osgi.wiring.package=org.opennms.web.charts)(version>=1.13.0)(!(version>=2.0.0))) at org.apache.karaf.features.internal.FeaturesServiceImpl.installFeatures(FeaturesServiceImpl.java:482)[40:org.apache.karaf.features.core:2.3.1] at org.apache.karaf.features.internal.FeaturesServiceImpl$2.run(FeaturesServiceImpl.java:1150)[40:org.apache.karaf.features.core:2.3.1] Caused by: org.osgi.framework.BundleException: Unresolved constraint in bundle org.opennms.features.vaadin-dashlets.dashlet-charts [95]: Unable to resolve 95.0: missing requirement [95.0] osgi.wiring.package; (&(osgi.wiring.package=org.opennms.web.charts)(version>=1.13.0)(!(version>=2.0.0))) at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:3826)[org.apache.felix.framework-4.0.3.jar:] at org.apache.felix.framework.Felix.startBundle(Felix.java:1868)[org.apache.felix.framework-4.0.3.jar:] at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:944)[org.apache.felix.framework-4.0.3.jar:] at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:931)[org.apache.felix.framework-4.0.3.jar:] at org.apache.karaf.features.internal.FeaturesServiceImpl.installFeatures(FeaturesServiceImpl.java:479)[40:org.apache.karaf.features.core:2.3.1] ... 1 more If you don't get this exception, try removing your local .m2 repository (that is why I get this error now, because I removed my .m2 repository yesterday)

    The OpenNMS Issue Tracker | 3 years ago | Markus von Rüden
    java.lang.Exception: Could not start bundle mvn:org.opennms.features.vaadin-dashlets/dashlet-charts/1.13.0-SNAPSHOT in feature(s) dashlet-charts-1.13.0-SNAPSHOT: Unresolved constraint in bundle org.opennms.features.vaadin-dashlets.dashlet-charts [95]: Unable to resolve 95.0: missing requirement [95.0] osgi.wiring.package; (&(osgi.wiring.package=org.opennms.web.charts)(version>=1.13.0)(!(version>=2.0.0)))
  3. 0

    admaDIC Blog: JDK8: Unable to Resolve javax.swing ?

    admadic.com | 1 year ago
    org.osgi.framework.BundleException: Unresolved constraint in bundle example.swing1 [1]: Unable to resolve 1.0: missing requirement [1.0] osgi.wiring.package; (osgi.wiring.package=javax.swing)
  4. Speed up your debug routine!

    Automated exception search integrated into your IDE

  5. 0

    Bug 233443 – Update Felix: was NB 7.3.1 OSGI related tests fail with org.osgi.framework.BundleException on JDK 8

    netbeans.org | 2 months ago
    org.osgi.framework.BundleException: Unresolved constraint in bundle custom [3]: Unable to resolve 3.0: missing requirement [3.0] osgi.wiring.bundle; (osgi.wiring.bundle=org.netbeans.core.osgi) [caused by: Unable to resolve 18.0: missing requirement [18.0] osgi.wiring.package; (osgi.wiring.package=org.xml.sax)]
  6. 0

    admaDIC Blog

    admadic.com | 1 year ago
    org.osgi.framework.BundleException: Unresolved constraint in bundle example.swing1 [1]: Unable to resolve 1.0: missing requirement [1.0] osgi.wiring.package; (osgi.wiring.package=javax.swing)

  1. davidvanlaatum 28 times, last 1 month ago
  2. davidvanlaatum 7 times, last 2 months ago
15 unregistered visitors
Not finding the right solution?
Take a tour to get the most out of Samebug.

Tired of useless tips?

Automated exception search integrated into your IDE

Root Cause Analysis

  1. org.osgi.framework.BundleException

    Unresolved constraint in bundle org.opennms.features.vaadin-dashlets.dashlet-charts [95]: Unable to resolve 95.0: missing requirement [95.0] osgi.wiring.package; (&(osgi.wiring.package=org.opennms.web.charts)(version>=1.13.0)(!(version>=2.0.0)))

    at org.apache.felix.framework.Felix.resolveBundleRevision()
  2. Apache Felix Framework
    BundleImpl.start
    1. org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:3826)[org.apache.felix.framework-4.0.3.jar:]
    2. org.apache.felix.framework.Felix.startBundle(Felix.java:1868)[org.apache.felix.framework-4.0.3.jar:]
    3. org.apache.felix.framework.BundleImpl.start(BundleImpl.java:944)[org.apache.felix.framework-4.0.3.jar:]
    4. org.apache.felix.framework.BundleImpl.start(BundleImpl.java:931)[org.apache.felix.framework-4.0.3.jar:]
    4 frames
  3. Pax Runner
    FeaturesServiceImpl$2.run
    1. org.apache.karaf.features.internal.FeaturesServiceImpl.installFeatures(FeaturesServiceImpl.java:479)[40:org.apache.karaf.features.core:2.3.1]
    2. org.apache.karaf.features.internal.FeaturesServiceImpl$2.run(FeaturesServiceImpl.java:1150)[40:org.apache.karaf.features.core:2.3.1]
    2 frames