java.lang.ClassNotFoundException

If you like a tip written by other Samebug users, mark is as helpful! Marks help our algorithm provide you better solutions and also help other users.
tip

A few things cause this exception: 1) Check if you have all jars and if they're in the correct path when running. 2) Your classpath might be broken, you can define it in the command line with "java -cp yourClassPath" or at your IDE if you're using one.

tip

If you're using Hibernate, this indicates you're missing FasterXML Classmate dependency, which you can add to your dependencies. To add it, the groupId is com.fasterxml and artifactId is Classmate.

tip

Check if you didn't forget to instantiate your topic in the kafka broker.

tip

NoClassDefFoundError means java has failed to find a class you're trying to instantiate, look if you've added the class you're trying to instantiate to the dependencies.

tip

You need to add httpcore to your dependencies. Try adding version 4.3 or further.

tip

You might've forgot to add a dependency or it's written wrong. Also, you might be using incompatible versions of Java and Hibernate. More on this here: https://goo.gl/SjSlRA

tip

This error means there's a class missing in your classpath during runtime. You need to create a jar with all your dependencies and have it in your classpath. Check Maven Assembly Plugin and how to add your dependencies to a jar: https://goo.gl/U2zr8k

tip

jsp-api and servlet-api jars must NOT be deployed by your web app. They should be marked as provided but not deployed by your app.

tip

The server rejects all jars that already belong to the server runtime (such as tomcat-**.jar, servlet**.jar). Consider substituting the CORS filter you're using for this one: https://goo.gl/ctQ7Fs

You have a different solution? A short tip here would help you and many other users who saw this issue last week.

  • Enterprise Designer Trouble
    via by 807574,
  • exception errors on loading CVS
    via by ddaniels,
  • Trying to load .class files in Eclipse
    via Stack Overflow by Daniel
    ,
  • Junit Error when trying to run unit test
    via Stack Overflow by parchambeau
    ,
  • GitHub comment 309#179413642
    via GitHub by fabboe
    ,
    • java.lang.ClassNotFoundException: com.stc.eindex.ede.action.NewObjectInstanceAction at java.net.URLClassLoader$1.run(URLClassLoader.java:199) at java.security.AccessController.doPrivileged(Native Method) at java.net.URLClassLoader.findClass(URLClassLoader.java:187) at java.lang.ClassLoader.loadClass(ClassLoader.java:289) at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:274) at java.lang.ClassLoader.loadClass(ClassLoader.java:235) at org.netbeans.core.modules.ProxyClassLoader.loadInOrder(ProxyClassLoader.java:472) at org.netbeans.core.modules.ProxyClassLoader.smartLoadClass(ProxyClassLoader.java:452) at org.netbeans.core.modules.ProxyClassLoader.loadClass(ProxyClassLoader.java:124) at java.lang.ClassLoader.loadClass(ClassLoader.java:235) at com.stc.egate.gui.projectexplorer.ProjectExplorer.buildActionDataBase(ProjectExplorer.java:290) at com.stc.egate.gui.projectexplorer.ProjectExplorer.init(ProjectExplorer.java:254) at com.stc.egate.gui.projectexplorer.LoadExplorerAction.loadExplorer(LoadExplorerAction.java:90) at com.stc.egate.gui.projectexplorer.LoadExplorerAction.performAction(LoadExplorerAction.java:76) at com.stc.login.module.LaunchLoginAction.launchExplorer(LaunchLoginAction.java:154) at com.stc.login.module.LaunchLoginAction.access$200(LaunchLoginAction.java:58) at com.stc.login.module.LaunchLoginAction$2.construct(LaunchLoginAction.java:235) at com.stc.login.module.SwingWorker$2.run(SwingWorker.java:124)[catch] at java.lang.Thread.run(Thread.java:534)

    Users with the same issue

    Unknown visitor1 times, last one,
    Unknown visitor1 times, last one,
    Unknown visitor1 times, last one,
    Unknown visitor1 times, last one,
    odd
    1 times, last one,
    2285 more bugmates