java.lang.NoClassDefFoundError

There are no available Samebug tips for this exception. Do you have an idea how to solve this issue? A short tip would help users who saw this issue last week.

  • java.lang.NoClassDefFoundError: Could not initialize class com.twitter.ambrose.util.JSONUtil at com.twitter.ambrose.model.Event.toJson(Event.java:81) at com.twitter.ambrose.service.impl.InMemoryStatsService.writeJsonEventToDisk(InMemoryStatsService.java:169) at com.twitter.ambrose.service.impl.InMemoryStatsService.pushEvent(InMemoryStatsService.java:132) at com.twitter.ambrose.hive.reporter.AmbroseHiveProgressReporter.pushEvent(AmbroseHiveProgressReporter.java:173) at com.twitter.ambrose.hive.AmbroseHiveFailHook.run(AmbroseHiveFailHook.java:75) at org.apache.hadoop.hive.ql.Driver.execute(Driver.java:1411) at org.apache.hadoop.hive.ql.Driver.runInternal(Driver.java:1179) at org.apache.hadoop.hive.ql.Driver.run(Driver.java:1006) at org.apache.hadoop.hive.ql.Driver.run(Driver.java:996) at org.apache.hadoop.hive.cli.CliDriver.processLocalCmd(CliDriver.java:247) at org.apache.hadoop.hive.cli.CliDriver.processCmd(CliDriver.java:199) at org.apache.hadoop.hive.cli.CliDriver.processLine(CliDriver.java:410) at org.apache.hadoop.hive.cli.CliDriver.processLine(CliDriver.java:345) at org.apache.hadoop.hive.cli.CliDriver.processReader(CliDriver.java:443) at org.apache.hadoop.hive.cli.CliDriver.processFile(CliDriver.java:459) at org.apache.hadoop.hive.cli.CliDriver.executeDriver(CliDriver.java:739) at org.apache.hadoop.hive.cli.CliDriver.run(CliDriver.java:677) at org.apache.hadoop.hive.cli.CliDriver.main(CliDriver.java:616) at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57) at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) at java.lang.reflect.Method.invoke(Method.java:606) at org.apache.hadoop.util.RunJar.run(RunJar.java:221) at org.apache.hadoop.util.RunJar.main(RunJar.java:136)
No Bugmate found.