com.splwg.xai.servlet.XAIWSServlet$WSAuthenticationException

java.io.IOException: Server returned HTTP response code: 401 for URL: http://HARI:6500/XAIApp/classicxai

Samebug tips1

Check if you didn't set RequestProperty Content-Type to the wrong type or if you're trying to send the wrong file to the server.

Don't give up yet. Our experts can help. Paste your full stack trace to get a solution.

Solutions on the web1

  • via Oracle Community by user55555, 1 year ago
    java.io.IOException: Server returned HTTP response code: 401 for URL: http://HARI:6500/XAIApp/classicxai
  • Stack trace

    • com.splwg.xai.servlet.XAIWSServlet$WSAuthenticationException: java.io.IOException: Server returned HTTP response code: 401 for URL: http://HARI:6500/XAIApp/classicxai at com.splwg.xai.servlet.XAIWSServlet.authenticateUser(XAIWSServlet.java:149) at com.splwg.xai.servlet.XAIWSServlet.doPost(XAIWSServlet.java:81) at javax.servlet.http.HttpServlet.service(HttpServlet.java:710) at javax.servlet.http.HttpServlet.service(HttpServlet.java:803) at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:290) at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206) at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:233) at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:175) at org.apache.catalina.authenticator.AuthenticatorBase.invoke(AuthenticatorBase.java:433) at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:128) at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102) at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109) at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:286) at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:844) at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:583) at org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:447) at java.lang.Thread.run(Thread.java:595) Caused by: java.io.IOException: Server returned HTTP response code: 401 for URL: http://HARI:6500/XAIApp/classicxai at sun.net.www.protocol.http.HttpURLConnection.getInputStream(HttpURLConnection.java:1170) at com.splwg.xai.server.WSAuthenticationImpl.getResponse(WSAuthenticationImpl.java:257) at com.splwg.xai.server.WSAuthenticationImpl.authenticateHTTPHeaderInformation(WSAuthenticationImpl.java:122) at com.splwg.xai.servlet.XAIWSServlet.attemptClassicAuthentication(XAIWSServlet.java:160) at com.splwg.xai.servlet.XAIWSServlet.authenticateUser(XAIWSServlet.java:139) ... 16 more

    Write tip

    You have a different solution? A short tip here would help you and many other users who saw this issue last week.

    Users with the same issue

    Once, 5 days ago
    10 times, 1 month ago
    Once, 1 month ago
    4 times, 6 months ago
    Once, 6 months ago
    75 more bugmates