weblogic.deployment.EnvironmentException

[J2EE:160101]Error: The ejb-link 'RegistrationAuthorityFacade#sg.com.stee.stars21.common.facade.RegistrationAuthorityFacade' declared in the ejb-ref or ejb-local-ref 'sg.com.stee.stars21.testing.RegistrationAuthorityBean/registrationAuthorityFacade' in the application module 'stars21_web-stars21-webapp' could not be resolved. The target EJB for the ejb-ref could not be found. Please ensure the link is correct.

Samebug tips0

There are no available Samebug tips for this exception. If you know how to solve this issue, help other users by writing a short tip.

Don't give up yet. Paste your full stack trace to get a solution.

Solutions on the web82

  • via Oracle Community by 717529, 1 year ago
    ' in the application module 'stars21_web-stars21-webapp' could not be resolved. The target EJB for the ejb-ref could not be found. Please ensure the link is correct.
  • via Oracle Community by 843830, 1 year ago
    target bean has not been specified. Attempts to automatically link the ejb-ref to its target bean failed because no EJBs in the application were found to implement the 'sg.com.stee.stars21.common.facade.RegistrationAuthorityFacade' interface. Please link or map this ejb-ref to its target EJB and ensure the interfaces declared in the ejb-ref are correct.
  • via Oracle Community by 3004, 1 year ago
    [J2EE:160101]Error: The ejb-link 'ejb/SysProperty' declared in the ejb-ref or ejb-local-ref 'ejb/SysProperty' in the application module 'ArmantaCustomEJB.jar' could not be resolved. The target EJB for the ejb-ref could not be found. Please ensure the link is correct.
  • Stack trace

    • weblogic.deployment.EnvironmentException: [J2EE:160101]Error: The ejb-link 'RegistrationAuthorityFacade#sg.com.stee.stars21.common.facade.RegistrationAuthorityFacade' declared in the ejb-ref or ejb-local-ref 'sg.com.stee.stars21.testing.RegistrationAuthorityBean/registrationAuthorityFacade' in the application module 'stars21_web-stars21-webapp' could not be resolved. The target EJB for the ejb-ref could not be found. Please ensure the link is correct. at weblogic.deployment.BaseEnvironmentBuilder.addEJBLinkRef(BaseEnvironmentBuilder.java:452) at weblogic.deployment.EnvironmentBuilder.addEJBReferences(EnvironmentBuilder.java:448) at weblogic.servlet.internal.CompEnv.activate(CompEnv.java:157) at weblogic.servlet.internal.WebAppServletContext.activate(WebAppServletContext.java:3034) at weblogic.servlet.internal.WebAppModule.activateContexts(WebAppModule.java:1359)

    Write tip

    You have a different solution? A short tip here would help you and many other users who saw this issue last week.

    Users with the same issue

    You’re the first here who have seen this exception.