org.springframework.dao.InvalidDataAccessApiUsageException: Usage of 'UserCredentials' with 'MongoClient' is no longer supported. Please use 'MongoCredential' for 'MongoClient' or just 'Mongo'.

Google Groups | Sami Ghayeni | 1 year ago
tip
Do you know that we can give you better hits? Get more relevant results from Samebug’s stack trace search.
  1. 0

    [cas-user] Unable to integrate Mongo-Service-Management in CAS 4.2.0

    Google Groups | 1 year ago | Sami Ghayeni
    org.springframework.dao.InvalidDataAccessApiUsageException: Usage of 'UserCredentials' with 'MongoClient' is no longer supported. Please use 'MongoCredential' for 'MongoClient' or just 'Mongo'.

    Root Cause Analysis

    1. org.springframework.dao.InvalidDataAccessApiUsageException

      Usage of 'UserCredentials' with 'MongoClient' is no longer supported. Please use 'MongoCredential' for 'MongoClient' or just 'Mongo'.

      at org.springframework.beans.BeanUtils.instantiateClass()
    2. Spring Beans
      ConstructorResolver.autowireConstructor
      1. org.springframework.beans.BeanUtils.instantiateClass(BeanUtils.java:163)
      2. org.springframework.beans.factory.support.SimpleInstantiationStrategy.instantiate(SimpleInstantiationStrategy.java:122)
      3. org.springframework.beans.factory.support.ConstructorResolver.autowireConstructor(ConstructorResolver.java:267)
      3 frames