javax.xml.parsers.FactoryConfigurationError: Provider weblogic.xml.jaxp.RegistrySAXParserFactory not found

Searched on Google with the first line of a JAVA stack trace?

We can recommend more relevant solutions and speed up debugging when you paste your entire stack trace with the exception message. Try a sample exception.

Recommended solutions based on your search

Samebug tips

Do you know how to solve this issue? Write a tip to help other users and build your expert profile.

Solutions on the web

via strutstestcase by gaurav096
, 1 year ago
Provider weblogic.xml.jaxp.RegistrySAXParserFactory not found
via Oracle Community by 442176, 1 year ago
Provider org.apache.xerces.jaxp.SAXParserFactoryImpl not found
via strutstestcase by bkidney
, 1 year ago
Provider org.netbeans.core.xml.NbSAXParserFactoryImpl not found
via Sonatype JIRA by Deleted User, 1 year ago
Provider org.apache.xerces.jaxp.SAXParserFactoryImpl not found
via Stack Overflow by Paras
, 2 years ago
via findbugs by debaftl
, 1 year ago
Provider org.apache.xerces.jaxp.SAXParserFactoryImpl not found
javax.xml.parsers.FactoryConfigurationError: Provider weblogic.xml.jaxp.RegistrySAXParserFactory not found
at javax.xml.parsers.SAXParserFactory.newInstance(SAXParserFactory.java:113)
at org.apache.commons.digester.Digester.getFactory(Digester.java:512)
at org.apache.commons.digester.Digester.getParser(Digester.java:686)
at org.apache.commons.digester.Digester.getXMLReader(Digester.java:902)
at servletunit.struts.MockStrutsTestCase.setServletConfigFile(MockStrutsTestCase.java:603)
at com.ntrs.ecp.ui.gainloss.MockUnrealizedGainLossAction.setUp(MockUnrealizedGainLossAction.java:27)
at junit.framework.TestCase.runBare(TestCase.java:128)
at junit.framework.TestResult$1.protect(TestResult.java:106)
at junit.framework.TestResult.runProtected(TestResult.java:124)
at junit.framework.TestResult.run(TestResult.java:109)
at junit.framework.TestCase.run(TestCase.java:120)
at junit.framework.TestSuite.runTest(TestSuite.java:230)
at junit.framework.TestSuite.run(TestSuite.java:225)
at org.eclipse.jdt.internal.junit.runner.junit3.JUnit3TestReference.run(JUnit3TestReference.java:128)
at org.eclipse.jdt.internal.junit.runner.TestExecution.run(TestExecution.java:38)
at org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.runTests(RemoteTestRunner.java:460)
at org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.runTests(RemoteTestRunner.java:673)
at org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.run(RemoteTestRunner.java:386)

Users with the same issue

Samebug visitor profile picture
Unknown user
Once, 1 year ago

Write tip

Know the solutions? Share your knowledge to help other developers to debug faster.