javax.servlet.UnavailableException

Cannot load a validator resource from 'null'

Samebug tips0

There are no available Samebug tips for this exception. If you know how to solve this issue, help other users by writing a short tip.

Don't give up yet. Paste your full stack trace to get a solution.

Solutions on the web358

  • via strutstestcase by ens00033
    , 1 year ago
    Cannot load a validator resource from 'null'
  • via Coderanch by vivek shankare gowda, 7 months ago
    Cannot load a validator resource from '/org/apache/struts/validator/validator-rules.xml, /WEB-INF/validation.xml'
  • via Coderanch by Prasanth Pillai, 7 months ago
    Cannot load a validator resource from '/org/apache/struts/validator/validator-rules.xml, /WEB-INF/validation.xml'
  • Stack trace

    • javax.servlet.UnavailableException: Cannot load a validator resource from 'null' at org.apache.struts.validator.ValidatorPlugIn.init(ValidatorPlugIn.java:172) at org.apache.struts.action.ActionServlet.initModulePlugIns(ActionServlet.java:869) at org.apache.struts.action.ActionServlet.init(ActionServlet.java:336) at javax.servlet.GenericServlet.init(GenericServlet.java:212) at servletunit.struts.MockStrutsTestCase.getActionServlet(MockStrutsTestCase.java:326) at servletunit.struts.MockStrutsTestCase.actionPerform(MockStrutsTestCase.java:394) at com.siemens.ada.Junit.struts.popup.TestPopup.testPopupShow(TestPopup.java:28) at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39) at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25) at java.lang.reflect.Method.invoke(Method.java:324) at junit.framework.TestCase.runTest(TestCase.java:164) at junit.framework.TestCase.runBare(TestCase.java:130) at junit.framework.TestResult$1.protect(TestResult.java:106) at junit.framework.TestResult.runProtected(TestResult.java:124) at junit.framework.TestResult.run(TestResult.java:109) at junit.framework.TestCase.run(TestCase.java:120) at junit.framework.TestSuite.runTest(TestSuite.java:230) at junit.framework.TestSuite.run(TestSuite.java:225) at org.eclipse.jdt.internal.junit.runner.junit3.JUnit3TestReference.run(JUnit3TestReference.java:130) at org.eclipse.jdt.internal.junit.runner.TestExecution.run(TestExecution.java:38) at org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.runTests(RemoteTestRunner.java:460) at org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.runTests(RemoteTestRunner.java:673) at org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.run(RemoteTestRunner.java:386) at org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.main(RemoteTestRunner.java:196)

    Write tip

    You have a different solution? A short tip here would help you and many other users who saw this issue last week.

    Users with the same issue

    Unknown user
    Once, 10 months ago
    Unknown user
    Once, 11 months ago
    Unknown user
    Once, 1 year ago
    Unknown user
    Once, 1 year ago
    Unknown user
    Once, 1 year ago
    7 more bugmates