java.net.BindException

tip

It might be that there's another process connecting to the same port you're trying to use, try to kill it or change the connection port.


rafaelrafael
tip

Change the connection port and ip adress. If you're trying to connect to your server from your own computer, check if you haven't already connected to the server in another instance.


rafaelrafael
tip

Try changing the port in core-site.xml from 9000 to 9001 as it seems port 9000 doesn't work.

You have a different solution? A short tip here would help you and many other users who saw this issue last week.

  • Problem while storing to HDFS
    via by Unknown author,
  • Running multiple connectors on one kafka host
    via by Bart Van Bos,
  • GitHub comment 179#269924755
    via GitHub by MichaelBlume
    ,
  • Apache Ignite Users - Couchbase as persistent store
    via by Unknown author,
  • 请问这是什么问题?
    via GitHub by beckno9
    ,
    • java.net.BindException: Die Adresse wird bereits verwendet at sun.nio.ch.Net.bind0(Native Method) at sun.nio.ch.Net.bind(Net.java:433) at sun.nio.ch.Net.bind(Net.java:425) at sun.nio.ch.ServerSocketChannelImpl.bind(ServerSocketChannelImpl.java:223) at sun.nio.ch.ServerSocketAdaptor.bind(ServerSocketAdaptor.java:74) at org.eclipse.jetty.server.ServerConnector.open(ServerConnector.java:321) at org.eclipse.jetty.server.AbstractNetworkConnector.doStart(AbstractNetworkConnector.java:80) at org.eclipse.jetty.server.ServerConnector.doStart(ServerConnector.java:236) at org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java:68) at org.eclipse.jetty.server.Server.doStart(Server.java:366) at org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java:68) at org.neo4j.server.web.Jetty9WebServer.startJetty(Jetty9WebServer.java:353) at org.neo4j.server.web.Jetty9WebServer.start(Jetty9WebServer.java:168) at org.neo4j.server.AbstractNeoServer.startWebServer(AbstractNeoServer.java:316) at org.neo4j.server.AbstractNeoServer.start(AbstractNeoServer.java:208) at org.neo4j.server.ServerBootstrapper.start(ServerBootstrapper.java:87)

    Users with the same issue

    PKeidelPKeidel
    2 times, last one,
    davidvanlaatumdavidvanlaatum
    3 times, last one,
    jstrayerjstrayer
    1 times, last one,
    DunmerDunmer
    36 times, last one,
    Unknown visitor
    Unknown visitor1 times, last one,
    136 more bugmates