com.atlassian.plugin.osgi.container.OsgiContainerException

There are no available Samebug tips for this exception. Do you have an idea how to solve this issue? A short tip would help users who saw this issue last week.

  • An exception is thrown when it tries to start the plugin. This looks like the key line: {noformat} Unresolved constraint in bundle org.swift.bamboo.bobswift-run-cli-bamboo [43]: Unable to resolve 43.0: missing requirement [43.0] osgi.wiring.package; (&(osgi.wiring.package=com.atlassian.upm.api.license)(version>=2.0.1)) {noformat} Here's the full exception: {{2016-04-08 08:33:54,959 ERROR [remoteEventRebroadcasterMessageListenerContainer-1] [OsgiPlugin] Detected an error (BundleException) enabling the plugin 'org.swift.bamboo.acli' : Unresolved constraint in bundle org.swift.bamboo.bobswift-run-cli-bamboo [43]: Unable to resolve 43.0: missing requirement [43.0] osgi.wiring.package; (&(osgi.wiring.package=com.atlassian.upm.api.license)(version>=2.0.1)). This error usually occurs when your plugin imports a package from another bundle with a specific version constraint and either the bundle providing that package doesn't meet those version constraints, or there is no bundle available that provides the specified package. For more details on how to fix this, see https://developer.atlassian.com/x/mQAN 2016-04-08 08:33:54,959 WARN [remoteEventRebroadcasterMessageListenerContainer-1] [AbstractPlugin] Unable to enable plugin 'org.swift.bamboo.acli' 2016-04-08 08:33:54,959 WARN [remoteEventRebroadcasterMessageListenerContainer-1] [AbstractPlugin] Because of this exception com.atlassian.plugin.osgi.container.OsgiContainerException: Cannot start plugin: org.swift.bamboo.acli at com.atlassian.plugin.osgi.factory.OsgiPlugin.enableInternal(OsgiPlugin.java:393) at com.atlassian.plugin.impl.AbstractPlugin.enable(AbstractPlugin.java:286) at com.atlassian.plugin.manager.PluginEnabler.actualEnable(PluginEnabler.java:130) at com.atlassian.plugin.manager.PluginEnabler.enable(PluginEnabler.java:107) at com.atlassian.plugin.manager.DefaultPluginManager.enableDependentPlugins(DefaultPluginManager.java:1079) at com.atlassian.plugin.manager.DefaultPluginManager.addPlugins(DefaultPluginManager.java:1055) at com.atlassian.plugin.manager.DefaultPluginManager.scanForNewPlugins(DefaultPluginManager.java:785) at com.atlassian.bamboo.v2.build.agent.remote.plugins.RemoteAgentPluginManager.enablePlugin(RemoteAgentPluginManager.java:51) at com.atlassian.bamboo.v2.build.agent.remote.plugins.RemoteAgentPluginEventHandlerImpl$RemoteAgentPluginManagerAdapter.onEvent(RemoteAgentPluginEventHandlerImpl.java:55) at com.atlassian.bamboo.plugin.events.EnableRemotePluginEvent.deliver(EnableRemotePluginEvent.java:22) at com.atlassian.bamboo.v2.build.agent.remote.plugins.RemoteAgentPluginEventHandlerImpl.deliver(RemoteAgentPluginEventHandlerImpl.java:139) at com.atlassian.bamboo.v2.build.agent.remote.plugins.RemoteAgentPluginEventHandlerImpl.handle(RemoteAgentPluginEventHandlerImpl.java:94) at com.atlassian.bamboo.v2.build.agent.remote.plugins.RemoteAgentPluginEventDeferringListener.onEvent(RemoteAgentPluginEventDeferringListener.java:53) at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62) at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) at java.lang.reflect.Method.invoke(Method.java:497) at com.atlassian.event.internal.SingleParameterMethodListenerInvoker.invoke(SingleParameterMethodListenerInvoker.java:36) at com.atlassian.event.internal.AsynchronousAbleEventDispatcher$1$1.run(AsynchronousAbleEventDispatcher.java:46) at com.google.common.util.concurrent.MoreExecutors$DirectExecutorService.execute(MoreExecutors.java:299) at com.atlassian.event.internal.AsynchronousAbleEventDispatcher.dispatch(AsynchronousAbleEventDispatcher.java:105) at com.atlassian.event.internal.LockFreeEventPublisher$Publisher.dispatch(LockFreeEventPublisher.java:260) at com.atlassian.event.internal.LockFreeEventPublisher.publish(LockFreeEventPublisher.java:102) at com.atlassian.bamboo.v2.build.agent.remote.event.RemoteEventRebroadcasterMessageListener.onMessage(RemoteEventRebroadcasterMessageListener.java:39) at com.atlassian.bamboo.spring.MessageListenerUtils$2.lambda$onMessage$1(MessageListenerUtils.java:42) at com.atlassian.bamboo.spring.MessageListenerUtils.wrapWithFingerprintCheck(MessageListenerUtils.java:55) at com.atlassian.bamboo.spring.MessageListenerUtils.access$000(MessageListenerUtils.java:16) at com.atlassian.bamboo.spring.MessageListenerUtils$2.onMessage(MessageListenerUtils.java:43) at org.springframework.jms.listener.AbstractMessageListenerContainer.doInvokeListener(AbstractMessageListenerContainer.java:562) at org.springframework.jms.listener.AbstractMessageListenerContainer.invokeListener(AbstractMessageListenerContainer.java:500) at org.springframework.jms.listener.AbstractMessageListenerContainer.doExecuteListener(AbstractMessageListenerContainer.java:468) at org.springframework.jms.listener.AbstractPollingMessageListenerContainer.doReceiveAndExecute(AbstractPollingMessageListenerContainer.java:325) at org.springframework.jms.listener.AbstractPollingMessageListenerContainer.receiveAndExecute(AbstractPollingMessageListenerContainer.java:263) at org.springframework.jms.listener.DefaultMessageListenerContainer$AsyncMessageListenerInvoker.invokeListener(DefaultMessageListenerContainer.java:1102) at org.springframework.jms.listener.DefaultMessageListenerContainer$AsyncMessageListenerInvoker.executeOngoingLoop(DefaultMessageListenerContainer.java:1094) at org.springframework.jms.listener.DefaultMessageListenerContainer$AsyncMessageListenerInvoker.run(DefaultMessageListenerContainer.java:991) at java.lang.Thread.run(Thread.java:745) Caused by: org.osgi.framework.BundleException: Unresolved constraint in bundle org.swift.bamboo.bobswift-run-cli-bamboo [43]: Unable to resolve 43.0: missing requirement [43.0] osgi.wiring.package; (&(osgi.wiring.package=com.atlassian.upm.api.license)(version>=2.0.1)) at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:3974) at org.apache.felix.framework.Felix.startBundle(Felix.java:2037) at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:955) at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:942) at com.atlassian.plugin.osgi.factory.OsgiPlugin.enableInternal(OsgiPlugin.java:374) ... 36 more 2016-04-08 08:33:54,960 ERROR [remoteEventRebroadcasterMessageListenerContainer-1] [PluginEnabler] Unable to enable plugin org.swift.bamboo.acli com.atlassian.plugin.osgi.container.OsgiContainerException: Cannot start plugin: org.swift.bamboo.acli at com.atlassian.plugin.osgi.factory.OsgiPlugin.enableInternal(OsgiPlugin.java:393) at com.atlassian.plugin.impl.AbstractPlugin.enable(AbstractPlugin.java:286) at com.atlassian.plugin.manager.PluginEnabler.actualEnable(PluginEnabler.java:130) at com.atlassian.plugin.manager.PluginEnabler.enable(PluginEnabler.java:107) at com.atlassian.plugin.manager.DefaultPluginManager.enableDependentPlugins(DefaultPluginManager.java:1079) at com.atlassian.plugin.manager.DefaultPluginManager.addPlugins(DefaultPluginManager.java:1055) at com.atlassian.plugin.manager.DefaultPluginManager.scanForNewPlugins(DefaultPluginManager.java:785) at com.atlassian.bamboo.v2.build.agent.remote.plugins.RemoteAgentPluginManager.enablePlugin(RemoteAgentPluginManager.java:51) at com.atlassian.bamboo.v2.build.agent.remote.plugins.RemoteAgentPluginEventHandlerImpl$RemoteAgentPluginManagerAdapter.onEvent(RemoteAgentPluginEventHandlerImpl.java:55) at com.atlassian.bamboo.plugin.events.EnableRemotePluginEvent.deliver(EnableRemotePluginEvent.java:22) at com.atlassian.bamboo.v2.build.agent.remote.plugins.RemoteAgentPluginEventHandlerImpl.deliver(RemoteAgentPluginEventHandlerImpl.java:139) at com.atlassian.bamboo.v2.build.agent.remote.plugins.RemoteAgentPluginEventHandlerImpl.handle(RemoteAgentPluginEventHandlerImpl.java:94) at com.atlassian.bamboo.v2.build.agent.remote.plugins.RemoteAgentPluginEventDeferringListener.onEvent(RemoteAgentPluginEventDeferringListener.java:53) at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62) at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) at java.lang.reflect.Method.invoke(Method.java:497) at com.atlassian.event.internal.SingleParameterMethodListenerInvoker.invoke(SingleParameterMethodListenerInvoker.java:36) at com.atlassian.event.internal.AsynchronousAbleEventDispatcher$1$1.run(AsynchronousAbleEventDispatcher.java:46) at com.google.common.util.concurrent.MoreExecutors$DirectExecutorService.execute(MoreExecutors.java:299) at com.atlassian.event.internal.AsynchronousAbleEventDispatcher.dispatch(AsynchronousAbleEventDispatcher.java:105) at com.atlassian.event.internal.LockFreeEventPublisher$Publisher.dispatch(LockFreeEventPublisher.java:260) at com.atlassian.event.internal.LockFreeEventPublisher.publish(LockFreeEventPublisher.java:102) at com.atlassian.bamboo.v2.build.agent.remote.event.RemoteEventRebroadcasterMessageListener.onMessage(RemoteEventRebroadcasterMessageListener.java:39) at com.atlassian.bamboo.spring.MessageListenerUtils$2.lambda$onMessage$1(MessageListenerUtils.java:42) at com.atlassian.bamboo.spring.MessageListenerUtils.wrapWithFingerprintCheck(MessageListenerUtils.java:55) at com.atlassian.bamboo.spring.MessageListenerUtils.access$000(MessageListenerUtils.java:16) at com.atlassian.bamboo.spring.MessageListenerUtils$2.onMessage(MessageListenerUtils.java:43) at org.springframework.jms.listener.AbstractMessageListenerContainer.doInvokeListener(AbstractMessageListenerContainer.java:562) at org.springframework.jms.listener.AbstractMessageListenerContainer.invokeListener(AbstractMessageListenerContainer.java:500) at org.springframework.jms.listener.AbstractMessageListenerContainer.doExecuteListener(AbstractMessageListenerContainer.java:468) at org.springframework.jms.listener.AbstractPollingMessageListenerContainer.doReceiveAndExecute(AbstractPollingMessageListenerContainer.java:325) at org.springframework.jms.listener.AbstractPollingMessageListenerContainer.receiveAndExecute(AbstractPollingMessageListenerContainer.java:263) at org.springframework.jms.listener.DefaultMessageListenerContainer$AsyncMessageListenerInvoker.invokeListener(DefaultMessageListenerContainer.java:1102) at org.springframework.jms.listener.DefaultMessageListenerContainer$AsyncMessageListenerInvoker.executeOngoingLoop(DefaultMessageListenerContainer.java:1094) at org.springframework.jms.listener.DefaultMessageListenerContainer$AsyncMessageListenerInvoker.run(DefaultMessageListenerContainer.java:991) at java.lang.Thread.run(Thread.java:745) Caused by: org.osgi.framework.BundleException: Unresolved constraint in bundle org.swift.bamboo.bobswift-run-cli-bamboo [43]: Unable to resolve 43.0: missing requirement [43.0] osgi.wiring.package; (&(osgi.wiring.package=com.atlassian.upm.api.license)(version>=2.0.1)) at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:3974) at org.apache.felix.framework.Felix.startBundle(Felix.java:2037) at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:955) at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:942) at com.atlassian.plugin.osgi.factory.OsgiPlugin.enableInternal(OsgiPlugin.java:374) ... 36 more 2016-04-08 08:33:54,960 INFO [remoteEventRebroadcasterMessageListenerContainer-1] [RemoteAgentPluginManager] Enabling plugin [org.swift.bamboo.acli] 2016-04-08 08:33:54,961 ERROR [remoteEventRebroadcasterMessageListenerContainer-1] [OsgiPluginInstalledHelper] Cannot determine required plugins, cannot resolve bundle 'org.swift.bamboo.bobswift-run-cli-bamboo' 2016-04-08 08:34:54,980 ERROR [remoteEventRebroadcasterMessageListenerContainer-1] [PluginEnabler] Unable to start the following plugins due to timeout while waiting for plugin to enable: org.swift.bamboo.acli }}
    via by Alan Yackel,
  • An exception is thrown when it tries to start the plugin. This looks like the key line: {noformat} Unresolved constraint in bundle org.swift.bamboo.bobswift-run-cli-bamboo [43]: Unable to resolve 43.0: missing requirement [43.0] osgi.wiring.package; (&(osgi.wiring.package=com.atlassian.upm.api.license)(version>=2.0.1)) {noformat} Here's the full exception: {{2016-04-08 08:33:54,959 ERROR [remoteEventRebroadcasterMessageListenerContainer-1] [OsgiPlugin] Detected an error (BundleException) enabling the plugin 'org.swift.bamboo.acli' : Unresolved constraint in bundle org.swift.bamboo.bobswift-run-cli-bamboo [43]: Unable to resolve 43.0: missing requirement [43.0] osgi.wiring.package; (&(osgi.wiring.package=com.atlassian.upm.api.license)(version>=2.0.1)). This error usually occurs when your plugin imports a package from another bundle with a specific version constraint and either the bundle providing that package doesn't meet those version constraints, or there is no bundle available that provides the specified package. For more details on how to fix this, see https://developer.atlassian.com/x/mQAN 2016-04-08 08:33:54,959 WARN [remoteEventRebroadcasterMessageListenerContainer-1] [AbstractPlugin] Unable to enable plugin 'org.swift.bamboo.acli' 2016-04-08 08:33:54,959 WARN [remoteEventRebroadcasterMessageListenerContainer-1] [AbstractPlugin] Because of this exception com.atlassian.plugin.osgi.container.OsgiContainerException: Cannot start plugin: org.swift.bamboo.acli at com.atlassian.plugin.osgi.factory.OsgiPlugin.enableInternal(OsgiPlugin.java:393) at com.atlassian.plugin.impl.AbstractPlugin.enable(AbstractPlugin.java:286) at com.atlassian.plugin.manager.PluginEnabler.actualEnable(PluginEnabler.java:130) at com.atlassian.plugin.manager.PluginEnabler.enable(PluginEnabler.java:107) at com.atlassian.plugin.manager.DefaultPluginManager.enableDependentPlugins(DefaultPluginManager.java:1079) at com.atlassian.plugin.manager.DefaultPluginManager.addPlugins(DefaultPluginManager.java:1055) at com.atlassian.plugin.manager.DefaultPluginManager.scanForNewPlugins(DefaultPluginManager.java:785) at com.atlassian.bamboo.v2.build.agent.remote.plugins.RemoteAgentPluginManager.enablePlugin(RemoteAgentPluginManager.java:51) at com.atlassian.bamboo.v2.build.agent.remote.plugins.RemoteAgentPluginEventHandlerImpl$RemoteAgentPluginManagerAdapter.onEvent(RemoteAgentPluginEventHandlerImpl.java:55) at com.atlassian.bamboo.plugin.events.EnableRemotePluginEvent.deliver(EnableRemotePluginEvent.java:22) at com.atlassian.bamboo.v2.build.agent.remote.plugins.RemoteAgentPluginEventHandlerImpl.deliver(RemoteAgentPluginEventHandlerImpl.java:139) at com.atlassian.bamboo.v2.build.agent.remote.plugins.RemoteAgentPluginEventHandlerImpl.handle(RemoteAgentPluginEventHandlerImpl.java:94) at com.atlassian.bamboo.v2.build.agent.remote.plugins.RemoteAgentPluginEventDeferringListener.onEvent(RemoteAgentPluginEventDeferringListener.java:53) at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62) at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) at java.lang.reflect.Method.invoke(Method.java:497) at com.atlassian.event.internal.SingleParameterMethodListenerInvoker.invoke(SingleParameterMethodListenerInvoker.java:36) at com.atlassian.event.internal.AsynchronousAbleEventDispatcher$1$1.run(AsynchronousAbleEventDispatcher.java:46) at com.google.common.util.concurrent.MoreExecutors$DirectExecutorService.execute(MoreExecutors.java:299) at com.atlassian.event.internal.AsynchronousAbleEventDispatcher.dispatch(AsynchronousAbleEventDispatcher.java:105) at com.atlassian.event.internal.LockFreeEventPublisher$Publisher.dispatch(LockFreeEventPublisher.java:260) at com.atlassian.event.internal.LockFreeEventPublisher.publish(LockFreeEventPublisher.java:102) at com.atlassian.bamboo.v2.build.agent.remote.event.RemoteEventRebroadcasterMessageListener.onMessage(RemoteEventRebroadcasterMessageListener.java:39) at com.atlassian.bamboo.spring.MessageListenerUtils$2.lambda$onMessage$1(MessageListenerUtils.java:42) at com.atlassian.bamboo.spring.MessageListenerUtils.wrapWithFingerprintCheck(MessageListenerUtils.java:55) at com.atlassian.bamboo.spring.MessageListenerUtils.access$000(MessageListenerUtils.java:16) at com.atlassian.bamboo.spring.MessageListenerUtils$2.onMessage(MessageListenerUtils.java:43) at org.springframework.jms.listener.AbstractMessageListenerContainer.doInvokeListener(AbstractMessageListenerContainer.java:562) at org.springframework.jms.listener.AbstractMessageListenerContainer.invokeListener(AbstractMessageListenerContainer.java:500) at org.springframework.jms.listener.AbstractMessageListenerContainer.doExecuteListener(AbstractMessageListenerContainer.java:468) at org.springframework.jms.listener.AbstractPollingMessageListenerContainer.doReceiveAndExecute(AbstractPollingMessageListenerContainer.java:325) at org.springframework.jms.listener.AbstractPollingMessageListenerContainer.receiveAndExecute(AbstractPollingMessageListenerContainer.java:263) at org.springframework.jms.listener.DefaultMessageListenerContainer$AsyncMessageListenerInvoker.invokeListener(DefaultMessageListenerContainer.java:1102) at org.springframework.jms.listener.DefaultMessageListenerContainer$AsyncMessageListenerInvoker.executeOngoingLoop(DefaultMessageListenerContainer.java:1094) at org.springframework.jms.listener.DefaultMessageListenerContainer$AsyncMessageListenerInvoker.run(DefaultMessageListenerContainer.java:991) at java.lang.Thread.run(Thread.java:745) Caused by: org.osgi.framework.BundleException: Unresolved constraint in bundle org.swift.bamboo.bobswift-run-cli-bamboo [43]: Unable to resolve 43.0: missing requirement [43.0] osgi.wiring.package; (&(osgi.wiring.package=com.atlassian.upm.api.license)(version>=2.0.1)) at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:3974) at org.apache.felix.framework.Felix.startBundle(Felix.java:2037) at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:955) at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:942) at com.atlassian.plugin.osgi.factory.OsgiPlugin.enableInternal(OsgiPlugin.java:374) ... 36 more 2016-04-08 08:33:54,960 ERROR [remoteEventRebroadcasterMessageListenerContainer-1] [PluginEnabler] Unable to enable plugin org.swift.bamboo.acli com.atlassian.plugin.osgi.container.OsgiContainerException: Cannot start plugin: org.swift.bamboo.acli at com.atlassian.plugin.osgi.factory.OsgiPlugin.enableInternal(OsgiPlugin.java:393) at com.atlassian.plugin.impl.AbstractPlugin.enable(AbstractPlugin.java:286) at com.atlassian.plugin.manager.PluginEnabler.actualEnable(PluginEnabler.java:130) at com.atlassian.plugin.manager.PluginEnabler.enable(PluginEnabler.java:107) at com.atlassian.plugin.manager.DefaultPluginManager.enableDependentPlugins(DefaultPluginManager.java:1079) at com.atlassian.plugin.manager.DefaultPluginManager.addPlugins(DefaultPluginManager.java:1055) at com.atlassian.plugin.manager.DefaultPluginManager.scanForNewPlugins(DefaultPluginManager.java:785) at com.atlassian.bamboo.v2.build.agent.remote.plugins.RemoteAgentPluginManager.enablePlugin(RemoteAgentPluginManager.java:51) at com.atlassian.bamboo.v2.build.agent.remote.plugins.RemoteAgentPluginEventHandlerImpl$RemoteAgentPluginManagerAdapter.onEvent(RemoteAgentPluginEventHandlerImpl.java:55) at com.atlassian.bamboo.plugin.events.EnableRemotePluginEvent.deliver(EnableRemotePluginEvent.java:22) at com.atlassian.bamboo.v2.build.agent.remote.plugins.RemoteAgentPluginEventHandlerImpl.deliver(RemoteAgentPluginEventHandlerImpl.java:139) at com.atlassian.bamboo.v2.build.agent.remote.plugins.RemoteAgentPluginEventHandlerImpl.handle(RemoteAgentPluginEventHandlerImpl.java:94) at com.atlassian.bamboo.v2.build.agent.remote.plugins.RemoteAgentPluginEventDeferringListener.onEvent(RemoteAgentPluginEventDeferringListener.java:53) at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62) at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) at java.lang.reflect.Method.invoke(Method.java:497) at com.atlassian.event.internal.SingleParameterMethodListenerInvoker.invoke(SingleParameterMethodListenerInvoker.java:36) at com.atlassian.event.internal.AsynchronousAbleEventDispatcher$1$1.run(AsynchronousAbleEventDispatcher.java:46) at com.google.common.util.concurrent.MoreExecutors$DirectExecutorService.execute(MoreExecutors.java:299) at com.atlassian.event.internal.AsynchronousAbleEventDispatcher.dispatch(AsynchronousAbleEventDispatcher.java:105) at com.atlassian.event.internal.LockFreeEventPublisher$Publisher.dispatch(LockFreeEventPublisher.java:260) at com.atlassian.event.internal.LockFreeEventPublisher.publish(LockFreeEventPublisher.java:102) at com.atlassian.bamboo.v2.build.agent.remote.event.RemoteEventRebroadcasterMessageListener.onMessage(RemoteEventRebroadcasterMessageListener.java:39) at com.atlassian.bamboo.spring.MessageListenerUtils$2.lambda$onMessage$1(MessageListenerUtils.java:42) at com.atlassian.bamboo.spring.MessageListenerUtils.wrapWithFingerprintCheck(MessageListenerUtils.java:55) at com.atlassian.bamboo.spring.MessageListenerUtils.access$000(MessageListenerUtils.java:16) at com.atlassian.bamboo.spring.MessageListenerUtils$2.onMessage(MessageListenerUtils.java:43) at org.springframework.jms.listener.AbstractMessageListenerContainer.doInvokeListener(AbstractMessageListenerContainer.java:562) at org.springframework.jms.listener.AbstractMessageListenerContainer.invokeListener(AbstractMessageListenerContainer.java:500) at org.springframework.jms.listener.AbstractMessageListenerContainer.doExecuteListener(AbstractMessageListenerContainer.java:468) at org.springframework.jms.listener.AbstractPollingMessageListenerContainer.doReceiveAndExecute(AbstractPollingMessageListenerContainer.java:325) at org.springframework.jms.listener.AbstractPollingMessageListenerContainer.receiveAndExecute(AbstractPollingMessageListenerContainer.java:263) at org.springframework.jms.listener.DefaultMessageListenerContainer$AsyncMessageListenerInvoker.invokeListener(DefaultMessageListenerContainer.java:1102) at org.springframework.jms.listener.DefaultMessageListenerContainer$AsyncMessageListenerInvoker.executeOngoingLoop(DefaultMessageListenerContainer.java:1094) at org.springframework.jms.listener.DefaultMessageListenerContainer$AsyncMessageListenerInvoker.run(DefaultMessageListenerContainer.java:991) at java.lang.Thread.run(Thread.java:745) Caused by: org.osgi.framework.BundleException: Unresolved constraint in bundle org.swift.bamboo.bobswift-run-cli-bamboo [43]: Unable to resolve 43.0: missing requirement [43.0] osgi.wiring.package; (&(osgi.wiring.package=com.atlassian.upm.api.license)(version>=2.0.1)) at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:3974) at org.apache.felix.framework.Felix.startBundle(Felix.java:2037) at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:955) at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:942) at com.atlassian.plugin.osgi.factory.OsgiPlugin.enableInternal(OsgiPlugin.java:374) ... 36 more 2016-04-08 08:33:54,960 INFO [remoteEventRebroadcasterMessageListenerContainer-1] [RemoteAgentPluginManager] Enabling plugin [org.swift.bamboo.acli] 2016-04-08 08:33:54,961 ERROR [remoteEventRebroadcasterMessageListenerContainer-1] [OsgiPluginInstalledHelper] Cannot determine required plugins, cannot resolve bundle 'org.swift.bamboo.bobswift-run-cli-bamboo' 2016-04-08 08:34:54,980 ERROR [remoteEventRebroadcasterMessageListenerContainer-1] [PluginEnabler] Unable to start the following plugins due to timeout while waiting for plugin to enable: org.swift.bamboo.acli }}
    via by Alan Yackel,
  • Cannot load FaCT++ reasoner
    via GitHub by AndreyMZ
    ,
  • Using Service Component Runtime
    via Stack Overflow by Stas Kurilin
    ,
  • GitHub comment 1#148274343
    via GitHub by pzitoun
    ,
    • com.atlassian.plugin.osgi.container.OsgiContainerException: Cannot start plugin: org.swift.bamboo.acli at com.atlassian.plugin.osgi.factory.OsgiPlugin.enableInternal(OsgiPlugin.java:393) at com.atlassian.plugin.impl.AbstractPlugin.enable(AbstractPlugin.java:286) at com.atlassian.plugin.manager.PluginEnabler.actualEnable(PluginEnabler.java:130) at com.atlassian.plugin.manager.PluginEnabler.enable(PluginEnabler.java:107) at com.atlassian.plugin.manager.DefaultPluginManager.enableDependentPlugins(DefaultPluginManager.java:1079) at com.atlassian.plugin.manager.DefaultPluginManager.addPlugins(DefaultPluginManager.java:1055) at com.atlassian.plugin.manager.DefaultPluginManager.scanForNewPlugins(DefaultPluginManager.java:785) at com.atlassian.bamboo.v2.build.agent.remote.plugins.RemoteAgentPluginManager.enablePlugin(RemoteAgentPluginManager.java:51) at com.atlassian.bamboo.v2.build.agent.remote.plugins.RemoteAgentPluginEventHandlerImpl$RemoteAgentPluginManagerAdapter.onEvent(RemoteAgentPluginEventHandlerImpl.java:55) at com.atlassian.bamboo.plugin.events.EnableRemotePluginEvent.deliver(EnableRemotePluginEvent.java:22) at com.atlassian.bamboo.v2.build.agent.remote.plugins.RemoteAgentPluginEventHandlerImpl.deliver(RemoteAgentPluginEventHandlerImpl.java:139) at com.atlassian.bamboo.v2.build.agent.remote.plugins.RemoteAgentPluginEventHandlerImpl.handle(RemoteAgentPluginEventHandlerImpl.java:94) at com.atlassian.bamboo.v2.build.agent.remote.plugins.RemoteAgentPluginEventDeferringListener.onEvent(RemoteAgentPluginEventDeferringListener.java:53) at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62) at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) at java.lang.reflect.Method.invoke(Method.java:497) at com.atlassian.event.internal.SingleParameterMethodListenerInvoker.invoke(SingleParameterMethodListenerInvoker.java:36) at com.atlassian.event.internal.AsynchronousAbleEventDispatcher$1$1.run(AsynchronousAbleEventDispatcher.java:46) at com.google.common.util.concurrent.MoreExecutors$DirectExecutorService.execute(MoreExecutors.java:299) at com.atlassian.event.internal.AsynchronousAbleEventDispatcher.dispatch(AsynchronousAbleEventDispatcher.java:105) at com.atlassian.event.internal.LockFreeEventPublisher$Publisher.dispatch(LockFreeEventPublisher.java:260) at com.atlassian.event.internal.LockFreeEventPublisher.publish(LockFreeEventPublisher.java:102) at com.atlassian.bamboo.v2.build.agent.remote.event.RemoteEventRebroadcasterMessageListener.onMessage(RemoteEventRebroadcasterMessageListener.java:39) at com.atlassian.bamboo.spring.MessageListenerUtils$2.lambda$onMessage$1(MessageListenerUtils.java:42) at com.atlassian.bamboo.spring.MessageListenerUtils.wrapWithFingerprintCheck(MessageListenerUtils.java:55) at com.atlassian.bamboo.spring.MessageListenerUtils.access$000(MessageListenerUtils.java:16) at com.atlassian.bamboo.spring.MessageListenerUtils$2.onMessage(MessageListenerUtils.java:43) at org.springframework.jms.listener.AbstractMessageListenerContainer.doInvokeListener(AbstractMessageListenerContainer.java:562) at org.springframework.jms.listener.AbstractMessageListenerContainer.invokeListener(AbstractMessageListenerContainer.java:500) at org.springframework.jms.listener.AbstractMessageListenerContainer.doExecuteListener(AbstractMessageListenerContainer.java:468) at org.springframework.jms.listener.AbstractPollingMessageListenerContainer.doReceiveAndExecute(AbstractPollingMessageListenerContainer.java:325) at org.springframework.jms.listener.AbstractPollingMessageListenerContainer.receiveAndExecute(AbstractPollingMessageListenerContainer.java:263) at org.springframework.jms.listener.DefaultMessageListenerContainer$AsyncMessageListenerInvoker.invokeListener(DefaultMessageListenerContainer.java:1102) at org.springframework.jms.listener.DefaultMessageListenerContainer$AsyncMessageListenerInvoker.executeOngoingLoop(DefaultMessageListenerContainer.java:1094) at org.springframework.jms.listener.DefaultMessageListenerContainer$AsyncMessageListenerInvoker.run(DefaultMessageListenerContainer.java:991) at java.lang.Thread.run(Thread.java:745) Caused by: org.osgi.framework.BundleException: Unresolved constraint in bundle org.swift.bamboo.bobswift-run-cli-bamboo [43]: Unable to resolve 43.0: missing requirement [43.0] osgi.wiring.package; (&(osgi.wiring.package=com.atlassian.upm.api.license)(version>=2.0.1)) at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:3974) at org.apache.felix.framework.Felix.startBundle(Felix.java:2037) at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:955) at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:942) at com.atlassian.plugin.osgi.factory.OsgiPlugin.enableInternal(OsgiPlugin.java:374) ... 36 more

    Users with the same issue

    davidvanlaatumdavidvanlaatum
    28 times, last one,
    Unknown visitor
    Unknown visitor1 times, last one,
    Unknown visitor
    Unknown visitor1 times, last one,
    Unknown visitor
    Unknown visitor1 times, last one,
    Unknown visitor
    Unknown visitor1 times, last one,
    16 more bugmates