org.mule.umo.model.ModelException

There are no available Samebug tips for this exception. Do you have an idea how to solve this issue? A short tip would help users who saw this issue last week.

  • I created a simple test channel, that picks local files and sends an email with the file content. When I tried deploying, it did not deploy, for an authentic reason. When I rectified that, and tried to redeploy, I have been getting this error and the channel doesnt deploy. [2010-05-10 14:03:15,468] ERROR (com.mirth.connect.server.controllers.MuleEngineController:174): Error registering channel. javax.management.InstanceAlreadyExistsException: MirthConfiguration:type=control,name=c97e329b-c47c-4db1-9be0-2ccdbeac37e6_source_connectorService at com.sun.jmx.mbeanserver.Repository.addMBean(Unknown Source) at com.sun.jmx.interceptor.DefaultMBeanServerInterceptor.internal_addObject(Unknown Source) at com.sun.jmx.interceptor.DefaultMBeanServerInterceptor.registerDynamicMBean(Unknown Source) at com.sun.jmx.interceptor.DefaultMBeanServerInterceptor.registerObject(Unknown Source) at com.sun.jmx.interceptor.DefaultMBeanServerInterceptor.registerMBean(Unknown Source) at com.sun.jmx.mbeanserver.JmxMBeanServer.registerMBean(Unknown Source) at org.mule.management.agents.JmxAgent.registerConnectorService(JmxAgent.java:436) at com.mirth.connect.server.controllers.MuleEngineController.registerConnector(MuleEngineController.java:485) at com.mirth.connect.server.controllers.MuleEngineController.configureInboundRouter(MuleEngineController.java:245) at com.mirth.connect.server.controllers.MuleEngineController.registerChannel(MuleEngineController.java:201) at com.mirth.connect.server.controllers.MuleEngineController.deployChannels(MuleEngineController.java:172) at com.mirth.connect.server.Mirth.deployChannels(Mirth.java:222) at com.mirth.connect.server.Mirth.run(Mirth.java:130) [2010-05-10 14:03:15,468] ERROR (com.mirth.connect.server.controllers.MuleEngineController:564): Error unregistering channel component. org.mule.umo.model.ModelException: The required object/property "UMO Descriptor" is null at org.mule.impl.model.AbstractModel.unregisterComponent(AbstractModel.java:188) at com.mirth.connect.server.controllers.MuleEngineController.unregisterChannel(MuleEngineController.java:562) at com.mirth.connect.server.controllers.MuleEngineController.deployChannels(MuleEngineController.java:177) at com.mirth.connect.server.Mirth.deployChannels(Mirth.java:222) at com.mirth.connect.server.Mirth.run(Mirth.java:130) How do we get rid of this?
    via by Deepa Rao,
  • I created a simple test channel, that picks local files and sends an email with the file content. When I tried deploying, it did not deploy, for an authentic reason. When I rectified that, and tried to redeploy, I have been getting this error and the channel doesnt deploy. [2010-05-10 14:03:15,468] ERROR (com.mirth.connect.server.controllers.MuleEngineController:174): Error registering channel. javax.management.InstanceAlreadyExistsException: MirthConfiguration:type=control,name=c97e329b-c47c-4db1-9be0-2ccdbeac37e6_source_connectorService at com.sun.jmx.mbeanserver.Repository.addMBean(Unknown Source) at com.sun.jmx.interceptor.DefaultMBeanServerInterceptor.internal_addObject(Unknown Source) at com.sun.jmx.interceptor.DefaultMBeanServerInterceptor.registerDynamicMBean(Unknown Source) at com.sun.jmx.interceptor.DefaultMBeanServerInterceptor.registerObject(Unknown Source) at com.sun.jmx.interceptor.DefaultMBeanServerInterceptor.registerMBean(Unknown Source) at com.sun.jmx.mbeanserver.JmxMBeanServer.registerMBean(Unknown Source) at org.mule.management.agents.JmxAgent.registerConnectorService(JmxAgent.java:436) at com.mirth.connect.server.controllers.MuleEngineController.registerConnector(MuleEngineController.java:485) at com.mirth.connect.server.controllers.MuleEngineController.configureInboundRouter(MuleEngineController.java:245) at com.mirth.connect.server.controllers.MuleEngineController.registerChannel(MuleEngineController.java:201) at com.mirth.connect.server.controllers.MuleEngineController.deployChannels(MuleEngineController.java:172) at com.mirth.connect.server.Mirth.deployChannels(Mirth.java:222) at com.mirth.connect.server.Mirth.run(Mirth.java:130) [2010-05-10 14:03:15,468] ERROR (com.mirth.connect.server.controllers.MuleEngineController:564): Error unregistering channel component. org.mule.umo.model.ModelException: The required object/property "UMO Descriptor" is null at org.mule.impl.model.AbstractModel.unregisterComponent(AbstractModel.java:188) at com.mirth.connect.server.controllers.MuleEngineController.unregisterChannel(MuleEngineController.java:562) at com.mirth.connect.server.controllers.MuleEngineController.deployChannels(MuleEngineController.java:177) at com.mirth.connect.server.Mirth.deployChannels(Mirth.java:222) at com.mirth.connect.server.Mirth.run(Mirth.java:130) How do we get rid of this?
    via by Deepa Rao,
    • org.mule.umo.model.ModelException: The required object/property "UMO Descriptor" is null at org.mule.impl.model.AbstractModel.unregisterComponent(AbstractModel.java:188) at com.mirth.connect.server.controllers.MuleEngineController.unregisterChannel(MuleEngineController.java:562) at com.mirth.connect.server.controllers.MuleEngineController.deployChannels(MuleEngineController.java:177) at com.mirth.connect.server.Mirth.deployChannels(Mirth.java:222) at com.mirth.connect.server.Mirth.run(Mirth.java:130)
    No Bugmate found.