org.mule.api.MuleRuntimeException: MBeans Failed to initialise

Searched on Google with the first line of a JAVA stack trace?

We can recommend more relevant solutions and speed up debugging when you paste your entire stack trace with the exception message. Try a sample exception.

Recommended solutions based on your search

Samebug tips

Do you know how to solve this issue? Write a tip to help other users and build your expert profile.

Solutions on the web

via MuleSoft JIRA by Daniel Zapata, 1 year ago
MBeans Failed to initialise
via MuleSoft JIRA by Daniel Zapata, 1 year ago
MBeans Failed to initialise
via MuleSoft JIRA by Emiliano Lesende, 1 year ago
MBeans Failed to initialise
org.mule.api.MuleRuntimeException: MBeans Failed to initialise
at com.sun.jmx.mbeanserver.Repository.addMBean(Repository.java:453)
at com.sun.jmx.interceptor.DefaultMBeanServerInterceptor.internal_addObject(DefaultMBeanServerInterceptor.java:1484)
at com.sun.jmx.interceptor.DefaultMBeanServerInterceptor.registerDynamicMBean(DefaultMBeanServerInterceptor.java:963)
at com.sun.jmx.interceptor.DefaultMBeanServerInterceptor.registerObject(DefaultMBeanServerInterceptor.java:917)
at com.sun.jmx.interceptor.DefaultMBeanServerInterceptor.registerMBean(DefaultMBeanServerInterceptor.java:312)
at org.mule.module.management.agent.JmxAgent.registerConnectorServices(JmxAgent.java:440)
at org.mule.module.management.agent.JmxAgent$MuleContextStartedListener.onNotification(JmxAgent.java:581)
at org.mule.context.notification.Sender.dispatch(Sender.java:40)
at org.mule.context.notification.Policy.dispatch(Policy.java:123)
at org.mule.context.notification.ServerNotificationManager.notifyListeners(ServerNotificationManager.java:221)
at org.mule.context.notification.ServerNotificationManager.fireNotification(ServerNotificationManager.java:174)
at org.mule.DefaultMuleContext.fireNotification(DefaultMuleContext.java:425)
at org.mule.DefaultMuleContext.start(DefaultMuleContext.java:240)
at org.mule.tck.AbstractMuleTestCase.setUp(AbstractMuleTestCase.java:395)
at junit.framework.TestCase.runBare(TestCase.java:132)
at org.mule.tck.AbstractMuleTestCase.runBare(AbstractMuleTestCase.java:277)
at junit.framework.TestResult$1.protect(TestResult.java:110)
at junit.framework.TestResult.runProtected(TestResult.java:128)
at junit.framework.TestResult.run(TestResult.java:113)
at junit.framework.TestCase.run(TestCase.java:124)
at org.mule.tck.AbstractMuleTestCase.run(AbstractMuleTestCase.java:256)
at junit.framework.TestSuite.runTest(TestSuite.java:232)
at junit.framework.TestSuite.run(TestSuite.java:227)
at org.eclipse.jdt.internal.junit.runner.TestExecution.run(TestExecution.java:38)
at org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.runTests(RemoteTestRunner.java:467)
at org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.runTests(RemoteTestRunner.java:683)
at org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.run(RemoteTestRunner.java:390)

Users with the same issue

2 times, 1 month ago
Once, 4 months ago
4 times, 4 months ago
1270 times, 5 months ago
3 times, 11 months ago

Write tip

Know the solutions? Share your knowledge to help other developers to debug faster.