java.lang.NoClassDefFoundError

There are no available Samebug tips for this exception. Do you have an idea how to solve this issue? A short tip would help users who saw this issue last week.

  • Re: Getting OpenWebBeans working in WebLogic 11g
    via by Unknown author,
  • Re: Getting OpenWebBeans working in WebLogic 11g
    via by Mark Struberg,
  • Re: Getting OpenWebBeans working in WebLogic 11g
    via by Rafael Pestano,
  • class not found exception with log4j.jar
    via by Syed Arshad,
  • NEWBIE Servlet Deploy question...
    via by Kai Jang,
  • Exception while deploying war
    via by Rajashekar Narsina,
    • java.lang.NoClassDefFoundError: org.apache.commons.logging.LogFactory. at weblogic.servlet.internal.ServletStubImpl.prepareServlet(ServletStubImpl.java:800) at weblogic.servlet.internal.WebAppServletContext.preloadServlet(WebAppServletContext.java:3236) at weblogic.servlet.internal.WebAppServletContext.preloadServlets(WebAppServletContext.java:3181) at weblogic.servlet.internal.WebAppServletContext.preloadResources(WebAppServletContext.java:3154) at weblogic.servlet.internal.WebAppServletContext.setStarted(WebAppServletContext.java:5637) at weblogic.servlet.internal.WebAppModule.start(WebAppModule.java:866) at weblogic.j2ee.J2EEApplicationContainer.start(J2EEApplicationContainer.java:2017) at weblogic.j2ee.J2EEApplicationContainer.activate(J2EEApplicationContainer.java:2058) at weblogic.management.deploy.slave.SlaveDeployer$ComponentActivateTask.activateContainer(SlaveDeployer.java:2624) at weblogic.management.deploy.slave.SlaveDeployer$ActivateTask.doCommit(SlaveDeployer.java:2547) at weblogic.management.deploy.slave.SlaveDeployer$Task.commit(SlaveDeployer.java:2349) at weblogic.management.deploy.slave.SlaveDeployer$Task.checkAutoCommit(SlaveDeployer.java:2431) at weblogic.management.deploy.slave.SlaveDeployer$Task.prepare(SlaveDeployer.java:2343) at weblogic.management.deploy.slave.SlaveDeployer$ActivateTask.prepare(SlaveDeployer.java:2511) at weblogic.management.deploy.slave.SlaveDeployer.processPrepareTask(SlaveDeployer.java:833) at weblogic.management.deploy.slave.SlaveDeployer.prepareDelta(SlaveDeployer.java:542) at weblogic.management.deploy.slave.SlaveDeployer.prepareUpdate(SlaveDeployer.java:500) at weblogic.drs.internal.SlaveCallbackHandler$1.execute(SlaveCallbackHandler.java:25) at weblogic.kernel.ExecuteThread.execute(ExecuteThread.java:197) at weblogic.kernel.ExecuteThread.run(ExecuteThread.java:170)
    No Bugmate found.