java.lang.IllegalArgumentException: wrong number of arguments

Searched on Google with the first line of a JAVA stack trace?

We can recommend more relevant solutions and speed up debugging when you paste your entire stack trace with the exception message. Try a sample exception.

Recommended solutions based on your search

Samebug tips

,

Thrown to indicate that a method has been passed an illegal or inappropriate argument. Check that you don't have more than one method existing with the same name.

Solutions on the web

via Appcelerator JIRA by Nam Le, 1 year ago
wrong number of arguments
via Appcelerator JIRA by Nam Le, 1 year ago
wrong number of arguments
via Appcelerator JIRA by Ingo Muschenetz, 1 year ago
wrong number of arguments
via Appcelerator JIRA by Ingo Muschenetz, 1 year ago
wrong number of arguments
via Stack Overflow by curlip
, 2 years ago
wrong number of arguments
via Oracle Community by 843798, 1 year ago
object is not an instance of declaring class
java.lang.IllegalArgumentException: wrong number of arguments
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at com.aptana.portal.ui.dispatch.actionControllers.AbstractActionController.invokeAction(AbstractActionController.java:101)
at com.aptana.portal.ui.dispatch.browserFunctions.DispatcherBrowserFunction.dispatch(DispatcherBrowserFunction.java:138)
at com.aptana.portal.ui.dispatch.browserFunctions.DispatcherBrowserFunction.function(DispatcherBrowserFunction.java:122)
at com.aptana.portal.ui.internal.BrowserWrapper$2.function(BrowserWrapper.java:51)
at org.eclipse.swt.browser.WebSite.Invoke(WebSite.java:763)
at org.eclipse.swt.internal.ole.win32.COMObject.callback6(COMObject.java:119)
at org.eclipse.swt.internal.win32.OS.DispatchMessageW(Native Method)
at org.eclipse.swt.internal.win32.OS.DispatchMessage(OS.java:2531)
at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.java:2696)
at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:2660)
at org.eclipse.ui.internal.Workbench.access$4(Workbench.java:2494)
at com.appcelerator.titanium.rcp.IDEApplication.start(IDEApplication.java:125)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:344)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:622)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:577)
at org.eclipse.equinox.launcher.Main.run(Main.java:1410)

Users with the same issue

Samebug visitor profile picture
Unknown user
Once, 1 year ago
6 times, 3 months ago
Samebug visitor profile picture
Unknown user
Once, 1 year ago
Samebug visitor profile picture
Unknown user
Once, 1 year ago
Once, 1 year ago

Write tip

Know the solutions? Share your knowledge to help other developers to debug faster.