weblogic.utils.AssertionError: ***** ASSERTION FAILED *****[ Failed to generate class for weblogic.common.i nternal.RMIBootServiceImpl_811_WLStub ] - with nested exception: [wldeploy] [java.lang.NullPointerException] [wldeploy]

There are no available Samebug tips for this exception. Do you have an idea how to solve this issue? A short tip would help users who saw this issue last week.

  • exception when using wldeploy ant task
    via by 3004,
  • problem with weblogic.Deployer in 8.1
    via by 3004,
  • weblogic ant redeploy failing
    via by 3004,
  • weblogic ant redeploy failing
    via by 3004,
  • Wldeploy errors
    via by 3004,
  • JNDI Provider Connection With Weblogic 8.1
    via by 807581,
  • Connection Leak
    via by 843859,
  • java.lang.reflect.InvocationTargetException
    via by Adrian Morales,
    • weblogic.utils.AssertionError: ***** ASSERTION FAILED *****[ Failed to generate class for weblogic.common.i nternal.RMIBootServiceImpl_811_WLStub ] - with nested exception: [wldeploy] [java.lang.NullPointerException] [wldeploy] at weblogic.rmi.internal.StubGenerator.generateStub(StubGenerator.java:807)[wldeploy] at weblogic.rmi.internal.StubGenerator.generateStub(StubGenerator.java:790)[wldeploy] at weblogic.rmi.extensions.StubFactory.getStub(StubFactory.java:79)[wldeploy] at weblogic.common.internal.RMIBootServiceStub.getStub(RMIBootServiceStub.java:50)[wldeploy] at weblogic.security.acl.internal.Security.authenticate(Security.java:152)[wldeploy] at weblogic.jndi.WLInitialContextFactoryDelegate.authenticateRemotely(WLInitialContextFactoryDelegate.java:597)[wldeploy] at weblogic.jndi.WLInitialContextFactoryDelegate.pushSubject(WLInitialContextFactoryDelegate.java:534)[wldeploy] at weblogic.jndi.WLInitialContextFactoryDelegate.newContext(WLInitialContextFactoryDelegate.java:336)[wldeploy] at weblogic.jndi.WLInitialContextFactoryDelegate.getInitialContext(WLInitialContextFactoryDelegate.java:308)[wldeploy] at weblogic.jndi.Environment.getContext(Environment.java:164)[wldeploy] at weblogic.jndi.Environment.getInitialContext(Environment.java:143)[wldeploy] at weblogic.management.deploy.utils.MBeanHomeTool.getMBeanHome(MBeanHomeTool.java:157)[wldeploy] at weblogic.Deployer.runBody(Deployer.java:555)[wldeploy] at weblogic.utils.compiler.Tool.run(Tool.java:146)[wldeploy] at weblogic.utils.compiler.Tool.run(Tool.java:103)[wldeploy] at weblogic.Deployer.main(Deployer.java:399)
    No Bugmate found.