org.osgi.framework.BundleException

There are no available Samebug tips for this exception. Do you have an idea how to solve this issue? A short tip would help users who saw this issue last week.

  • Missing bundle in Jdeveloper Upgrading Maf to 2.1.1
    via by 84665a67-53f6-4076-95af-8f233a0efd27,
  • NetBeans NetCAT: db@netcat.netbeans.org: Archive
    via by Unknown author,
  • Run Java 8 application on eclipse 3.7
    via Stack Overflow by D3_GXT_Java
    ,
  • Vega, issue on startup
    via GitHub by SinisterShade
    ,
    • org.osgi.framework.BundleException: The bundle "com.oracle.jdeveloper.nbnavigator_1.0.0 [920]" could not be resolved. Reason: Missing Constraint: Require-Bundle: oracle.ide; bundle-version="[11.1.2,100.0.0)" at org.eclipse.osgi.framework.internal.core.AbstractBundle.getResolverError(AbstractBundle.java:1332) at org.eclipse.osgi.framework.internal.core.AbstractBundle.getResolutionFailureException(AbstractBundle.java:1316) at org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:323) at org.eclipse.osgi.framework.internal.core.AbstractBundle.resume(AbstractBundle.java:390) at org.eclipse.osgi.framework.internal.core.Framework.resumeBundle(Framework.java:1177) at org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:559) at org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:544) at org.eclipse.osgi.framework.internal.core.StartLevelManager.incFWSL(StartLevelManager.java:457) at org.eclipse.osgi.framework.internal.core.StartLevelManager.doSetStartLevel(StartLevelManager.java:243) at org.eclipse.osgi.framework.internal.core.EquinoxLauncher.internalStart(EquinoxLauncher.java:271) at org.eclipse.osgi.framework.internal.core.EquinoxLauncher.start(EquinoxLauncher.java:241) at org.eclipse.osgi.launch.Equinox.start(Equinox.java:258) at org.netbeans.core.netigso.Netigso.start(Netigso.java:190) at org.netbeans.NetigsoHandle.startFramework(NetigsoHandle.java:198) at org.netbeans.ModuleManager.enable(ModuleManager.java:1189) at org.netbeans.ModuleManager.enable(ModuleManager.java:1011) at org.netbeans.core.startup.ModuleList.installNew(ModuleList.java:340) at org.netbeans.core.startup.ModuleList.trigger(ModuleList.java:276) at org.netbeans.core.startup.ModuleSystem.restore(ModuleSystem.java:301) at org.netbeans.core.startup.Main.getModuleSystem(Main.java:181) at org.netbeans.core.startup.Main.getModuleSystem(Main.java:150) at org.netbeans.core.startup.Main.start(Main.java:307) at org.netbeans.core.startup.TopThreadGroup.run(TopThreadGroup.java:123) at java.lang.Thread.run(Thread.java:744)

    Users with the same issue

    Unknown visitor
    Unknown visitor1 times, last one,
    poroszdporoszd
    6 times, last one,
    Unknown visitor
    Unknown visitor1 times, last one,
    Unknown visitor
    Unknown visitor1 times, last one,