Searched on Google with the first line of a JAVA stack trace?

We can recommend more relevant solutions and speed up debugging when you paste your entire stack trace with the exception message. Try a sample exception.

Recommended solutions based on your search

Samebug tips

  1. ,

    Provide a working directory instead of pointing it to a file or an empty directory in process builder.

  2. ,
    Expert tip

    This is a bug in some versions of the Arduino IDE. Try updating to the version 1.6.12 or further.

Solutions on the web

via GitHub by ltsjames
, 1 year ago
brut.androlib.AndrolibException: brut.common.BrutException: could not exec: [/data/data/per.pqy.apktool/apktool/openjdk/bin/aaptnew, p, --min-sdk-version, 14, --target-sdk-version, 21, --version-code, 143, --version-name, 10.8.5.7666, -F, /data/data
via 4pda.ru by Unknown author, 2 years ago
brut.androlib.AndrolibException: brut.common.BrutException: could not exec command: [/data/data/per.pqy.apktool/apktool/openjdk/bin/aaptnew, p, --min-sdk-version, 14, --target-sdk-version, 22, --version-code, 20200140, --version-name, 2.2.0.140, -F
via catatandroid.com by Unknown author, 2 years ago
brut.androlib.AndrolibException: brut.common.BrutException: could not exec command: [/data/data/per.pqy.apktool/apktool/openjdk/bin/aaptnew, p, --min-sdk-version, 21, --target-sdk-version, 21, --version-code, 1231505221, --version-name, 1.2.3.150522
via GitHub by giorkam80
, 2 years ago
brut.androlib.AndrolibException: brut.common.BrutException: could not exec command: [/data/data/per.pqy.apktool/apktool/openjdk/bin/aaptnew, p, --min-sdk-version, 21, --target-sdk-version, 21, --version-code, 21, --version-name, 5.0.2-G901FXXU1BOH4
via GitHub by PLUKo
, 2 years ago
brut.androlib.AndrolibException: brut.common.BrutException: could not exec command: [/data/data/per.pqy.apktool/apktool/openjdk/bin/aaptnew, p, --min-sdk-version, 14, --target-sdk-version, 19, --version-code, 1501131305, --version-name, 1.0, -F
via 4pda.ru by Unknown author, 2 years ago
brut.androlib.AndrolibException: brut.common.BrutException: could not exec command: [/data/data/per.pqy.apktool/apktool/openjdk/bin/aaptnew, p, --min-sdk-version, 19, --target-sdk-version, 19, --version-code, 19, --version-name, 4.4.2, -F, /data
java.io.IOException: error=13, Permission denied	at java.lang.UNIXProcess.forkAndExec(Native Method)	at java.lang.UNIXProcess.(UNIXProcess.java:186)	at java.lang.ProcessImpl.start(ProcessImpl.java:130)	at java.lang.ProcessBuilder.start(ProcessBuilder.java:1028)	at brut.util.OS.exec(OS.java:90)	at brut.androlib.res.AndrolibResources.aaptPackage(AndrolibResources.java:430)	at brut.androlib.Androlib.buildResourcesFull(Androlib.java:423)	at brut.androlib.Androlib.buildResources(Androlib.java:371)	at brut.androlib.Androlib.build(Androlib.java:281)	at brut.androlib.Androlib.build(Androlib.java:254)	at brut.apktool.Main.cmdBuild(Main.java:224)	at brut.apktool.Main.main(Main.java:84)