java.lang.NullPointerException

There are no available Samebug tips for this exception. Do you have an idea how to solve this issue? A short tip would help users who saw this issue last week.

  • Null Pointer after successful Maven build
    via by Tim Pizey,
  • Tomcat 7.020, Windows 7, Jenkins 1.426, Maven 3 build, SCM Perforce, using the Perforce plug in. Each build is successful, but at the end of the build, the following is reported. [INFO] ------------------------------------------------------------------------ [INFO] Reactor Summary: [INFO] [INFO] cciAdapter ........................................ SUCCESS [0.577s] [INFO] cciAdapter-core ................................... SUCCESS [2.655s] [INFO] cciAdapter-ftp .................................... SUCCESS [1.092s] [INFO] cciAdapter-ws Spring-WS Application ............... SUCCESS [0.996s] [INFO] ------------------------------------------------------------------------ [INFO] BUILD SUCCESS [INFO] ------------------------------------------------------------------------ [INFO] Total time: 6.257s [INFO] Finished at: Tue Aug 16 14:11:50 BST 2011 [INFO] Final Memory: 19M/123M [INFO] ------------------------------------------------------------------------ Waiting for Jenkins to finish collecting data channel stopped FATAL: null java.lang.NullPointerException at hudson.maven.MavenModuleSetBuild$RunnerImpl.doRun(MavenModuleSetBuild.java:833) at hudson.model.AbstractBuild$AbstractRunner.run(AbstractBuild.java:448) at hudson.model.Run.run(Run.java:1376) at hudson.maven.MavenModuleSetBuild.run(MavenModuleSetBuild.java:479) at hudson.model.ResourceController.execute(ResourceController.java:88) at hudson.model.Executor.run(Executor.java:230) Full log file is attached.
    via by Scott Marshall,
  • Tomcat 7.020, Windows 7, Jenkins 1.426, Maven 3 build, SCM Perforce, using the Perforce plug in. Each build is successful, but at the end of the build, the following is reported. [INFO] ------------------------------------------------------------------------ [INFO] Reactor Summary: [INFO] [INFO] cciAdapter ........................................ SUCCESS [0.577s] [INFO] cciAdapter-core ................................... SUCCESS [2.655s] [INFO] cciAdapter-ftp .................................... SUCCESS [1.092s] [INFO] cciAdapter-ws Spring-WS Application ............... SUCCESS [0.996s] [INFO] ------------------------------------------------------------------------ [INFO] BUILD SUCCESS [INFO] ------------------------------------------------------------------------ [INFO] Total time: 6.257s [INFO] Finished at: Tue Aug 16 14:11:50 BST 2011 [INFO] Final Memory: 19M/123M [INFO] ------------------------------------------------------------------------ Waiting for Jenkins to finish collecting data channel stopped FATAL: null java.lang.NullPointerException at hudson.maven.MavenModuleSetBuild$RunnerImpl.doRun(MavenModuleSetBuild.java:833) at hudson.model.AbstractBuild$AbstractRunner.run(AbstractBuild.java:448) at hudson.model.Run.run(Run.java:1376) at hudson.maven.MavenModuleSetBuild.run(MavenModuleSetBuild.java:479) at hudson.model.ResourceController.execute(ResourceController.java:88) at hudson.model.Executor.run(Executor.java:230) Full log file is attached.
    via by Scott Marshall,
  • Tomcat 7.020, Windows 7, Jenkins 1.426, Maven 3 build, SCM Perforce, using the Perforce plug in. Each build is successful, but at the end of the build, the following is reported. [INFO] ------------------------------------------------------------------------ [INFO] Reactor Summary: [INFO] [INFO] cciAdapter ........................................ SUCCESS [0.577s] [INFO] cciAdapter-core ................................... SUCCESS [2.655s] [INFO] cciAdapter-ftp .................................... SUCCESS [1.092s] [INFO] cciAdapter-ws Spring-WS Application ............... SUCCESS [0.996s] [INFO] ------------------------------------------------------------------------ [INFO] BUILD SUCCESS [INFO] ------------------------------------------------------------------------ [INFO] Total time: 6.257s [INFO] Finished at: Tue Aug 16 14:11:50 BST 2011 [INFO] Final Memory: 19M/123M [INFO] ------------------------------------------------------------------------ Waiting for Jenkins to finish collecting data channel stopped FATAL: null java.lang.NullPointerException at hudson.maven.MavenModuleSetBuild$RunnerImpl.doRun(MavenModuleSetBuild.java:833) at hudson.model.AbstractBuild$AbstractRunner.run(AbstractBuild.java:448) at hudson.model.Run.run(Run.java:1376) at hudson.maven.MavenModuleSetBuild.run(MavenModuleSetBuild.java:479) at hudson.model.ResourceController.execute(ResourceController.java:88) at hudson.model.Executor.run(Executor.java:230) Full log file is attached.
    via by Scott Marshall,
    • java.lang.NullPointerException at hudson.maven.MavenModuleSetBuild$RunnerImpl.doRun(MavenModuleSetBuild.java:833) at hudson.model.AbstractBuild$AbstractRunner.run(AbstractBuild.java:448) at hudson.model.Run.run(Run.java:1376) at hudson.maven.MavenModuleSetBuild.run(MavenModuleSetBuild.java:479) at hudson.model.ResourceController.execute(ResourceController.java:88) at hudson.model.Executor.run(Executor.java:230)
    No Bugmate found.