java.lang.NullPointerException

There are no available Samebug tips for this exception. Do you have an idea how to solve this issue? A short tip would help users who saw this issue last week.

  • After upgrading to the current nightly (3.1.0.201212191959) I get the following error on start up in Windows 8: {code} !ENTRY org.eclipse.core.jobs 4 2 2012-12-20 08:04:09.152 !MESSAGE An internal error occurred during: "Initializing Mobile UI Plugin". !STACK 0 java.lang.NullPointerException at com.aptana.ui.BrowserManager.<init>(BrowserManager.java:54) at com.aptana.ui.BrowserManager.getInstance(BrowserManager.java:47) at com.appcelerator.titanium.mobile.ui.MobileUIPlugin$1.run(MobileUIPlugin.java:156) at org.eclipse.core.internal.jobs.Worker.run(Worker.java:54) {code} And in Mac OS: {code} !ENTRY org.eclipse.core.jobs 4 2 2012-12-20 08:05:32.315 !MESSAGE An internal error occurred during: "Initializing Mobile UI Plugin". !STACK 0 java.lang.NullPointerException at org.eclipse.jface.resource.JFaceResources.getResources(JFaceResources.java:207) at org.eclipse.jface.resource.ImageRegistry.<init>(ImageRegistry.java:152) at org.eclipse.jface.resource.ImageRegistry.<init>(ImageRegistry.java:124) at org.eclipse.ui.internal.WorkbenchImages.initializeImageRegistry(WorkbenchImages.java:641) at org.eclipse.ui.internal.WorkbenchImages.getDescriptors(WorkbenchImages.java:530) at org.eclipse.ui.internal.WorkbenchImages.getImageDescriptor(WorkbenchImages.java:566) at org.eclipse.ui.internal.SharedImages.getImageDescriptor(SharedImages.java:47) at org.eclipse.ui.plugin.AbstractUIPlugin.imageDescriptorFromPlugin(AbstractUIPlugin.java:671) at com.appcelerator.titanium.mobile.ui.MobileUIPlugin$1.run(MobileUIPlugin.java:142) at org.eclipse.core.internal.jobs.Worker.run(Worker.java:54) {code} This is a regression as this does not occur in Titanium Studio, build: 3.0.1.201212181159. Steps to reproduce: 1. Start Titanium Studio. Expected result: Studio launches without error. Actual result: Slight pause then the above error.
    via by Clayton Headley,
  • After upgrading to the current nightly (3.1.0.201212191959) I get the following error on start up in Windows 8: {code} !ENTRY org.eclipse.core.jobs 4 2 2012-12-20 08:04:09.152 !MESSAGE An internal error occurred during: "Initializing Mobile UI Plugin". !STACK 0 java.lang.NullPointerException at com.aptana.ui.BrowserManager.<init>(BrowserManager.java:54) at com.aptana.ui.BrowserManager.getInstance(BrowserManager.java:47) at com.appcelerator.titanium.mobile.ui.MobileUIPlugin$1.run(MobileUIPlugin.java:156) at org.eclipse.core.internal.jobs.Worker.run(Worker.java:54) {code} And in Mac OS: {code} !ENTRY org.eclipse.core.jobs 4 2 2012-12-20 08:05:32.315 !MESSAGE An internal error occurred during: "Initializing Mobile UI Plugin". !STACK 0 java.lang.NullPointerException at org.eclipse.jface.resource.JFaceResources.getResources(JFaceResources.java:207) at org.eclipse.jface.resource.ImageRegistry.<init>(ImageRegistry.java:152) at org.eclipse.jface.resource.ImageRegistry.<init>(ImageRegistry.java:124) at org.eclipse.ui.internal.WorkbenchImages.initializeImageRegistry(WorkbenchImages.java:641) at org.eclipse.ui.internal.WorkbenchImages.getDescriptors(WorkbenchImages.java:530) at org.eclipse.ui.internal.WorkbenchImages.getImageDescriptor(WorkbenchImages.java:566) at org.eclipse.ui.internal.SharedImages.getImageDescriptor(SharedImages.java:47) at org.eclipse.ui.plugin.AbstractUIPlugin.imageDescriptorFromPlugin(AbstractUIPlugin.java:671) at com.appcelerator.titanium.mobile.ui.MobileUIPlugin$1.run(MobileUIPlugin.java:142) at org.eclipse.core.internal.jobs.Worker.run(Worker.java:54) {code} This is a regression as this does not occur in Titanium Studio, build: 3.0.1.201212181159. Steps to reproduce: 1. Start Titanium Studio. Expected result: Studio launches without error. Actual result: Slight pause then the above error.
    via by Clayton Headley,
    • java.lang.NullPointerException at com.aptana.ui.BrowserManager.<init>(BrowserManager.java:54) at com.aptana.ui.BrowserManager.getInstance(BrowserManager.java:47) at com.appcelerator.titanium.mobile.ui.MobileUIPlugin$1.run(MobileUIPlugin.java:156) at org.eclipse.core.internal.jobs.Worker.run(Worker.java:54)
    No Bugmate found.