org.osgi.framework.BundleException: Could not resolve module: org.eclipse.ui.workbench.texteditor [81] Unresolved requirement: Require-Bundle: org.eclipse.compare.core; bundle-version="[3.5.0,4.0.0)"

eclipse.org | 9 months ago
tip
Do you know that we can give you better hits? Get more relevant results from Samebug’s stack trace search.
  1. 0

    Eclipse Community Forums

    eclipse.org | 9 months ago
    org.osgi.framework.BundleException: Could not resolve module: org.eclipse.ui.workbench.texteditor [81] Unresolved requirement: Require-Bundle: org.eclipse.compare.core; bundle-version="[3.5.0,4.0.0)"
  2. 0

    [pde-dev] Starting a runtime Eclipse fails with Exception in org.eclipse

    eclipse.org | 8 months ago
    org.osgi.framework.BundleException: Could not resolve module: org.eclipse.pde.api.tools.tests [267] Unresolved requirement: Require-Bundle: org.eclipse.test.performance
  3. 0

    [CloudDesigner]When running eclipse from CloudDesigner, some mylyn dependencies not found

    GitHub | 6 months ago | cgourdin
    org.osgi.framework.BundleException: Could not resolve module: org.eclipse.mylyn.tasks.ui [4989] Unresolved requirement: Require-Bundle: org.eclipse.mylyn.monitor.ui; bundle-version="3.8.0" -> Bundle-SymbolicName: org.eclipse.mylyn.monitor.ui; bundle-version="3.20.0.v20160421-1819"; singleton:="true" org.eclipse.mylyn.monitor.ui [4984] Unresolved requirement: Require-Bundle: org.eclipse.mylyn.context.core; bundle-version="[3.0.0,4.0.0)" -> Bundle-SymbolicName: org.eclipse.mylyn.context.core; bundle-version="3.20.0.v20160421-1902"; singleton:="true" org.eclipse.mylyn.context.core [4979] Unresolved requirement: Import-Package: org.apache.commons.io; version="[1.4.0,3.0.0)"
  4. Speed up your debug routine!

    Automated exception search integrated into your IDE

  5. 0

    Investigate bundle exception relative to OS

    GitHub | 6 months ago | yoosiba
    org.osgi.framework.BundleException: Could not resolve module: org.eclipse.compare.win32 [297] Unresolved requirement: Require-Capability: eclipse.platform; filter:="(osgi.os=win32)"
  6. 0

    OSGI errors

    GitHub | 5 months ago | mjtapp
    org.osgi.framework.BundleException: Could not resolve module: com.archimatetool.hammer [17] Another singleton bundle selected: osgi.identity; osgi.identity="com.archimatetool.hammer"; type="osgi.bundle"; version:Version="4.0.0.201611021627"; singleton:="true"

    47 unregistered visitors
    Not finding the right solution?
    Take a tour to get the most out of Samebug.

    Tired of useless tips?

    Automated exception search integrated into your IDE

    Root Cause Analysis

    1. org.osgi.framework.BundleException

      Could not resolve module: org.eclipse.ui.workbench.texteditor [81] Unresolved requirement: Require-Bundle: org.eclipse.compare.core; bundle-version="[3.5.0,4.0.0)"

      at org.eclipse.osgi.container.Module.start()
    2. Eclipse OSGi
      EventManager$EventThread.run
      1. org.eclipse.osgi.container.Module.start(Module.java:444)
      2. org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1620)
      3. org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1599)
      4. org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1571)
      5. org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1514)
      6. org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
      7. org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
      8. org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)
      8 frames