java.lang.UnsupportedClassVersionError: org/dspace/storage/rdbms/DatabaseUtils : Unsupported major.minor version 51.0

Sakai JIRA | vimal | 2 years ago
  1. 0

    Skip to content Using Gmail with screen readers Take me to Inbox 8 of 6,752 to Dspace Dear Friends, I got following error in the final step of Dspace installation. You got such errors before? root@user1:/build/dspace-5.1-src-release/dspace/target/dspace-installer# sudo ant fresh_install Unable to locate tools.jar. Expected to find it in /usr/lib/jvm/java-6-openjdk-amd64/lib/tools.jar Buildfile: /build/dspace-5.1-src-release/dspace/target/dspace-installer/build.xml init_installation: init_configs: [copy] Copying 41 files to /dspace/config [copy] Copying 1 file to /dspace/config test_database: [java] Exception in thread "main" java.lang.UnsupportedClassVersionError: org/dspace/storage/rdbms/DatabaseUtils : Unsupported major.minor version 51.0 [java] at java.lang.ClassLoader.defineClass1(Native Method) [java] at java.lang.ClassLoader.defineClass(ClassLoader.java:643) [java] at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:142) [java] at java.net.URLClassLoader.defineClass(URLClassLoader.java:277) [java] at java.net.URLClassLoader.access$000(URLClassLoader.java:73) [java] at java.net.URLClassLoader$1.run(URLClassLoader.java:212) [java] at java.security.AccessController.doPrivileged(Native Method) [java] at java.net.URLClassLoader.findClass(URLClassLoader.java:205) [java] at java.lang.ClassLoader.loadClass(ClassLoader.java:323) [java] at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:294) [java] at java.lang.ClassLoader.loadClass(ClassLoader.java:268) [java] Could not find the main class: org.dspace.storage.rdbms.DatabaseUtils. Program will exit. BUILD FAILED /build/dspace-5.1-src-release/dspace/target/dspace-installer/build.xml:797: Java returned: 1 Total time: 4 seconds

    Sakai JIRA | 2 years ago | vimal
    java.lang.UnsupportedClassVersionError: org/dspace/storage/rdbms/DatabaseUtils : Unsupported major.minor version 51.0
  2. 0

    Skip to content Using Gmail with screen readers Take me to Inbox 8 of 6,752 to Dspace Dear Friends, I got following error in the final step of Dspace installation. You got such errors before? root@user1:/build/dspace-5.1-src-release/dspace/target/dspace-installer# sudo ant fresh_install Unable to locate tools.jar. Expected to find it in /usr/lib/jvm/java-6-openjdk-amd64/lib/tools.jar Buildfile: /build/dspace-5.1-src-release/dspace/target/dspace-installer/build.xml init_installation: init_configs: [copy] Copying 41 files to /dspace/config [copy] Copying 1 file to /dspace/config test_database: [java] Exception in thread "main" java.lang.UnsupportedClassVersionError: org/dspace/storage/rdbms/DatabaseUtils : Unsupported major.minor version 51.0 [java] at java.lang.ClassLoader.defineClass1(Native Method) [java] at java.lang.ClassLoader.defineClass(ClassLoader.java:643) [java] at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:142) [java] at java.net.URLClassLoader.defineClass(URLClassLoader.java:277) [java] at java.net.URLClassLoader.access$000(URLClassLoader.java:73) [java] at java.net.URLClassLoader$1.run(URLClassLoader.java:212) [java] at java.security.AccessController.doPrivileged(Native Method) [java] at java.net.URLClassLoader.findClass(URLClassLoader.java:205) [java] at java.lang.ClassLoader.loadClass(ClassLoader.java:323) [java] at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:294) [java] at java.lang.ClassLoader.loadClass(ClassLoader.java:268) [java] Could not find the main class: org.dspace.storage.rdbms.DatabaseUtils. Program will exit. BUILD FAILED /build/dspace-5.1-src-release/dspace/target/dspace-installer/build.xml:797: Java returned: 1 Total time: 4 seconds

    Sakai JIRA | 2 years ago | vimal
    java.lang.UnsupportedClassVersionError: org/dspace/storage/rdbms/DatabaseUtils : Unsupported major.minor version 51.0
  3. 0

    Crosscompilation

    GitHub | 3 years ago | MarcDahlem
    java.lang.UnsupportedClassVersionError: org/hyperion/hypercon/Main : Unsupported major.minor version 51.0
  4. Speed up your debug routine!

    Automated exception search integrated into your IDE

  5. 0

    Unsupported major.minor version 51.0 - Could not find the main class: de.komoot.photon.importer.App

    GitHub | 2 years ago | daryltucker
    java.lang.UnsupportedClassVersionError: spark/Route : Unsupported major.minor version 51.0
  6. 0

    Starting fdb-sql layer when it can't contact the fdb-server failure needs better message in fdb-sql log

    GitHub | 3 years ago | tjoneslo
    java.lang.UnsupportedClassVersionError: com/foundationdb/sql/Main : Unsupported major.minor version 51.0

  1. Mark 1 times, last 4 days ago
  2. harshg 4 times, last 3 months ago
  3. muffinmannen 1 times, last 6 months ago
  4. bpbhat77 1 times, last 6 months ago
  5. Akhilesh Patel 2 times, last 1 year ago
57 unregistered visitors
Not finding the right solution?
Take a tour to get the most out of Samebug.

Tired of useless tips?

Automated exception search integrated into your IDE

Root Cause Analysis

  1. java.lang.UnsupportedClassVersionError

    org/dspace/storage/rdbms/DatabaseUtils : Unsupported major.minor version 51.0

    at java.lang.ClassLoader.defineClass1()
  2. Java RT
    ClassLoader.loadClass
    1. java.lang.ClassLoader.defineClass1(Native Method)
    2. java.lang.ClassLoader.defineClass(ClassLoader.java:643)
    3. java.security.SecureClassLoader.defineClass(SecureClassLoader.java:142)
    4. java.net.URLClassLoader.defineClass(URLClassLoader.java:277)
    5. java.net.URLClassLoader.access$000(URLClassLoader.java:73)
    6. java.net.URLClassLoader$1.run(URLClassLoader.java:212)
    7. java.security.AccessController.doPrivileged(Native Method)
    8. java.net.URLClassLoader.findClass(URLClassLoader.java:205)
    9. java.lang.ClassLoader.loadClass(ClassLoader.java:323)
    10. sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:294)
    11. java.lang.ClassLoader.loadClass(ClassLoader.java:268)
    11 frames