org.labkey.api.util.ConfigurationException: DataSources are not properly configured in labkey.xml.

Searched on Google with the first line of a JAVA stack trace?

We can recommend more relevant solutions and speed up debugging when you paste your entire stack trace with the exception message. Try a sample exception.

Recommended solutions based on your search

Solutions on the web

via labkey.org by Unknown author, 1 year ago
DataSources are not properly configured in labkey.xml.
via labkey.org by Unknown author, 2 years ago
DataSources are not properly configured in labkey.xml.
via labkey.org by Unknown author, 2 years ago
DataSources are not properly configured in labkey.xml.
via labkey.org by Unknown author, 1 year ago
DataSources are not properly configured in labkey.xml.
via labkey.org by Unknown author, 1 year ago
DataSources are not properly configured in labkey.xml.
via labkey.org by Unknown author, 2 years ago
DataSources are not properly configured in labkey.xml.
javax.naming.NameNotFoundException: Name [comp/env] is not bound in this Context. Unable to find [comp].
at org.apache.naming.NamingContext.lookup(NamingContext.java:819)
at org.apache.naming.NamingContext.lookup(NamingContext.java:167)
at org.apache.naming.SelectorContext.lookup(SelectorContext.java:156)
at javax.naming.InitialContext.lookup(InitialContext.java:417)
at org.labkey.api.module.ModuleLoader.ensureDatabase(ModuleLoader.java:902)
at org.labkey.api.module.ModuleLoader.initializeDataSources(ModuleLoader.java:864)

Users with the same issue

2 times, 3 months ago
6 times, 7 months ago
Once, 11 months ago
Once, 1 year ago
2 times, 1 year ago

Write tip

Know the solutions? Share your knowledge to help other developers to debug faster.