java.lang.ClassNotFoundException

org.jboss.deployment.J2eeDeploymentException (no security manager: RMI class loader disabled)

Samebug tips0

There are no available Samebug tips for this exception. If you know how to solve this issue, help other users by writing a short tip.

Don't give up yet. Paste your full stack trace to get a solution.

Solutions on the web6422

  • via sourceforge.net by Unknown author, 1 year ago
    org.jboss.deployment.J2eeDeploymentException (no security manager: RMI class loader disabled)
  • via Atlassian JIRA by David Currie [Atlassian], 10 months ago
    com.atlassian.mywork.client.service.HostServiceImpl$HostType (no security manager: RMI class loader disabled)
  • via Spring JIRA by Kapil Gupta, 2 weeks ago
    int (no security manager: RMI class loader disabled)
  • Stack trace

    • java.lang.ClassNotFoundException: org.jboss.deployment.J2eeDeploymentException (no security manager: RMI class loader disabled) at sun.rmi.server.LoaderHandler.loadClass(LoaderHandler.java:318) at sun.rmi.server.LoaderHandler.loadClass(LoaderHandler.java:132) at sun.rmi.server.MarshalInputStream.resolveClass(MarshalInputStream.java:143) at java.io.ObjectInputStream.inputClassDescriptor(ObjectInputStream.java:918) at java.io.ObjectInputStream.readObject(ObjectInputStream.java:366) at java.io.ObjectInputStream.readObject(ObjectInputStream.java:236) at java.io.ObjectInputStream.inputObject(ObjectInputStream.java:1186) at java.io.ObjectInputStream.readObject(ObjectInputStream.java:386) at java.io.ObjectInputStream.inputClassFields(ObjectInputStream.java:2262) at java.io.ObjectInputStream.defaultReadObject(ObjectInputStream.java:519) at java.io.ObjectInputStream.inputObject(ObjectInputStream.java:1411) at java.io.ObjectInputStream.readObject(ObjectInputStream.java:386) at java.io.ObjectInputStream.readObject(ObjectInputStream.java:236) at sun.rmi.transport.StreamRemoteCall.executeCall(StreamRemoteCall.java:212) at sun.rmi.server.UnicastRef.invoke(UnicastRef.java:122) at org.jboss.jmx.server.JMXAdaptorImpl_Stub.invoke(Unknown Source) at org.jboss.jmx.client.Deployer.deploy(Deployer.java:55) at org.jboss.test.xa.test.Main.setUp(Main.java:149) at junit.framework.TestCase.runBare(TestCase.java:127) at junit.framework.TestResult$1.protect(TestResult.java:100) at junit.framework.TestResult.runProtected(TestResult.java:117) at junit.framework.TestResult.run(TestResult.java:103) at junit.framework.TestCase.run(TestCase.java:120) at junit.framework.TestSuite.run(TestSuite.java:144) at org.apache.tools.ant.taskdefs.optional.junit.JUnitTestRunner.run(JUnitTestRunner.java:202) at org.apache.tools.ant.taskdefs.optional.junit.JUnitTestRunner.main(JUnitTestRunner.java:326)

    Write tip

    You have a different solution? A short tip here would help you and many other users who saw this issue last week.

    Users with the same issue

    Once, 6 months ago
    Unknown user
    Once, 1 year ago