java.lang.RuntimeException: Unable to start activity ComponentInfo{*}: java.lang.IllegalStateException: You need to use a Theme.AppCompat theme (or descendant) with this activity.

google.com | 6 months ago
tip
Click on the to mark the solution that helps you, Samebug will learn from it.
As a community member, you’ll be rewarded for you help.
  1. 0

    Issue 190237 - android - Bug: appcompat-v7:23.1.0 has dynamic themes issues with proguard - Android Open Source Project - Issue Tracker - Google Project Hosting

    google.com | 6 months ago
    java.lang.RuntimeException: Unable to start activity ComponentInfo{*}: java.lang.IllegalStateException: You need to use a Theme.AppCompat theme (or descendant) with this activity.
  2. 0

    Proguard causes AppCompat crash when app loads

    Stack Overflow | 2 years ago | Calc
    java.lang.IllegalStateException: You need to use a Theme.AppCompat theme (or descendant) with this activity.

    Root Cause Analysis

    1. java.lang.IllegalStateException

      You need to use a Theme.AppCompat theme (or descendant) with this activity.

      at android.support.v7.app.t.a()
    2. Android v7
      q.onCreate
      1. android.support.v7.app.t.a(AppCompatDelegateImplBase.java:124)
      2. android.support.v7.app.AppCompatDelegateImplV7.a(AppCompatDelegateImplV7.java:146)
      3. android.support.v7.app.q.onCreate(AppCompatActivity.java:59)
      3 frames