org.osgi.framework.BundleException: Unresolved constraint in bundle nl.lxtreme.ols.tool.base [7]: Unable to resolve 7.0: missing requirement [7.0] package; (package=javax.swing.filechooser)

Searched on Google with the first line of a JAVA stack trace?

We can recommend more relevant solutions and speed up debugging when you paste your entire stack trace with the exception message. Try a sample exception.

Recommended solutions based on your search

Solutions on the web

via GitHub by wayoda
, 1 year ago
Unresolved constraint in bundle nl.lxtreme.ols.tool.base [7]: Unable to resolve 7.0: missing requirement [7.0] package; (package=javax.swing.filechooser)
via nabble.com by Unknown author, 2 years ago
Unresolved constraint in bundle org.apache.aries.blueprint [7]: Unable to resolve 7.0: missing requirement [7.0] package; (package=org.eclipse.osgi.framework.adaptor)
via Google Groups by Duleep Samuel, 4 months ago
Unresolved constraint in bundle org.apache.aries.blueprint [7]: Unable to resolve 7.0: missing requirement [7.0] package; (package=javax.xml.parsers)
via Apache's JIRA Issue Tracker by Charles Moulliard, 1 year ago
Unresolved constraint in bundle org.apache.aries.blueprint [7]: Unable to resolve 7.0: missing requirement [7.0] package; (&(package=org.apache.aries.proxy)(version>=0.3.0)(!(version>=1.0.0)))
via GitHub by aowen
, 10 months ago
Unresolved constraint in bundle org.apache.aries.proxy [7]: Unable to resolve 7.0: missing requirement [7.0] package; (&(package=org.apache.aries.util)(version>=0.3.0)(!(version>=1.0.0))) [caused by: Unable to resolve 10.0: missing requirement [10.0] package; (&(package=org.osgi.framework)(version>=1.5.0)(!(version>=2.0.0)))] ```
via GitHub by rchawdry
, 2 years ago
Unresolved constraint in bundle org.apache.aries.proxy [7]: Unable to resolve 7.0: missing requirement [7.0] package; (&(package=org.apache.aries.util)(version>=0.3.0)(!(version>=1.0.0))) [caused by: Unable to resolve 10.0: missing requirement [10.0] package; (&(package=org.osgi.framework)(version>=1.5.0)(!(version>=2.0.0)))]
org.osgi.framework.BundleException: Unresolved constraint in bundle nl.lxtreme.ols.tool.base [7]: Unable to resolve 7.0: missing requirement [7.0] package; (package=javax.swing.filechooser)
at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3446)
at org.apache.felix.framework.Felix.startBundle(Felix.java:1734)
at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1163)
at java.lang.Thread.run(Thread.java:722)

Users with the same issue

Samebug visitor profile picture
Unknown user
Once, 2 years ago
2 times, 9 months ago
Samebug visitor profile picture
Unknown user
Once, 1 year ago
Samebug visitor profile picture
Unknown user
Once, 2 years ago
Samebug visitor profile picture
Unknown user
Once, 1 year ago
2 more bugmates

Know the solutions? Share your knowledge to help other developers to debug faster.