org.osgi.framework.BundleException

Unresolved constraint in bundle nl.lxtreme.ols.tool.i2c [9]: Unable to resolve 9.0: missing requirement [9.0] package; (package=nl.lxtreme.ols.api) [caused by: Unable to resolve 21.0: missing requirement [21.0] package; (package=nl.lxtreme.ols.util) [caused by: Unable to resolve 17.0: missing requirement [17.0] package; (package=javax.accessibility)]]

Samebug tips0

There are no available Samebug tips for this exception. If you know how to solve this issue, help other users by writing a short tip.

Don't give up yet. Paste your full stack trace to get a solution.

Solutions on the web6407

  • Unresolved constraint in bundle nl.lxtreme.ols.tool.i2c [9]: Unable to resolve 9.0: missing requirement [9.0] package; (package=nl.lxtreme.ols.api) [caused by: Unable to resolve 21.0: missing requirement [21.0] package; (package=nl.lxtreme.ols.util) [caused by: Unable to resolve 17.0: missing requirement [17.0] package; (package=javax.accessibility)]]
  • via SpringSource Issue Tracker by The Alchemist, 1 year ago
    Unresolved constraint in bundle org.springframework.roo.addon.creator [9]: Unable to resolve 9.0: missing requirement [9.0] package; (package=javax.xml.parsers)
  • via GitHub by rchawdry
    , 1 year ago
    Unresolved constraint in bundle org.apache.aries.blueprint [9]: Unable to resolve 9.0: missing requirement [9.0] package; (package=javax.xml.parsers)
  • Stack trace

    • org.osgi.framework.BundleException: Unresolved constraint in bundle nl.lxtreme.ols.tool.i2c [9]: Unable to resolve 9.0: missing requirement [9.0] package; (package=nl.lxtreme.ols.api) [caused by: Unable to resolve 21.0: missing requirement [21.0] package; (package=nl.lxtreme.ols.util) [caused by: Unable to resolve 17.0: missing requirement [17.0] package; (package=javax.accessibility)]] at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3446) at org.apache.felix.framework.Felix.startBundle(Felix.java:1734) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1163) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:264) at java.lang.Thread.run(Thread.java:722)

    Write tip

    You have a different solution? A short tip here would help you and many other users who saw this issue last week.

    Users with the same issue

    2 times, 5 months ago
    Unknown user
    Once, 1 year ago
    Unknown user
    Once, 1 year ago
    Unknown user
    Once, 1 year ago
    Unknown user
    Once, 11 months ago
    2 more bugmates