java.lang.NoClassDefFoundError

tip

Look if your classpath is correct, and check if the versions of your libraries match the version you described in your pom.xml

You have a different solution? A short tip here would help you and many other users who saw this issue last week.

  • GitHub comment 2573#158913924
    via GitHub by srs
    ,
  • Unable to create Hello World site
    via GitHub by Tmarty
    ,
  • apache karaf faild to load web bundle
    via Stack Overflow by WestFarmer
    ,
  • GLASSFISH 3 DOMAIN SERVICE ERROR
    via Stack Overflow by DES
    ,
  • Generate pdf document on server - Mendix Forum
    via by Unknown author,
  • Karaf - Dev - Java 6 support broken in Karaf 3.0.x
    via by Unknown author,
  • Stack Overflow
    via by Unknown author,
    • java.lang.NoClassDefFoundError: org/apache/jsp/... (wrong name: jsp/...) at java.lang.ClassLoader.defineClass1(Native Method) at java.lang.ClassLoader.defineClass(ClassLoader.java:760) at org.apache.felix.framework.BundleWiringImpl$BundleClassLoader.defineClass(BundleWiringImpl.java:2370) at org.apache.felix.framework.BundleWiringImpl$BundleClassLoader.findClass(BundleWiringImpl.java:2154) at org.apache.felix.framework.BundleWiringImpl.findClassOrResourceByDelegation(BundleWiringImpl.java:1542) at org.apache.felix.framework.BundleWiringImpl.access$400(BundleWiringImpl.java:79) at org.apache.felix.framework.BundleWiringImpl$BundleClassLoader.loadClass(BundleWiringImpl.java:2018) at java.lang.ClassLoader.loadClass(ClassLoader.java:357) at org.apache.felix.framework.Felix.loadBundleClass(Felix.java:1925) at org.apache.felix.framework.BundleImpl.loadClass(BundleImpl.java:978) at org.glassfish.osgijavaeebase.BundleClassLoader.loadClass(BundleClassLoader.java:79) at org.glassfish.osgiweb.OSGiWebDeploymentContext$WABClassLoader.loadClass(OSGiWebDeploymentContext.java:169) at org.glassfish.osgiweb.OSGiWebDeploymentContext$WABClassLoader.loadClass(OSGiWebDeploymentContext.java:154) at org.apache.jasper.JspCompilationContext.load(JspCompilationContext.java:654) at org.apache.jasper.servlet.JspServletWrapper.getServlet(JspServletWrapper.java:202) at org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:388) at org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:473) at org.apache.jasper.servlet.JspServlet.service(JspServlet.java:377) at javax.servlet.http.HttpServlet.service(HttpServlet.java:790) at org.apache.catalina.core.StandardWrapper.service(StandardWrapper.java:1682) at org.apache.catalina.core.ApplicationDispatcher.doInvoke(ApplicationDispatcher.java:875) at org.apache.catalina.core.ApplicationDispatcher.invoke(ApplicationDispatcher.java:739) at org.apache.catalina.core.ApplicationDispatcher.doInclude(ApplicationDispatcher.java:695) at org.apache.catalina.core.ApplicationDispatcher.include(ApplicationDispatcher.java:626)

    Users with the same issue

    Unknown visitor1 times, last one,
    Unknown visitor1 times, last one,
    Unknown visitor1 times, last one,
    davidvanlaatum
    1 times, last one,
    DannyDBag
    12 times, last one,
    139 more bugmates