java.lang.NoClassDefFoundError: org/apache/jsp/... (wrong name: jsp/...)

Searched on Google with the first line of a JAVA stack trace?

We can recommend more relevant solutions and speed up debugging when you paste your entire stack trace with the exception message. Try a sample exception.

Recommended solutions based on your search

Samebug tips

,
Expert tip

Look if your classpath is correct, and check if the versions of your libraries match the version you described in your pom.xml

Solutions on the web

via Stack Overflow by JimJim2000
, 1 year ago
org/apache/jsp/... (wrong name: jsp/...)
via Oracle Community by 843830, 1 year ago
CIncomingMessage (wrong name: org/smslib/CIn comingMessage)
via Oracle Community by 843854, 11 months ago
Testdb (wrong name: org/hsqldb/sample/Testdb)
via Oracle Community by 843810, 1 year ago
JavaFive (wrong name: org/redrum/tests/JavaFive)
via adempiere by mar_cal_westf
, 1 year ago
GenerateModel (wrong name: org/compiere/util/GenerateModel)
via Oracle Community by 843804, 1 year ago
MeterInterface (wrong name: org/Dave/CBSD/MeterInterface)
java.lang.NoClassDefFoundError: org/apache/jsp/... (wrong name: jsp/...)
at java.lang.ClassLoader.defineClass1(Native Method)
at java.lang.ClassLoader.defineClass(ClassLoader.java:760)
at org.apache.felix.framework.BundleWiringImpl$BundleClassLoader.defineClass(BundleWiringImpl.java:2370)
at org.apache.felix.framework.BundleWiringImpl$BundleClassLoader.findClass(BundleWiringImpl.java:2154)
at org.apache.felix.framework.BundleWiringImpl.findClassOrResourceByDelegation(BundleWiringImpl.java:1542)
at org.apache.felix.framework.BundleWiringImpl.access$400(BundleWiringImpl.java:79)
at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
at org.apache.felix.framework.Felix.loadBundleClass(Felix.java:1925)
at org.glassfish.osgijavaeebase.BundleClassLoader.loadClass(BundleClassLoader.java:79)
at org.glassfish.osgiweb.OSGiWebDeploymentContext$WABClassLoader.loadClass(OSGiWebDeploymentContext.java:169)
at org.apache.jasper.JspCompilationContext.load(JspCompilationContext.java:654)
at org.apache.jasper.servlet.JspServletWrapper.getServlet(JspServletWrapper.java:202)
at org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:388)
at org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:473)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:790)
at org.apache.catalina.core.StandardWrapper.service(StandardWrapper.java:1682)
at org.apache.catalina.core.ApplicationDispatcher.doInvoke(ApplicationDispatcher.java:875)
at org.apache.catalina.core.ApplicationDispatcher.invoke(ApplicationDispatcher.java:739)
at org.apache.catalina.core.ApplicationDispatcher.doInclude(ApplicationDispatcher.java:695)
at org.apache.catalina.core.ApplicationDispatcher.include(ApplicationDispatcher.java:626)

Users with the same issue

Samebug visitor profile picture
Unknown user
Once, 1 year ago
Samebug visitor profile picture
Unknown user
Once, 2 years ago
12 times, 5 months ago
Samebug visitor profile picture
Unknown user
Once, 1 year ago
Once, 1 year ago
145 more bugmates

Know the solutions? Share your knowledge to help other developers to debug faster.