java.net.SocketException: Broken pipe

tip

Probably there is a bug in TestNG Eclipse plugin (6.8.6.20130607_0745), try an other version (e.g. 6.8.0.20121120_1820)

tip

before running my test in debug mode, i open the debug view, and remove some breakpoints (such as some remaining on NullPointersExceptions, and Sockets)

tip

Try removing all the breakpoints (even if breakpoints are disabled the problem still occurs, yes even if both disabled entirely and piecewise).

tip

There is a known issue between TestNG 6.4 and IDEA, the next EAP will fix this but in the meantime, use the previous version.

You have a different solution? A short tip here would help you and many other users who saw this issue last week.

  • Imported issue was from wmdopple: From the forums, thought I'd open an issue for this as well. At a random time after starting a conversation with someone who is using the official MSN client, the sent messages from the Jabber side stop arriving on the MSN side. Messages from the MSN side to the Jabber user continue arriving normally. This started happening fairly recently, with no changes on the server. Conversations with an MSN contact using Trillian don't seem to show the same behavior. The Openfire debug log shows nothing unusual. The error log shows: 2009.11.14 13:41:35 [org.jivesoftware.util.log.util.CommonsLogFactory$1.error(CommonsLogFactory.java:92)] error sending msg: MSG 119 U 93 ==================== Chunk Debug ==================== MIME-Version: 1.0 Content-Type: text/x-msmsgscontrol TypingUser: [redacted]@hotmail.com ==================== Binary Chunk Debug ==================== 00000000h: 4D 49 4D 45 2D 56 65 72 73 69 6F 6E 3A 20 31 2E ; MIME-Version: 1. 00000010h: 30 0D 0A 43 6F 6E 74 65 6E 74 2D 54 79 70 65 3A ; 0..Content-Type: 00000020h: 20 74 65 78 74 2F 78 2D 6D 73 6D 73 67 73 63 6F ; text/x-msmsgsco 00000030h: 6E 74 72 6F 6C 0D 0A 54 79 70 69 6E 67 55 73 65 ; ntrol..TypingUse 00000040h: 72 3A 20 00 00 00 00 00 00 00 00 40 68 6F 74 6D ; r: [redacted]@hotm 00000050h: 61 69 6C 2E 63 6F 6D 0D 0A 0D 0A 0D 0A ; ail.com...... java.net.SocketException: Broken pipe at java.net.SocketOutputStream.socketWrite0(Native Method) at java.net.SocketOutputStream.socketWrite(Unknown Source) at java.net.SocketOutputStream.write(Unknown Source) at java.io.ByteArrayOutputStream.writeTo(Unknown Source) at net.sf.jml.net.Session.sendMessage(Session.java:511) at net.sf.jml.net.Session.access$1300(Session.java:30) at net.sf.jml.net.Session$MsgSender.run(Session.java:476) at java.lang.Thread.run(Unknown Source) This is followed by a similar error every time a message send is attempted. Kraken v1.1.2 Version: Openfire 3.6.4 Java Version: 1.6.0_03 Sun Microsystems Inc. -- Java HotSpot(TM) Server VM Appserver: jetty-6.1.x OS / Hardware: Linux / i386 This has also been tested with the previous Openfire version, and with Kraken v1.1.3 compiled from SVN on 11/20/09.
    via by Daniel Henninger,
  • Imported issue was from wmdopple: From the forums, thought I'd open an issue for this as well. At a random time after starting a conversation with someone who is using the official MSN client, the sent messages from the Jabber side stop arriving on the MSN side. Messages from the MSN side to the Jabber user continue arriving normally. This started happening fairly recently, with no changes on the server. Conversations with an MSN contact using Trillian don't seem to show the same behavior. The Openfire debug log shows nothing unusual. The error log shows: 2009.11.14 13:41:35 [org.jivesoftware.util.log.util.CommonsLogFactory$1.error(CommonsLogFactory.java:92)] error sending msg: MSG 119 U 93 ==================== Chunk Debug ==================== MIME-Version: 1.0 Content-Type: text/x-msmsgscontrol TypingUser: [redacted]@hotmail.com ==================== Binary Chunk Debug ==================== 00000000h: 4D 49 4D 45 2D 56 65 72 73 69 6F 6E 3A 20 31 2E ; MIME-Version: 1. 00000010h: 30 0D 0A 43 6F 6E 74 65 6E 74 2D 54 79 70 65 3A ; 0..Content-Type: 00000020h: 20 74 65 78 74 2F 78 2D 6D 73 6D 73 67 73 63 6F ; text/x-msmsgsco 00000030h: 6E 74 72 6F 6C 0D 0A 54 79 70 69 6E 67 55 73 65 ; ntrol..TypingUse 00000040h: 72 3A 20 00 00 00 00 00 00 00 00 40 68 6F 74 6D ; r: [redacted]@hotm 00000050h: 61 69 6C 2E 63 6F 6D 0D 0A 0D 0A 0D 0A ; ail.com...... java.net.SocketException: Broken pipe at java.net.SocketOutputStream.socketWrite0(Native Method) at java.net.SocketOutputStream.socketWrite(Unknown Source) at java.net.SocketOutputStream.write(Unknown Source) at java.io.ByteArrayOutputStream.writeTo(Unknown Source) at net.sf.jml.net.Session.sendMessage(Session.java:511) at net.sf.jml.net.Session.access$1300(Session.java:30) at net.sf.jml.net.Session$MsgSender.run(Session.java:476) at java.lang.Thread.run(Unknown Source) This is followed by a similar error every time a message send is attempted. Kraken v1.1.2 Version: Openfire 3.6.4 Java Version: 1.6.0_03 Sun Microsystems Inc. -- Java HotSpot(TM) Server VM Appserver: jetty-6.1.x OS / Hardware: Linux / i386 This has also been tested with the previous Openfire version, and with Kraken v1.1.3 compiled from SVN on 11/20/09.
    via by Daniel Henninger,
  • Imported issue was from wmdopple: From the forums, thought I'd open an issue for this as well. At a random time after starting a conversation with someone who is using the official MSN client, the sent messages from the Jabber side stop arriving on the MSN side. Messages from the MSN side to the Jabber user continue arriving normally. This started happening fairly recently, with no changes on the server. Conversations with an MSN contact using Trillian don't seem to show the same behavior. The Openfire debug log shows nothing unusual. The error log shows: 2009.11.14 13:41:35 [org.jivesoftware.util.log.util.CommonsLogFactory$1.error(CommonsLogFactory.java:92)] error sending msg: MSG 119 U 93 ==================== Chunk Debug ==================== MIME-Version: 1.0 Content-Type: text/x-msmsgscontrol TypingUser: [redacted]@hotmail.com ==================== Binary Chunk Debug ==================== 00000000h: 4D 49 4D 45 2D 56 65 72 73 69 6F 6E 3A 20 31 2E ; MIME-Version: 1. 00000010h: 30 0D 0A 43 6F 6E 74 65 6E 74 2D 54 79 70 65 3A ; 0..Content-Type: 00000020h: 20 74 65 78 74 2F 78 2D 6D 73 6D 73 67 73 63 6F ; text/x-msmsgsco 00000030h: 6E 74 72 6F 6C 0D 0A 54 79 70 69 6E 67 55 73 65 ; ntrol..TypingUse 00000040h: 72 3A 20 00 00 00 00 00 00 00 00 40 68 6F 74 6D ; r: [redacted]@hotm 00000050h: 61 69 6C 2E 63 6F 6D 0D 0A 0D 0A 0D 0A ; ail.com...... java.net.SocketException: Broken pipe at java.net.SocketOutputStream.socketWrite0(Native Method) at java.net.SocketOutputStream.socketWrite(Unknown Source) at java.net.SocketOutputStream.write(Unknown Source) at java.io.ByteArrayOutputStream.writeTo(Unknown Source) at net.sf.jml.net.Session.sendMessage(Session.java:511) at net.sf.jml.net.Session.access$1300(Session.java:30) at net.sf.jml.net.Session$MsgSender.run(Session.java:476) at java.lang.Thread.run(Unknown Source) This is followed by a similar error every time a message send is attempted. Kraken v1.1.2 Version: Openfire 3.6.4 Java Version: 1.6.0_03 Sun Microsystems Inc. -- Java HotSpot(TM) Server VM Appserver: jetty-6.1.x OS / Hardware: Linux / i386 This has also been tested with the previous Openfire version, and with Kraken v1.1.3 compiled from SVN on 11/20/09.
    via by Daniel Henninger,
  • Openfire service crashing daily | Ignite Realtime
    via by Unknown author,
  • Ftp File download From java code
    via Stack Overflow by nomee.tec
    ,
  • Table Output step - Connection problem
    via by Unknown author,
  • [Te-webmaster] Apache Tomcat 7 Error
    via by Unknown author,
  • GitHub comment 207#164266226
    via GitHub by kpassoubady
    ,
  • Hive metastore not working in HDInsight 3.0
    via by Unknown author,
    • java.net.SocketException: Broken pipe at java.net.SocketOutputStream.socketWrite0(Native Method) at java.net.SocketOutputStream.socketWrite(Unknown Source) at java.net.SocketOutputStream.write(Unknown Source) at java.io.ByteArrayOutputStream.writeTo(Unknown Source) at net.sf.jml.net.Session.sendMessage(Session.java:511) at net.sf.jml.net.Session.access$1300(Session.java:30) at net.sf.jml.net.Session$MsgSender.run(Session.java:476) at java.lang.Thread.run(Unknown Source)

    Users with the same issue

    Unknown visitor1 times, last one,
    ivanszkypeter
    ivanszkypeter728 times, last one,
    Unknown visitor1 times, last one,
    Unknown visitor1 times, last one,
    Unknown visitor1 times, last one,
    207 more bugmates