org.apache.catalina.LifecycleException

tip

Change the connection port and ip adress. If you're trying to connect to your server from your own computer, check if you haven't already connected to the server in another instance.


rafael
tip

Try changing the port in core-site.xml from 9000 to 9001 as it seems port 9000 doesn't work.

tip

It might be that there's another process connecting to the same port you're trying to use, try to kill it or change the connection port.


rafael

You have a different solution? A short tip here would help you and many other users who saw this issue last week.

  • Spring suite tools start error - spring boot
    via Stack Overflow by j. doe
    ,
  • Spring BootでHello World
    via by Unknown author,
  • Amazon Echo HA Bridge issues - openHAB Community
    via by Unknown author,
    • org.apache.catalina.LifecycleException: Failed to start component [Connector[HTTP/1.1-8080]] at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:153)[tomcat-embed-core-8.0.32.jar:8.0.32] at org.apache.catalina.core.StandardService.addConnector(StandardService.java:239)[tomcat-embed-core-8.0.32.jar:8.0.32] at org.springframework.boot.context.embedded.tomcat.TomcatEmbeddedServletContainer.addPreviouslyRemovedConnectors(TomcatEmbeddedServletContainer.java:194)[spring-boot-1.3.3.RELEASE.jar:1.3.3.RELEASE] at org.springframework.boot.context.embedded.tomcat.TomcatEmbeddedServletContainer.start(TomcatEmbeddedServletContainer.java:151)[spring-boot-1.3.3.RELEASE.jar:1.3.3.RELEASE] at org.springframework.boot.context.embedded.EmbeddedWebApplicationContext.startEmbeddedServletContainer(EmbeddedWebApplicationContext.java:293)[spring-boot-1.3.3.RELEASE.jar:1.3.3.RELEASE] at org.springframework.boot.context.embedded.EmbeddedWebApplicationContext.finishRefresh(EmbeddedWebApplicationContext.java:141)[spring-boot-1.3.3.RELEASE.jar:1.3.3.RELEASE] at org.springframework.context.support.AbstractApplicationContext.refresh(AbstractApplicationContext.java:541)[spring-context-4.2.5.RELEASE.jar:4.2.5.RELEASE] at org.springframework.boot.context.embedded.EmbeddedWebApplicationContext.refresh(EmbeddedWebApplicationContext.java:118)[spring-boot-1.3.3.RELEASE.jar:1.3.3.RELEASE] at org.springframework.boot.SpringApplication.refresh(SpringApplication.java:766)[spring-boot-1.3.3.RELEASE.jar:1.3.3.RELEASE] at org.springframework.boot.SpringApplication.createAndRefreshContext(SpringApplication.java:361)[spring-boot-1.3.3.RELEASE.jar:1.3.3.RELEASE] at org.springframework.boot.SpringApplication.run(SpringApplication.java:307)[spring-boot-1.3.3.RELEASE.jar:1.3.3.RELEASE] at org.springframework.boot.SpringApplication.run(SpringApplication.java:1191)[spring-boot-1.3.3.RELEASE.jar:1.3.3.RELEASE] at org.springframework.boot.SpringApplication.run(SpringApplication.java:1180)[spring-boot-1.3.3.RELEASE.jar:1.3.3.RELEASE] at io.soumasish.Application.main(Application.java:14)[main/:na] at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)[na:1.8.0_92] at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)[na:1.8.0_92] at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)[na:1.8.0_92] at java.lang.reflect.Method.invoke(Method.java:498)[na:1.8.0_92] at com.intellij.rt.execution.application.AppMain.main(AppMain.java:144)[idea_rt.jar:na] Caused by: org.apache.catalina.LifecycleException: service.getName(): "Tomcat"; Protocol handler start failed at org.apache.catalina.connector.Connector.startInternal(Connector.java:993)[tomcat-embed-core-8.0.32.jar:8.0.32] at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:147)[tomcat-embed-core-8.0.32.jar:8.0.32] ... 18 more Caused by: java.net.BindException: Address already in use at sun.nio.ch.Net.bind0(Native Method)[na:1.8.0_92] at sun.nio.ch.Net.bind(Net.java:433)[na:1.8.0_92] at sun.nio.ch.Net.bind(Net.java:425)[na:1.8.0_92] at sun.nio.ch.ServerSocketChannelImpl.bind(ServerSocketChannelImpl.java:223)[na:1.8.0_92] at sun.nio.ch.ServerSocketAdaptor.bind(ServerSocketAdaptor.java:74)[na:1.8.0_92] at org.apache.tomcat.util.net.NioEndpoint.bind(NioEndpoint.java:340)[tomcat-embed-core-8.0.32.jar:8.0.32] at org.apache.tomcat.util.net.AbstractEndpoint.start(AbstractEndpoint.java:765)[tomcat-embed-core-8.0.32.jar:8.0.32] at org.apache.coyote.AbstractProtocol.start(AbstractProtocol.java:473)[tomcat-embed-core-8.0.32.jar:8.0.32] at org.apache.catalina.connector.Connector.startInternal(Connector.java:986)[tomcat-embed-core-8.0.32.jar:8.0.32] ... 19 more

    Users with the same issue

    slash
    5 times, last one,
    rocday
    1 times, last one,
    batwalrus76
    1 times, last one,
    musketyr
    1 times, last one,
    Dunmer
    2 times, last one,
    136 more bugmates