java.lang.UnsatisfiedLinkError: Could not load SWT library. Reasons: no swt-pi-gtk-4233 in java.library.path no swt-pi-gtk in java.library.path Can't load library: /home/tester/.swt/lib/linux/x86_64/libswt-pi-gtk-4233.so Can't load library: /home/tester/.swt/lib/linux/x86_64/libswt-pi-gtk.so /home/tester/.swt/lib/linux/x86_64/libswt-pi-gtk-4233.so: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.14' not found (required by /home/tester/.swt/lib/linux/x86_64/libswt-pi-gtk-4233.so)

runawfe | vromav | 2 years ago
  1. 0

    linux дистрибутивы 4.1.0, runawfe4-notifier_4.1.0-eter5debian_amd64, debian 7.3 amd64, не запускается, critical error

    runawfe | 2 years ago | vromav
    java.lang.UnsatisfiedLinkError: Could not load SWT library. Reasons: no swt-pi-gtk-4233 in java.library.path no swt-pi-gtk in java.library.path Can't load library: /home/tester/.swt/lib/linux/x86_64/libswt-pi-gtk-4233.so Can't load library: /home/tester/.swt/lib/linux/x86_64/libswt-pi-gtk.so /home/tester/.swt/lib/linux/x86_64/libswt-pi-gtk-4233.so: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.14' not found (required by /home/tester/.swt/lib/linux/x86_64/libswt-pi-gtk-4233.so)
  2. 0

    GitHub comment 37#138505079

    GitHub | 1 year ago | rgwch
    java.lang.UnsatisfiedLinkError: Could not load SWT library. Reasons: /home/elexisbuilder/elexis-3-core/ch.elexis.core.ui.importer.div.tests/target/work/configuration/org.eclipse.osgi/bundles/76/1/.cp/libswt-pi-gtk-3836.so: libgtk-x11-2.0.so.0: cannot open shared object file: No such file or directory no swt-pi-gtk in java.library.path Can't load library: /home/elexisbuilder/.swt/lib/linux/x86_64/libswt-pi-gtk-3836.so Can't load library: /home/elexisbuilder/.swt/lib/linux/x86_64/libswt-pi-gtk.so /home/elexisbuilder/.swt/lib/linux/x86_64/libswt-pi-gtk-3836.so: libgtk-x11-2.0.so.0: cannot open shared object file: No such file or directory
  3. 0

    "android update sdk" on headless linux

    Stack Overflow | 7 years ago | focuser
    java.lang.UnsatisfiedLinkError: no swt-pi-gtk-3550 or swt-pi-gtk in swt.library.path, java.library.path or the jar file
  4. Speed up your debug routine!

    Automated exception search integrated into your IDE

  5. 0

    Eclimd doesnt start

    Google Groups | 7 years ago | Kai Karius
    java.lang.UnsatisfiedLinkError: no swt-pi-gtk-3550 or swt-pi-gtk in swt.library.path, java.library.path or the jar file
  6. 0

    "android update sdk" on headless linux

    Google Groups | 7 years ago | focuser
    java.lang.UnsatisfiedLinkError: no swt- pi-gtk-3550 or swt-pi-gtk in swt.library.path, java.library.path or the jar file

    1 unregistered visitors
    Not finding the right solution?
    Take a tour to get the most out of Samebug.

    Tired of useless tips?

    Automated exception search integrated into your IDE

    Root Cause Analysis

    1. java.lang.UnsatisfiedLinkError

      Could not load SWT library. Reasons: no swt-pi-gtk-4233 in java.library.path no swt-pi-gtk in java.library.path Can't load library: /home/tester/.swt/lib/linux/x86_64/libswt-pi-gtk-4233.so Can't load library: /home/tester/.swt/lib/linux/x86_64/libswt-pi-gtk.so /home/tester/.swt/lib/linux/x86_64/libswt-pi-gtk-4233.so: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.14' not found (required by /home/tester/.swt/lib/linux/x86_64/libswt-pi-gtk-4233.so)

      at org.eclipse.swt.internal.Library.loadLibrary()
    2. RWT
      Library.loadLibrary
      1. org.eclipse.swt.internal.Library.loadLibrary(Library.java:331)
      2. org.eclipse.swt.internal.Library.loadLibrary(Library.java:240)
      2 frames
    3. org.eclipse.swt
      OS.<clinit>
      1. org.eclipse.swt.internal.gtk.OS.<clinit>(OS.java:22)
      1 frame
    4. RWT
      Display.<clinit>
      1. org.eclipse.swt.internal.Converter.wcsToMbcs(Converter.java:63)
      2. org.eclipse.swt.internal.Converter.wcsToMbcs(Converter.java:54)
      3. org.eclipse.swt.widgets.Display.<clinit>(Display.java:133)
      3 frames
    5. ru.runa.notifier
      PlatformLoader.main
      1. ru.runa.notifier.PlatformLoader.<init>(PlatformLoader.java:44)
      2. ru.runa.notifier.PlatformLoader.main(PlatformLoader.java:78)
      2 frames