org.osgi.framework.BundleException

There are no available Samebug tips for this exception. Do you have an idea how to solve this issue? A short tip would help users who saw this issue last week.

  • Latest 1.1.4 in Roo repository throws the following exception: {code} Welcome to Spring Roo. For assistance press TAB or type "hint" then hit ENTER. roo> ERROR: Error starting file:/home/eruiz/software/java/spring-roo-1.1.4.BUILD-SNAPSHOT/bundle/org.springframework.roo.wrapping.cloud-foundry-api-0.0.1.0010.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.wrapping.cloud-foundry-api [62]: Unable to resolve 62.0: missing requirement [62.0] package; (&(package=org.codehaus.jackson)(version>=1.6.0)(!(version>=2.0.0)))) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.wrapping.cloud-foundry-api [62]: Unable to resolve 62.0: missing requirement [62.0] package; (&(package=org.codehaus.jackson)(version>=1.6.0)(!(version>=2.0.0))) at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3409) at org.apache.felix.framework.Felix.startBundle(Felix.java:1719) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1148) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:264) at java.lang.Thread.run(Thread.java:662) [org.springframework.roo.wrapping.cloud-foundry-api [62]] FrameworkEvent ERROR org.apache.felix.log.LogException: org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.wrapping.cloud-foundry-api [62]: Unable to resolve 62.0: missing requirement [62.0] package; (&(package=org.codehaus.jackson)(version>=1.6.0)(!(version>=2.0.0))) at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3409) at org.apache.felix.framework.Felix.startBundle(Felix.java:1719) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1148) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:264) at java.lang.Thread.run(Thread.java:662) {code}
    via by Enrique Ruiz (DiSiD),
  • Latest 1.1.4 in Roo repository throws the following exception: {code} Welcome to Spring Roo. For assistance press TAB or type "hint" then hit ENTER. roo> ERROR: Error starting file:/home/eruiz/software/java/spring-roo-1.1.4.BUILD-SNAPSHOT/bundle/org.springframework.roo.wrapping.cloud-foundry-api-0.0.1.0010.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.wrapping.cloud-foundry-api [62]: Unable to resolve 62.0: missing requirement [62.0] package; (&(package=org.codehaus.jackson)(version>=1.6.0)(!(version>=2.0.0)))) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.wrapping.cloud-foundry-api [62]: Unable to resolve 62.0: missing requirement [62.0] package; (&(package=org.codehaus.jackson)(version>=1.6.0)(!(version>=2.0.0))) at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3409) at org.apache.felix.framework.Felix.startBundle(Felix.java:1719) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1148) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:264) at java.lang.Thread.run(Thread.java:662) [org.springframework.roo.wrapping.cloud-foundry-api [62]] FrameworkEvent ERROR org.apache.felix.log.LogException: org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.wrapping.cloud-foundry-api [62]: Unable to resolve 62.0: missing requirement [62.0] package; (&(package=org.codehaus.jackson)(version>=1.6.0)(!(version>=2.0.0))) at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3409) at org.apache.felix.framework.Felix.startBundle(Felix.java:1719) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1148) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:264) at java.lang.Thread.run(Thread.java:662) {code}
    via by Enrique Ruiz (DiSiD),
  • Custom Spring roo addon fail
    via Stack Overflow by user2378554
    ,
  • NoClassDefFoundError when loading BundleContext
    via by René Groeschke,
  • Cant get Spring OSGI to work in felix
    via by hazlorealidad,
  • Peaberry and service import problem
    via by Richard Wallace,
    • org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.wrapping.cloud-foundry-api [62]: Unable to resolve 62.0: missing requirement [62.0] package; (&(package=org.codehaus.jackson)(version>=1.6.0)(!(version>=2.0.0))) at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3409) at org.apache.felix.framework.Felix.startBundle(Felix.java:1719) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1148) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:264) at java.lang.Thread.run(Thread.java:662)

    Users with the same issue

    andyglickandyglick
    2 times, last one,
    Unknown visitor
    Unknown visitor1 times, last one,
    Unknown visitor
    Unknown visitor1 times, last one,
    Unknown visitor
    Unknown visitor1 times, last one,
    Unknown visitor
    Unknown visitor1 times, last one,
    2 more bugmates