org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.wrapping.cloud-foundry-api [62]: Unable to resolve 62.0: missing requirement [62.0] package; (&(package=org.codehaus.jackson)(version>=1.6.0)(!(version>=2.0.0)))

Spring JIRA | Enrique Ruiz (DiSiD) | 6 years ago
  1. 0

    Latest 1.1.4 in Roo repository throws the following exception: {code} Welcome to Spring Roo. For assistance press TAB or type "hint" then hit ENTER. roo> ERROR: Error starting file:/home/eruiz/software/java/spring-roo-1.1.4.BUILD-SNAPSHOT/bundle/org.springframework.roo.wrapping.cloud-foundry-api-0.0.1.0010.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.wrapping.cloud-foundry-api [62]: Unable to resolve 62.0: missing requirement [62.0] package; (&(package=org.codehaus.jackson)(version>=1.6.0)(!(version>=2.0.0)))) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.wrapping.cloud-foundry-api [62]: Unable to resolve 62.0: missing requirement [62.0] package; (&(package=org.codehaus.jackson)(version>=1.6.0)(!(version>=2.0.0))) at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3409) at org.apache.felix.framework.Felix.startBundle(Felix.java:1719) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1148) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:264) at java.lang.Thread.run(Thread.java:662) [org.springframework.roo.wrapping.cloud-foundry-api [62]] FrameworkEvent ERROR org.apache.felix.log.LogException: org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.wrapping.cloud-foundry-api [62]: Unable to resolve 62.0: missing requirement [62.0] package; (&(package=org.codehaus.jackson)(version>=1.6.0)(!(version>=2.0.0))) at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3409) at org.apache.felix.framework.Felix.startBundle(Felix.java:1719) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1148) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:264) at java.lang.Thread.run(Thread.java:662) {code}

    Spring JIRA | 6 years ago | Enrique Ruiz (DiSiD)
    org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.wrapping.cloud-foundry-api [62]: Unable to resolve 62.0: missing requirement [62.0] package; (&(package=org.codehaus.jackson)(version>=1.6.0)(!(version>=2.0.0)))
  2. 0

    Latest 1.1.4 in Roo repository throws the following exception: {code} Welcome to Spring Roo. For assistance press TAB or type "hint" then hit ENTER. roo> ERROR: Error starting file:/home/eruiz/software/java/spring-roo-1.1.4.BUILD-SNAPSHOT/bundle/org.springframework.roo.wrapping.cloud-foundry-api-0.0.1.0010.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.wrapping.cloud-foundry-api [62]: Unable to resolve 62.0: missing requirement [62.0] package; (&(package=org.codehaus.jackson)(version>=1.6.0)(!(version>=2.0.0)))) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.wrapping.cloud-foundry-api [62]: Unable to resolve 62.0: missing requirement [62.0] package; (&(package=org.codehaus.jackson)(version>=1.6.0)(!(version>=2.0.0))) at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3409) at org.apache.felix.framework.Felix.startBundle(Felix.java:1719) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1148) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:264) at java.lang.Thread.run(Thread.java:662) [org.springframework.roo.wrapping.cloud-foundry-api [62]] FrameworkEvent ERROR org.apache.felix.log.LogException: org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.wrapping.cloud-foundry-api [62]: Unable to resolve 62.0: missing requirement [62.0] package; (&(package=org.codehaus.jackson)(version>=1.6.0)(!(version>=2.0.0))) at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3409) at org.apache.felix.framework.Felix.startBundle(Felix.java:1719) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1148) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:264) at java.lang.Thread.run(Thread.java:662) {code}

    Spring JIRA | 6 years ago | Enrique Ruiz (DiSiD)
    org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.wrapping.cloud-foundry-api [62]: Unable to resolve 62.0: missing requirement [62.0] package; (&(package=org.codehaus.jackson)(version>=1.6.0)(!(version>=2.0.0)))
  3. 0

    [GLASSFISH-15772] 3.0.1 to 3.1 update requires removal of osgi-cache for the DAS to start - Java.net JIRA

    java.net | 11 months ago
    org.osgi.framework.BundleException: Unresolved constraint in bundle org.glassfish.osgi-web-container : Unable to resolve 217.0: missing requirement package; (&(package=com.sun.enterprise.config.serverbeans)(version>=3.0.0)) [caused by: Unable to resolve 10.0: missing requirement package; (&(package=com.sun.appserv.server.util)(version>=3.0.0)) [caused by: Unable to resolve 187.0: missing requirement package; (&(package=com.sun.enterprise.module.bootstrap)(version>=1.0.0)) [caused by: Unable to resolve 57.0: missing requirement package; (&(package=com.sun.hk2.component)(version>=1.0.0)) [caused by: Unable to resolve 198.0: missing requirement package; (package=org.jvnet.tiger_types)]]]]
  4. Speed up your debug routine!

    Automated exception search integrated into your IDE

  5. 0

    Resolve dependencies error in Sling OSGi container

    Stack Overflow | 2 years ago | Barcelona
    org.osgi.framework.BundleException: Unresolved constraint in bundle net.jasonday.examples.sling.spring.mvc [79]: Unable to resolve 79.0: missing requirement [79 .0] package; (&(package=javax.annotation)(version>=1.0.0)(!(version>=2.0.0)))
  6. 0

    camel-example-cxf Not Deployed in ServiceMix 4.4.2

    Stack Overflow | 4 years ago | abhi
    org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.camel.camel-example-cxf [43]: Unable to resolve 43.0: missing requirement [43.0] package; (&(package=org.apache.activemq.broker)(version>=5.7.0)(!(version>=6.0.0)))

    3 unregistered visitors
    Not finding the right solution?
    Take a tour to get the most out of Samebug.

    Tired of useless tips?

    Automated exception search integrated into your IDE

    Root Cause Analysis

    1. org.osgi.framework.BundleException

      Unresolved constraint in bundle org.springframework.roo.wrapping.cloud-foundry-api [62]: Unable to resolve 62.0: missing requirement [62.0] package; (&(package=org.codehaus.jackson)(version>=1.6.0)(!(version>=2.0.0)))

      at org.apache.felix.framework.Felix.resolveBundle()
    2. Apache Felix Framework
      StartLevelImpl.run
      1. org.apache.felix.framework.Felix.resolveBundle(Felix.java:3409)
      2. org.apache.felix.framework.Felix.startBundle(Felix.java:1719)
      3. org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1148)
      4. org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:264)
      4 frames
    3. Java RT
      Thread.run
      1. java.lang.Thread.run(Thread.java:662)
      1 frame