org.apache.felix.log.LogException: org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.wrapping.cloud-foundry-api [62]: Unable to resolve 62.0: missing requirement [62.0] package; (&(package=org.codehaus.jackson)(version>=1.6.0)(!(version>=2.0.0)))

Searched on Google with the first line of a JAVA stack trace?

We can recommend more relevant solutions and speed up debugging when you paste your entire stack trace with the exception message. Try a sample exception.

Recommended solutions based on your search

Solutions on the web

via Spring JIRA by Enrique Ruiz (DiSiD), 1 year ago
org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.wrapping.cloud-foundry-api [62]: Unable to resolve 62.0: missing requirement [62.0] package; (&(package=org.codehaus.jackson)(version>=1.6.0)(!(version>=2.0.0)))
via Spring JIRA by Enrique Ruiz (DiSiD), 1 year ago
org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.wrapping.cloud-foundry-api [62]: Unable to resolve 62.0: missing requirement [62.0] package; (&(package=org.codehaus.jackson)(version>=1.6.0)(!(version>=2.0.0)))
via jboss.org by Unknown author, 2 years ago
org.osgi.framework.BundleException: Unresolved constraint in bundle 13: package; (&(package=org.apache.log4j)(version>=1.2.15))
via wordpress.com by Unknown author, 2 years ago
org.osgi.framework.BundleException: Unresolved constraint in bundle com.springsource.oracle.jdb c [66]: Unable to resolve 66.0: missing requirement [66.0] package; (&(package=javax.resource)(version>=1.5.0)(!(version>=2.0.0)))
via Stack Overflow by Andres Olarte
, 2 years ago
org.osgi.framework.BundleException: Uses constraint violation. Unable to resolve module org.springframework.roo.addon.entity [83.0] because it is exposed to package 'org.springframework.roo.support.util' from modules org.springframework.roo.support
org.apache.felix.log.LogException: org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.wrapping.cloud-foundry-api [62]: Unable to resolve 62.0: missing requirement [62.0] package; (&(package=org.codehaus.jackson)(version>=1.6.0)(!(version>=2.0.0)))
at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3409)
at org.apache.felix.framework.Felix.startBundle(Felix.java:1719)
at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1148)
at java.lang.Thread.run(Thread.java:662)

Users with the same issue

You are the first who have seen this exception.

Write tip

Know the solutions? Share your knowledge to help other developers to debug faster.