java.lang.NullPointerException

There are no available Samebug tips for this exception. Do you have an idea how to solve this issue? A short tip would help users who saw this issue last week.

  • I just upgraded to 3.2.0, OS-X 10.9.1 (Mavericks),Xcode 5.0.2 Launching existing or new projects to the iOS simulator I'm getting: An internal error occurred during: "Launching Titanium iOS Simulator - iOS Simulator - ProjectName". java.lang.NullPointerException Note that I can open the iPhone simulator (7.0.3) from Xcode - the problem is with the new Studio. Studio log file: !SESSION 2013-12-21 22:04:03.045 ----------------------------------------------- eclipse.buildId=unknown java.version=1.6.0_65 java.vendor=Apple Inc. BootLoader constants: OS=macosx, ARCH=x86, WS=cocoa, NL=en_US Framework arguments: -keyring /Users/Marek/.eclipse_keyring -showlocation Command-line arguments: -os macosx -ws cocoa -arch x86 -keyring /Users/Marek/.eclipse_keyring -consoleLog -showlocation !ENTRY org.eclipse.core.net 1 0 2013-12-21 22:04:05.925 !MESSAGE System property http.nonProxyHosts has been set to local|*.local|169.254/16|*.169.254/16 by an external source. This value will be overwritten using the values from the preferences !ENTRY org.eclipse.ui 2 0 2013-12-21 22:04:06.140 !MESSAGE Warnings while parsing the images from the 'org.eclipse.ui.commandImages' extension point. !SUBENTRY 1 org.eclipse.ui 2 0 2013-12-21 22:04:06.140 !MESSAGE Cannot bind to an undefined command: plug-in='com.appcelerator.titanium.android.ui', id='com.appcelerator.titanium.mobile.command.run_on_device.android' !SUBENTRY 1 org.eclipse.ui 2 0 2013-12-21 22:04:06.140 !MESSAGE Cannot bind to an undefined command: plug-in='com.appcelerator.titanium.android.ui', id='com.appcelerator.titanium.mobile.command.debug_on_device.android' !ENTRY org.eclipse.core.jobs 4 2 2013-12-21 22:04:46.093 !MESSAGE An internal error occurred during: "Launching Titanium iOS Simulator - iOS Simulator - ttt". !STACK 0 java.lang.NullPointerException at com.appcelerator.titanium.ios.ui.launching.simulator.IOSSimulatorLaunchConfigurationDelegate.launch(IOSSimulatorLaunchConfigurationDelegate.java:62) at org.eclipse.debug.internal.core.LaunchConfiguration.launch(LaunchConfiguration.java:858) at org.eclipse.debug.internal.core.LaunchConfiguration.launch(LaunchConfiguration.java:707) at org.eclipse.debug.internal.ui.DebugUIPlugin.buildAndLaunch(DebugUIPlugin.java:1018) at org.eclipse.debug.internal.ui.DebugUIPlugin$8.run(DebugUIPlugin.java:1222) at org.eclipse.core.internal.jobs.Worker.run(Worker.java:53)
    via by Mark Mokryn,
  • I just upgraded to 3.2.0, OS-X 10.9.1 (Mavericks),Xcode 5.0.2 Launching existing or new projects to the iOS simulator I'm getting: An internal error occurred during: "Launching Titanium iOS Simulator - iOS Simulator - ProjectName". java.lang.NullPointerException Note that I can open the iPhone simulator (7.0.3) from Xcode - the problem is with the new Studio. Studio log file: !SESSION 2013-12-21 22:04:03.045 ----------------------------------------------- eclipse.buildId=unknown java.version=1.6.0_65 java.vendor=Apple Inc. BootLoader constants: OS=macosx, ARCH=x86, WS=cocoa, NL=en_US Framework arguments: -keyring /Users/Marek/.eclipse_keyring -showlocation Command-line arguments: -os macosx -ws cocoa -arch x86 -keyring /Users/Marek/.eclipse_keyring -consoleLog -showlocation !ENTRY org.eclipse.core.net 1 0 2013-12-21 22:04:05.925 !MESSAGE System property http.nonProxyHosts has been set to local|*.local|169.254/16|*.169.254/16 by an external source. This value will be overwritten using the values from the preferences !ENTRY org.eclipse.ui 2 0 2013-12-21 22:04:06.140 !MESSAGE Warnings while parsing the images from the 'org.eclipse.ui.commandImages' extension point. !SUBENTRY 1 org.eclipse.ui 2 0 2013-12-21 22:04:06.140 !MESSAGE Cannot bind to an undefined command: plug-in='com.appcelerator.titanium.android.ui', id='com.appcelerator.titanium.mobile.command.run_on_device.android' !SUBENTRY 1 org.eclipse.ui 2 0 2013-12-21 22:04:06.140 !MESSAGE Cannot bind to an undefined command: plug-in='com.appcelerator.titanium.android.ui', id='com.appcelerator.titanium.mobile.command.debug_on_device.android' !ENTRY org.eclipse.core.jobs 4 2 2013-12-21 22:04:46.093 !MESSAGE An internal error occurred during: "Launching Titanium iOS Simulator - iOS Simulator - ttt". !STACK 0 java.lang.NullPointerException at com.appcelerator.titanium.ios.ui.launching.simulator.IOSSimulatorLaunchConfigurationDelegate.launch(IOSSimulatorLaunchConfigurationDelegate.java:62) at org.eclipse.debug.internal.core.LaunchConfiguration.launch(LaunchConfiguration.java:858) at org.eclipse.debug.internal.core.LaunchConfiguration.launch(LaunchConfiguration.java:707) at org.eclipse.debug.internal.ui.DebugUIPlugin.buildAndLaunch(DebugUIPlugin.java:1018) at org.eclipse.debug.internal.ui.DebugUIPlugin$8.run(DebugUIPlugin.java:1222) at org.eclipse.core.internal.jobs.Worker.run(Worker.java:53)
    via by Mark Mokryn,
    • java.lang.NullPointerException at com.appcelerator.titanium.ios.internal.core.IOSNodeJSCommandsHelper.build(IOSNodeJSCommandsHelper.java:265) at com.appcelerator.titanium.ios.internal.core.IOSNodeJSCommandsHelper.runOnSimulator(IOSNodeJSCommandsHelper.java:362) at com.appcelerator.titanium.ios.internal.core.IOSCommandsHelper.run(IOSCommandsHelper.java:461) at com.appcelerator.titanium.ios.internal.core.IOSNodeJSCommandsHelper.run(IOSNodeJSCommandsHelper.java:1) at com.appcelerator.titanium.core.internal.cli.NodeTitaniumSDKCommandsHandler.run(NodeTitaniumSDKCommandsHandler.java:399) at com.appcelerator.titanium.ios.ui.launching.simulator.IOSSimulatorLaunchConfigurationDelegate.launch(IOSSimulatorLaunchConfigurationDelegate.java:66) at org.eclipse.debug.internal.core.LaunchConfiguration.launch(LaunchConfiguration.java:857) at org.eclipse.debug.internal.core.LaunchConfiguration.launch(LaunchConfiguration.java:706) at org.eclipse.debug.internal.ui.DebugUIPlugin.buildAndLaunch(DebugUIPlugin.java:1018) at org.eclipse.debug.internal.ui.DebugUIPlugin$8.run(DebugUIPlugin.java:1222) at org.eclipse.core.internal.jobs.Worker.run(Worker.java:53)
    No Bugmate found.