org.apache.maven.project.ProjectBuildingException

There are no available Samebug tips for this exception. Do you have an idea how to solve this issue? A short tip would help users who saw this issue last week.

  • if using *central* as repository id in settings.xml to configure a different repository dep-analyzer still uses http://repo1.maven.org/maven2/ as central one. {code} org.apache.maven.project.ProjectBuildingException: POM 'axis2.rampart:axis2-security' not found in repository: Unable to download the artifact from any repository axis2.rampart:axis2-security:pom:1.1 from the specified remote repositories: snapshots (http://gsbede02:8085/archiva/repository/snapshots/), central (http://repo1.maven.org/maven2/) at org.apache.maven.project.DefaultMavenProjectBuilder.findModelFromRepository(DefaultMavenProjectBuilder.java:528) at org.apache.maven.project.DefaultMavenProjectBuilder.buildFromRepository(DefaultMavenProjectBuilder.java:228) at org.apache.maven.embedder.MavenEmbedder.buildFromRepository(MavenEmbedder.java:269) at org.jfrog.maven.viewer.dao.DefaultMavenProjectDao.getMavenProject(DefaultMavenProjectDao.java:138) at org.jfrog.maven.viewer.domain.ArtifactFactory.createArtifact(ArtifactFactory.java:157) {code} snippet of settings.xml: {code:xml} ... <profiles> <profile> <id>archiva</id> <repositories> <repository> <id>central</id> <name>Archiva Managed Internal Repository</name> <url>http://gsbede02:8085/archiva/repository/internal/</url> <releases> <enabled>true</enabled> </releases> <snapshots> <enabled>false</enabled> </snapshots> </repository> <repository> <id>snapshots</id> <name>Archiva Managed Snapshot Repository</name> <url>http://gsbede02:8085/archiva/repository/snapshots/</url> <releases> <enabled>true</enabled> </releases> <snapshots> <enabled>true</enabled> <updatePolicy>always</updatePolicy> </snapshots> </repository> </repositories> ... <activeProfiles> <activeProfile>archiva</activeProfile> </activeProfiles> </settings> {code} because it recognizes declared repository id *snapshots*, it does not seem to ignore the profile in general. on command line (maven 2.0.8) resolving to declared central-repository goes fine.
    via by manuel aldana,
  • if using *central* as repository id in settings.xml to configure a different repository dep-analyzer still uses http://repo1.maven.org/maven2/ as central one. {code} org.apache.maven.project.ProjectBuildingException: POM 'axis2.rampart:axis2-security' not found in repository: Unable to download the artifact from any repository axis2.rampart:axis2-security:pom:1.1 from the specified remote repositories: snapshots (http://gsbede02:8085/archiva/repository/snapshots/), central (http://repo1.maven.org/maven2/) at org.apache.maven.project.DefaultMavenProjectBuilder.findModelFromRepository(DefaultMavenProjectBuilder.java:528) at org.apache.maven.project.DefaultMavenProjectBuilder.buildFromRepository(DefaultMavenProjectBuilder.java:228) at org.apache.maven.embedder.MavenEmbedder.buildFromRepository(MavenEmbedder.java:269) at org.jfrog.maven.viewer.dao.DefaultMavenProjectDao.getMavenProject(DefaultMavenProjectDao.java:138) at org.jfrog.maven.viewer.domain.ArtifactFactory.createArtifact(ArtifactFactory.java:157) {code} snippet of settings.xml: {code:xml} ... <profiles> <profile> <id>archiva</id> <repositories> <repository> <id>central</id> <name>Archiva Managed Internal Repository</name> <url>http://gsbede02:8085/archiva/repository/internal/</url> <releases> <enabled>true</enabled> </releases> <snapshots> <enabled>false</enabled> </snapshots> </repository> <repository> <id>snapshots</id> <name>Archiva Managed Snapshot Repository</name> <url>http://gsbede02:8085/archiva/repository/snapshots/</url> <releases> <enabled>true</enabled> </releases> <snapshots> <enabled>true</enabled> <updatePolicy>always</updatePolicy> </snapshots> </repository> </repositories> ... <activeProfiles> <activeProfile>archiva</activeProfile> </activeProfiles> </settings> {code} because it recognizes declared repository id *snapshots*, it does not seem to ignore the profile in general. on command line (maven 2.0.8) resolving to declared central-repository goes fine.
    via by manuel aldana,
  • Documentation Outdated.
    via by Mark1900,
  • maven site reports artifactnotfoundexception
    via Stack Overflow by Michael
    ,
  • Cannot create Lift projects using Maven and Netbeans
    via by Akshay Dev Wankhede,
  • mvn install - iniciante
    via by Assis Antunes,
    • org.apache.maven.project.ProjectBuildingException: POM 'axis2.rampart:axis2-security' not found in repository: Unable to download the artifact from any repository axis2.rampart:axis2-security:pom:1.1 from the specified remote repositories: snapshots (http://gsbede02:8085/archiva/repository/snapshots/), central (http://repo1.maven.org/maven2/) at org.apache.maven.project.DefaultMavenProjectBuilder.findModelFromRepository(DefaultMavenProjectBuilder.java:528) at org.apache.maven.project.DefaultMavenProjectBuilder.buildFromRepository(DefaultMavenProjectBuilder.java:228) at org.apache.maven.embedder.MavenEmbedder.buildFromRepository(MavenEmbedder.java:269) at org.jfrog.maven.viewer.dao.DefaultMavenProjectDao.getMavenProject(DefaultMavenProjectDao.java:138) at org.jfrog.maven.viewer.domain.ArtifactFactory.createArtifact(ArtifactFactory.java:157)
    No Bugmate found.