weblogic.ejb20.WLDeploymentException

There are no available Samebug tips for this exception. Do you have an idea how to solve this issue? A short tip would help users who saw this issue last week.

  • wps.jar error
    via by 3004,
  • EJBCA, JEE PKI Certificate Authority / Mailing Lists
    via by Unknown author,
  • error in deploying EJB
    via by andrew,
  • error in deploying EJB
    via by 3004,
  • error in deploying EJB
    via by 3004,
  • error in deploying EJB
    via by andrew,
    • weblogic.ejb20.WLDeploymentException: The run-as principal 'portaladmin' for EJB 'MailService' is not a user in the current realm. The user must exist for the EJB to successfully deploy. at weblogic.ejb20.deployer.MBeanDeploymentInfoImpl.getRunAsPrincipal(MBeanDeploymentInfoImpl.java:1047) at weblogic.ejb20.deployer.MBeanDeploymentInfoImpl.initializeRunAsSettings(MBeanDeploymentInfoImpl.java:838) at weblogic.ejb20.deployer.MBeanDeploymentInfoImpl.<init>(MBeanDeploymentInfoImpl.java:246) at weblogic.ejb20.deployer.EJBDeployer.prepare(EJBDeployer.java:1262) at weblogic.ejb20.deployer.EJBModule.prepare(EJBModule.java:477) at weblogic.j2ee.J2EEApplicationContainer.prepareModule(J2EEApplicationContainer.java:2962) at weblogic.j2ee.J2EEApplicationContainer.prepareModules(J2EEApplicationContainer.java:1534) at weblogic.j2ee.J2EEApplicationContainer.prepare(J2EEApplicationContainer.java:1188) at weblogic.j2ee.J2EEApplicationContainer.prepare(J2EEApplicationContainer.java:1031) at weblogic.management.deploy.slave.SlaveDeployer$ComponentActivateTask.prepareContainer(SlaveDeployer.java:2602) at weblogic.management.deploy.slave.SlaveDeployer$ActivateTask.createContainer(SlaveDeployer.java:2552) at weblogic.management.deploy.slave.SlaveDeployer$ActivateTask.prepare(SlaveDeployer.java:2474) at weblogic.management.deploy.slave.SlaveDeployer.processPrepareTask(SlaveDeployer.java:798) at weblogic.management.deploy.slave.SlaveDeployer.prepareDelta(SlaveDeployer.java:507) at weblogic.management.deploy.slave.SlaveDeployer.prepareUpdate(SlaveDeployer.java:465) at weblogic.drs.internal.SlaveCallbackHandler$1.execute(SlaveCallbackHandler.java:25) at weblogic.kernel.ExecuteThread.execute(ExecuteThread.java:197) at weblogic.kernel.ExecuteThread.run(ExecuteThread.java:170) at weblogic.management.deploy.slave.SlaveDeployer$ActivateTask.createContainer(SlaveDeployer.java:2556) at weblogic.management.deploy.slave.SlaveDeployer$ActivateTask.prepare(SlaveDeployer.java:2474) at weblogic.management.deploy.slave.SlaveDeployer.processPrepareTask(SlaveDeployer.java:798) at weblogic.management.deploy.slave.SlaveDeployer.prepareDelta(SlaveDeployer.java:507) at weblogic.management.deploy.slave.SlaveDeployer.prepareUpdate(SlaveDeployer.java:465) at weblogic.drs.internal.SlaveCallbackHandler$1.execute(SlaveCallbackHandler.java:25) at weblogic.kernel.ExecuteThread.execute(ExecuteThread.java:197) at weblogic.kernel.ExecuteThread.run(ExecuteThread.java:170)
    No Bugmate found.