org.osgi.framework.BundleException

Unresolved constraint in bundle org.springframework.roo.addon.property.editor [23]: Unable to resolve 23.0: missing requirement [23.0] package; (&(package=org.springframework.roo.addon.entity)(version>=1.1.0)(!(version>=2.0.0))) [caused by: Unable to resolve 13.0: missing requirement [13.0] package; (&(package=org.springframework.roo.addon.configurable)(version>=1.1.0)(!(version>=2.0.0))) [caused by: Unable to resolve 8.0: missing requirement [8.0] package; (&(package=org.springframework.roo.classpath)(version>=1.1.0)(!(version>=2.0.0))) [caused by: Unable t o resolve 36.0: missing requirement [36.0] package; (&(package=org.springframework.roo.file.monitor)(version>=1.1.0)(!(version>=2.0.0))) [caused by: Unable to resolve 39.0: missing requirement [39.0] package; (&(package=org.springframework.roo.support.ant)(version>=1.1.0)(!(version>=2.0.0))) [caused by: Unable to resolve 52.0: missing requirement [52.0] package; (package=javax.xml.namespace)]]]]]

Samebug tips0

We couldn't find tips for this exception.

Don't give up yet. Paste your full stack trace to get a solution.

Solutions on the web241

  • via Unknown by The Alchemist,
  • via Unknown by Martin Lippert,
  • via Unknown by Martin Lippert,
  • Stack trace

    • org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.property.editor [23]: Unable to resolve 23.0: missing requirement [23.0] package; (&(package=org.springframework.roo.addon.entity)(version>=1.1.0)(!(version>=2.0.0))) [caused by: Unable to resolve 13.0: missing requirement [13.0] package; (&(package=org.springframework.roo.addon.configurable)(version>=1.1.0)(!(version>=2.0.0))) [caused by: Unable to resolve 8.0: missing requirement [8.0] package; (&(package=org.springframework.roo.classpath)(version>=1.1.0)(!(version>=2.0.0))) [caused by: Unable t o resolve 36.0: missing requirement [36.0] package; (&(package=org.springframework.roo.file.monitor)(version>=1.1.0)(!(version>=2.0.0))) [caused by: Unable to resolve 39.0: missing requirement [39.0] package; (&(package=org.springframework.roo.support.ant)(version>=1.1.0)(!(version>=2.0.0))) [caused by: Unable to resolve 52.0: missing requirement [52.0] package; (package=javax.xml.namespace)]]]]] at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3409) at org.apache.felix.framework.Felix.startBundle(Felix.java:1719) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1148) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:264) at java.lang.Thread.run(Thread.java:722)

    Write tip

    You have a different solution? A short tip here would help you and many other users who saw this issue last week.

    Users with the same issue

    andyglickandyglick
    2 times, last one
    Unknown visitor
    Unknown visitorOnce,
    Unknown visitor
    Unknown visitorOnce,
    Unknown visitor
    Unknown visitorOnce,
    Unknown visitor
    Unknown visitorOnce,
    2 more bugmates