Pattern selector

Most relevant patterns first. Most helpful ones displayed. Click here to show all.

  1. Thread.run() has thrown a BundleException
    Java Runtime
    5
    6
    20
  2. StartLevelImpl.run() has thrown a BundleException
    Apache Felix Main
    5
    6
    21

Your stack trace compared to the selected pattern

Jump to solutionsExpand frames
org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.jdbc [17]: Unable to resolve 17.0: missing requirement [17.0] package; (&(package=org.springframework.roo.support.api)(version>=1.1.0)(!(version>=2.0.0))) [caused by: Unable to resolve 52.0: missing requirement [52.0] package; (package=javax.xml.namespace)]
3 matching frames hidden
    at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:264)
    at java.lang.Thread.run(Thread.java:722)

External results for this pattern (10)

  1. aowenvia GitHub4 weeks ago
    Unresolved constraint in bundle org.apache.karaf.deployer.wrap [29]: Unable to resolve 29.0: missing requirement [29.0] package; (&(package=org.apache.felix.fileinstall)(version>=3.2.0)(!(version>=4.0.0))) [caused by: Unable to resolve 6.0: missing requirement [6.0] package; (&(package=org.osgi.framework)(version>=1.4.0)(!(version>=2.0.0)))] ERROR: Bundle org.apache.karaf.deployer.wrap [29] Error starting mvn:org.apache.karaf.deployer/org.apache.karaf.deployer.wrap/2.2.11 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.deployer.wrap [29]: Unable to resolve 29.0: missing requirement [29.0] package; (&(package=org.apache.felix.fileinstall)(version>=3.2.0)(!(version>=4.0.0))) [caused by: Unable to resolve 6.0: missing requirement [6.0] package; (&(package=org.osgi.framework)(version>=1.4.0)(!(version>=2.0.0)))]) ```
    Show stack trace
  2. Unknown authorvia Stack Overflow3 months ago
    Unresolved constraint in bundle org.springframework.roo.support.osgi [70]: Unable to resolve 70.0: missing requirement [70.0] package; (&(package=org.springframework.roo.support.ant)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)]
    Show stack trace
  3. Unresolved constraint in bundle org.ops4j.pax.url.wrap [1]: Unable to resolve 1.0: missing requirement [1.0] package; (package=javax.net.ssl)
    Show stack trace
  4. Unknown authorvia wordpress.com5 months ago
    Unresolved constraint in bundle org.sakaiproject.nakamura.webconsole.solr [124]: Unable to resolve 124.0: missing requirement [124.0] package; (package=org.apache.solr.client.solrj) [caused by: Unable to resolve 84.0: missing requirement [84.0] package; (package=org.sakaiproject.nakamura.api.lite) [caused by: Unable to resolve 86.0: missing requirement [86.0] package; (&(package=com.google.common.collect)(version>=9.0.0)(!(version>=10.0.0)))]]
    Show stack trace
  5. Unknown authorvia wordpress.com5 months ago
    Unresolved constraint in bundle org.sakaiproject.nakamura.webconsole.solr [124]: Unable to resolve 124.0: missing requirement [124.0] package; (package=org.apache.solr.client.solrj) [caused by: Unable to resolve 84.0: missing requirement [84.0] package; (package=org.sakaiproject.nakamura.api.lite) [caused by: Unable to resolve 86.0: missing requirement [86.0] package; (&(package=com.google.common.collect)(version>=9.0.0)(!(version>=10.0.0)))]]
    Show stack trace
  6. Unknown authorvia blogspot.com5 months ago
    Unresolved constraint in bundle jaxb-api [1]: Unable to resolve 1.0: missing requirement [1.0] package; (package=javax.activation)
    Show stack trace
  7. Unknown authorvia netbeans.org5 months ago
    Unresolved constraint in bundle module3 [3]: module; (&(bundle-symbolic-name=org.apache.felix.prefs)(bundle-version>=1.0.4)(!(bundle- version>=100.0.0)))
    Show stack trace
  8. Unknown authorvia qiita.com5 months ago
    Unresolved constraint in bundle org.springframework.uaa.client [81]: Unable to resolve 81.0: missing requirement [81.0] package; (package=javax.xml.parsers)
    Show stack trace
  9. Krishna Srinivasanvia Spring JIRA5 months ago
    Unresolved constraint in bundle org.springframework.roo.uaa [71]: Unable to resolve 71.0: missing requirement [71.0] package; (&(package=org.springframework.roo.shell)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 64.0: missing requirement [64.0] package; (package=javax.xml.parsers)]
    Show stack trace
  10. Artemvia Spring JIRA5 months ago
    Unresolved constraint in bundle com.github.antlrjavaparser.antlr-java-parser [3]: Unable to resolve 3.0: missing requirement [3.0] package; (package=org.antlr.v4.runtime) [caused by: Unable to resolve 74.0: missing requirement [74.0] package; (package=javax.imageio)]
    Show stack trace