java.io.IOException

Failed to deploy file: HTTP response code: 404. HTTP response message: The target deployment path 'groupid/artifactid/0.0.7-SNAPSHOT/artifactid-0.0.7-SNAPSHOT.pom' does not match the POM's expected path prefix 'groupid/artifactid/0.0.8-SNAPSHOT'. Please verify your POM content for correctness and make sure the source path is a valid Maven 2 repository root path.

Samebug tips0

We couldn't find tips for this exception.

Don't give up yet. Paste your full stack trace to get a solution.

Solutions on the web52

  • via Unknown by Shawn Clark,
  • via Unknown by Shawn Clark,
  • Stack trace

    • java.io.IOException: Failed to deploy file: HTTP response code: 404. HTTP response message: The target deployment path 'groupid/artifactid/0.0.7-SNAPSHOT/artifactid-0.0.7-SNAPSHOT.pom' does not match the POM's expected path prefix 'groupid/artifactid/0.0.8-SNAPSHOT'. Please verify your POM content for correctness and make sure the source path is a valid Maven 2 repository root path. at org.jfrog.build.client.ArtifactoryBuildInfoClient.throwHttpIOException(ArtifactoryBuildInfoClient.java:441) at org.jfrog.build.client.ArtifactoryBuildInfoClient.uploadFile(ArtifactoryBuildInfoClient.java:374) at org.jfrog.build.client.ArtifactoryBuildInfoClient.deployArtifact(ArtifactoryBuildInfoClient.java:275) at org.jfrog.hudson.maven2.ArtifactsDeployer.deployArtifact(ArtifactsDeployer.java:125) at org.jfrog.hudson.maven2.ArtifactsDeployer.deploy(ArtifactsDeployer.java:89) at org.jfrog.hudson.ArtifactoryRedeployPublisher.perform(ArtifactoryRedeployPublisher.java:177) at hudson.tasks.BuildStepMonitor$1.perform(BuildStepMonitor.java:19) at hudson.model.AbstractBuild$AbstractRunner.perform(AbstractBuild.java:601) at hudson.model.AbstractBuild$AbstractRunner.performAllBuildSteps(AbstractBuild.java:580) at hudson.maven.MavenModuleSetBuild$RunnerImpl.post2(MavenModuleSetBuild.java:595) at hudson.model.AbstractBuild$AbstractRunner.post(AbstractBuild.java:528) at hudson.model.Run.run(Run.java:1303) at hudson.maven.MavenModuleSetBuild.run(MavenModuleSetBuild.java:293) at hudson.model.ResourceController.execute(ResourceController.java:88) at hudson.model.Executor.run(Executor.java:137)

    Write tip

    You have a different solution? A short tip here would help you and many other users who saw this issue last week.

    Users with the same issue

    Unknown visitor
    Unknown visitorOnce,