java.lang.IllegalArgumentException: Could not find a grails install for 'P/site'Please configure an install from the Grails preferences page.

SpringSource Issue Tracker | Andy Clement | 6 years ago
tip
Click on the to mark the solution that helps you, Samebug will learn from it.
As a community member, you’ll be rewarded for you help.
  1. 0

    When doing this I did get told to go and configure one (but the formatting wasnt great, no newline after the project name and the P/ is a bit confusing for those not intimate with eclipse). java.lang.IllegalArgumentException: Could not find a grails install for 'P/site'Please configure an install from the Grails preferences page. at com.springsource.sts.grails.commands.GrailsCommandUtils.deleteOutOfSynchPlugins(GrailsCommandUtils.java:392) at com.springsource.sts.grails.commands.GrailsCommandUtils.refreshDependencies(GrailsCommandUtils.java:324) at com.springsource.sts.grails.core.internal.classpath.GrailsClasspathContainerUpdateJob.runInWorkspace(GrailsClasspathContainerUpdateJob.java:77) at org.eclipse.core.internal.resources.InternalWorkspaceJob.run(InternalWorkspaceJob.java:38) at org.eclipse.core.internal.jobs.Worker.run(Worker.java:54) but this also appeared in the log: java.lang.NullPointerException at com.springsource.sts.grails.core.model.GrailsVersion.compareNoQualifier(GrailsVersion.java:116) at com.springsource.sts.grails.core.model.GrailsVersion.compareTo(GrailsVersion.java:89) at com.springsource.sts.grails.ui.internal.importfixes.GrailsProjectVersionFixer$ProjectChangeHandler.handleMismatchingVersions(GrailsProjectVersionFixer.java:329) at com.springsource.sts.grails.ui.internal.importfixes.GrailsProjectVersionFixer$ProjectChangeHandler.handleUnknownEclipseVersion(GrailsProjectVersionFixer.java:354) at com.springsource.sts.grails.ui.internal.importfixes.GrailsProjectVersionFixer$ProjectChangeHandler.fix(GrailsProjectVersionFixer.java:271) at com.springsource.sts.grails.ui.internal.importfixes.GrailsProjectVersionFixer$ProjectChangeHandler.projectsChanged(GrailsProjectVersionFixer.java:244) at com.springsource.sts.grails.ui.internal.importfixes.GrailsProjectVersionFixer$ProjectChangeHandler.access$1(GrailsProjectVersionFixer.java:230) at com.springsource.sts.grails.ui.internal.importfixes.GrailsProjectVersionFixer$1.resourceChanged(GrailsProjectVersionFixer.java:99) at org.eclipse.core.internal.events.NotificationManager$2.run(NotificationManager.java:291) at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:42) at org.eclipse.core.internal.events.NotificationManager.notify(NotificationManager.java:285) at org.eclipse.core.internal.events.NotificationManager.broadcastChanges(NotificationManager.java:149) at org.eclipse.core.internal.resources.Workspace.broadcastPostChange(Workspace.java:327) at org.eclipse.core.internal.resources.Workspace.endOperation(Workspace.java:1181) at org.eclipse.core.internal.resources.Resource.refreshLocal(Resource.java:1676) at org.eclipse.core.internal.refresh.RefreshJob.runInWorkspace(RefreshJob.java:166) at org.eclipse.core.internal.resources.InternalWorkspaceJob.run(InternalWorkspaceJob.java:38) at org.eclipse.core.internal.jobs.Worker.run(Worker.java:54)

    SpringSource Issue Tracker | 6 years ago | Andy Clement
    java.lang.IllegalArgumentException: Could not find a grails install for 'P/site'Please configure an install from the Grails preferences page.
  2. 0

    When doing this I did get told to go and configure one (but the formatting wasnt great, no newline after the project name and the P/ is a bit confusing for those not intimate with eclipse). java.lang.IllegalArgumentException: Could not find a grails install for 'P/site'Please configure an install from the Grails preferences page. at com.springsource.sts.grails.commands.GrailsCommandUtils.deleteOutOfSynchPlugins(GrailsCommandUtils.java:392) at com.springsource.sts.grails.commands.GrailsCommandUtils.refreshDependencies(GrailsCommandUtils.java:324) at com.springsource.sts.grails.core.internal.classpath.GrailsClasspathContainerUpdateJob.runInWorkspace(GrailsClasspathContainerUpdateJob.java:77) at org.eclipse.core.internal.resources.InternalWorkspaceJob.run(InternalWorkspaceJob.java:38) at org.eclipse.core.internal.jobs.Worker.run(Worker.java:54) but this also appeared in the log: java.lang.NullPointerException at com.springsource.sts.grails.core.model.GrailsVersion.compareNoQualifier(GrailsVersion.java:116) at com.springsource.sts.grails.core.model.GrailsVersion.compareTo(GrailsVersion.java:89) at com.springsource.sts.grails.ui.internal.importfixes.GrailsProjectVersionFixer$ProjectChangeHandler.handleMismatchingVersions(GrailsProjectVersionFixer.java:329) at com.springsource.sts.grails.ui.internal.importfixes.GrailsProjectVersionFixer$ProjectChangeHandler.handleUnknownEclipseVersion(GrailsProjectVersionFixer.java:354) at com.springsource.sts.grails.ui.internal.importfixes.GrailsProjectVersionFixer$ProjectChangeHandler.fix(GrailsProjectVersionFixer.java:271) at com.springsource.sts.grails.ui.internal.importfixes.GrailsProjectVersionFixer$ProjectChangeHandler.projectsChanged(GrailsProjectVersionFixer.java:244) at com.springsource.sts.grails.ui.internal.importfixes.GrailsProjectVersionFixer$ProjectChangeHandler.access$1(GrailsProjectVersionFixer.java:230) at com.springsource.sts.grails.ui.internal.importfixes.GrailsProjectVersionFixer$1.resourceChanged(GrailsProjectVersionFixer.java:99) at org.eclipse.core.internal.events.NotificationManager$2.run(NotificationManager.java:291) at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:42) at org.eclipse.core.internal.events.NotificationManager.notify(NotificationManager.java:285) at org.eclipse.core.internal.events.NotificationManager.broadcastChanges(NotificationManager.java:149) at org.eclipse.core.internal.resources.Workspace.broadcastPostChange(Workspace.java:327) at org.eclipse.core.internal.resources.Workspace.endOperation(Workspace.java:1181) at org.eclipse.core.internal.resources.Resource.refreshLocal(Resource.java:1676) at org.eclipse.core.internal.refresh.RefreshJob.runInWorkspace(RefreshJob.java:166) at org.eclipse.core.internal.resources.InternalWorkspaceJob.run(InternalWorkspaceJob.java:38) at org.eclipse.core.internal.jobs.Worker.run(Worker.java:54)

    SpringSource Issue Tracker | 6 years ago | Andy Clement
    java.lang.IllegalArgumentException: Could not find a grails install for 'P/site'Please configure an install from the Grails preferences page.

    Root Cause Analysis

    1. java.lang.IllegalArgumentException

      Could not find a grails install for 'P/site'Please configure an install from the Grails preferences page.

      at com.springsource.sts.grails.commands.GrailsCommandUtils.deleteOutOfSynchPlugins()
    2. com.springsource.sts
      GrailsClasspathContainerUpdateJob.runInWorkspace
      1. com.springsource.sts.grails.commands.GrailsCommandUtils.deleteOutOfSynchPlugins(GrailsCommandUtils.java:392)
      2. com.springsource.sts.grails.commands.GrailsCommandUtils.refreshDependencies(GrailsCommandUtils.java:324)
      3. com.springsource.sts.grails.core.internal.classpath.GrailsClasspathContainerUpdateJob.runInWorkspace(GrailsClasspathContainerUpdateJob.java:77)
      3 frames
    3. Core Resource Management
      InternalWorkspaceJob.run
      1. org.eclipse.core.internal.resources.InternalWorkspaceJob.run(InternalWorkspaceJob.java:38)
      1 frame
    4. Eclipse Jobs
      Worker.run
      1. org.eclipse.core.internal.jobs.Worker.run(Worker.java:54)
      1 frame