java.lang.NullPointerException

JFrog JIRA | Francisco Lozano | 4 years ago
  1. 0

    I'm getting: {noformat} [INFO] ------------------------------------------------------------------------ [INFO] ------------------------------------------------------------------------ [INFO] BUILD SUCCESSFUL [INFO] ------------------------------------------------------------------------ [INFO] Total time: 1 minute 15 seconds [INFO] Finished at: Thu Dec 06 09:02:02 UTC 2012 [INFO] Final Memory: 51M/473M [INFO] ------------------------------------------------------------------------ Waiting for Jenkins to finish collecting data channel stopped ERROR: null java.lang.NullPointerException at org.jfrog.hudson.AbstractBuildInfoDeployer.addBuildInfoProperties(AbstractBuildInfoDeployer.java:148) at org.jfrog.hudson.AbstractBuildInfoDeployer.createBuildInfo(AbstractBuildInfoDeployer.java:99) at org.jfrog.hudson.maven2.MavenBuildInfoDeployer.<init>(MavenBuildInfoDeployer.java:62) at org.jfrog.hudson.ArtifactoryRedeployPublisher.perform(ArtifactoryRedeployPublisher.java:312) at hudson.tasks.BuildStepMonitor$1.perform(BuildStepMonitor.java:19) at hudson.model.AbstractBuild$AbstractBuildExecution.perform(AbstractBuild.java:804) at hudson.model.AbstractBuild$AbstractBuildExecution.performAllBuildSteps(AbstractBuild.java:779) at hudson.maven.MavenModuleSetBuild$MavenModuleSetBuildExecution.post2(MavenModuleSetBuild.java:939) at hudson.model.AbstractBuild$AbstractBuildExecution.post(AbstractBuild.java:726) at hudson.model.Run.execute(Run.java:1543) at hudson.maven.MavenModuleSetBuild.run(MavenModuleSetBuild.java:477) at hudson.model.ResourceController.execute(ResourceController.java:88) at hudson.model.Executor.run(Executor.java:236) Build step 'Deploy artifacts to Artifactory' changed build result to FAILURE Finished: FAILURE {noformat} if capture build info option of the artifactory jenkins plugin is enabled. If I don't enable this option, the plugin successfully deploys to my artifactory repository.

    JFrog JIRA | 4 years ago | Francisco Lozano
    java.lang.NullPointerException
  2. 0

    I'm getting: {noformat} [INFO] ------------------------------------------------------------------------ [INFO] ------------------------------------------------------------------------ [INFO] BUILD SUCCESSFUL [INFO] ------------------------------------------------------------------------ [INFO] Total time: 1 minute 15 seconds [INFO] Finished at: Thu Dec 06 09:02:02 UTC 2012 [INFO] Final Memory: 51M/473M [INFO] ------------------------------------------------------------------------ Waiting for Jenkins to finish collecting data channel stopped ERROR: null java.lang.NullPointerException at org.jfrog.hudson.AbstractBuildInfoDeployer.addBuildInfoProperties(AbstractBuildInfoDeployer.java:148) at org.jfrog.hudson.AbstractBuildInfoDeployer.createBuildInfo(AbstractBuildInfoDeployer.java:99) at org.jfrog.hudson.maven2.MavenBuildInfoDeployer.<init>(MavenBuildInfoDeployer.java:62) at org.jfrog.hudson.ArtifactoryRedeployPublisher.perform(ArtifactoryRedeployPublisher.java:312) at hudson.tasks.BuildStepMonitor$1.perform(BuildStepMonitor.java:19) at hudson.model.AbstractBuild$AbstractBuildExecution.perform(AbstractBuild.java:804) at hudson.model.AbstractBuild$AbstractBuildExecution.performAllBuildSteps(AbstractBuild.java:779) at hudson.maven.MavenModuleSetBuild$MavenModuleSetBuildExecution.post2(MavenModuleSetBuild.java:939) at hudson.model.AbstractBuild$AbstractBuildExecution.post(AbstractBuild.java:726) at hudson.model.Run.execute(Run.java:1543) at hudson.maven.MavenModuleSetBuild.run(MavenModuleSetBuild.java:477) at hudson.model.ResourceController.execute(ResourceController.java:88) at hudson.model.Executor.run(Executor.java:236) Build step 'Deploy artifacts to Artifactory' changed build result to FAILURE Finished: FAILURE {noformat} if capture build info option of the artifactory jenkins plugin is enabled. If I don't enable this option, the plugin successfully deploys to my artifactory repository.

    JFrog JIRA | 4 years ago | Francisco Lozano
    java.lang.NullPointerException
  3. 0
  4. Speed up your debug routine!

    Automated exception search integrated into your IDE

  5. 0

    hi! i'm trying to deploy artifacts to artifactory and i followed the tutorial, however, i got the same problem no matter what: Waiting for Jenkins to finish collecting data channel stopped Deploying artifacts to http://192.168.1.22/artifactory Deploying artifacts of module: etask.components.security:COM-SecurityGuardEntities ERROR: null java.lang.NullPointerException at org.jfrog.hudson.util.BuildUniqueIdentifierHelper.getUpstreamIdentifier(BuildUniqueIdentifierHelper.java:106) at org.jfrog.hudson.maven2.ArtifactsDeployer.deployArtifact(ArtifactsDeployer.java:170) at org.jfrog.hudson.maven2.ArtifactsDeployer.deploy(ArtifactsDeployer.java:127) at org.jfrog.hudson.ArtifactoryRedeployPublisher.perform(ArtifactoryRedeployPublisher.java:300) at hudson.tasks.BuildStepMonitor$1.perform(BuildStepMonitor.java:19) at hudson.model.AbstractBuild$AbstractRunner.perform(AbstractBuild.java:710) at hudson.model.AbstractBuild$AbstractRunner.performAllBuildSteps(AbstractBuild.java:685) at hudson.maven.MavenModuleSetBuild$RunnerImpl.post2(MavenModuleSetBuild.java:994) at hudson.model.AbstractBuild$AbstractRunner.post(AbstractBuild.java:632) at hudson.model.Run.run(Run.java:1463) at hudson.maven.MavenModuleSetBuild.run(MavenModuleSetBuild.java:477) at hudson.model.ResourceController.execute(ResourceController.java:88) at hudson.model.Executor.run(Executor.java:239) Build step 'Deploy artifacts to Artifactory' changed build result to FAILURE Finished: FAILURE it doesn't say anything i can use to resolve the problem. i attached the configuration of jenkins thank you so much for the help, Maritzabell Suarez

    Jenkins JIRA | 5 years ago | maritzabell suarez
    java.lang.NullPointerException
  6. 0

    Not finding the right solution?
    Take a tour to get the most out of Samebug.

    Tired of useless tips?

    Automated exception search integrated into your IDE

    Root Cause Analysis

    1. java.lang.NullPointerException

      No message provided

      at org.jfrog.hudson.AbstractBuildInfoDeployer.addBuildInfoProperties()
    2. org.jfrog.hudson
      ArtifactoryRedeployPublisher.perform
      1. org.jfrog.hudson.AbstractBuildInfoDeployer.addBuildInfoProperties(AbstractBuildInfoDeployer.java:148)
      2. org.jfrog.hudson.AbstractBuildInfoDeployer.createBuildInfo(AbstractBuildInfoDeployer.java:99)
      3. org.jfrog.hudson.maven2.MavenBuildInfoDeployer.<init>(MavenBuildInfoDeployer.java:62)
      4. org.jfrog.hudson.ArtifactoryRedeployPublisher.perform(ArtifactoryRedeployPublisher.java:312)
      4 frames
    3. Hudson
      AbstractBuild$AbstractBuildExecution.performAllBuildSteps
      1. hudson.tasks.BuildStepMonitor$1.perform(BuildStepMonitor.java:19)
      2. hudson.model.AbstractBuild$AbstractBuildExecution.perform(AbstractBuild.java:804)
      3. hudson.model.AbstractBuild$AbstractBuildExecution.performAllBuildSteps(AbstractBuild.java:779)
      3 frames
    4. Hudson Maven Embedder
      MavenModuleSetBuild$MavenModuleSetBuildExecution.post2
      1. hudson.maven.MavenModuleSetBuild$MavenModuleSetBuildExecution.post2(MavenModuleSetBuild.java:939)
      1 frame
    5. Hudson
      Run.execute
      1. hudson.model.AbstractBuild$AbstractBuildExecution.post(AbstractBuild.java:726)
      2. hudson.model.Run.execute(Run.java:1543)
      2 frames
    6. Hudson Maven Embedder
      MavenModuleSetBuild.run
      1. hudson.maven.MavenModuleSetBuild.run(MavenModuleSetBuild.java:477)
      1 frame
    7. Hudson
      Executor.run
      1. hudson.model.ResourceController.execute(ResourceController.java:88)
      2. hudson.model.Executor.run(Executor.java:236)
      2 frames