java.lang.NullPointerException

There are no available Samebug tips for this exception. Do you have an idea how to solve this issue? A short tip would help users who saw this issue last week.

  • I'm getting: {noformat} [INFO] ------------------------------------------------------------------------ [INFO] ------------------------------------------------------------------------ [INFO] BUILD SUCCESSFUL [INFO] ------------------------------------------------------------------------ [INFO] Total time: 1 minute 15 seconds [INFO] Finished at: Thu Dec 06 09:02:02 UTC 2012 [INFO] Final Memory: 51M/473M [INFO] ------------------------------------------------------------------------ Waiting for Jenkins to finish collecting data channel stopped ERROR: null java.lang.NullPointerException at org.jfrog.hudson.AbstractBuildInfoDeployer.addBuildInfoProperties(AbstractBuildInfoDeployer.java:148) at org.jfrog.hudson.AbstractBuildInfoDeployer.createBuildInfo(AbstractBuildInfoDeployer.java:99) at org.jfrog.hudson.maven2.MavenBuildInfoDeployer.<init>(MavenBuildInfoDeployer.java:62) at org.jfrog.hudson.ArtifactoryRedeployPublisher.perform(ArtifactoryRedeployPublisher.java:312) at hudson.tasks.BuildStepMonitor$1.perform(BuildStepMonitor.java:19) at hudson.model.AbstractBuild$AbstractBuildExecution.perform(AbstractBuild.java:804) at hudson.model.AbstractBuild$AbstractBuildExecution.performAllBuildSteps(AbstractBuild.java:779) at hudson.maven.MavenModuleSetBuild$MavenModuleSetBuildExecution.post2(MavenModuleSetBuild.java:939) at hudson.model.AbstractBuild$AbstractBuildExecution.post(AbstractBuild.java:726) at hudson.model.Run.execute(Run.java:1543) at hudson.maven.MavenModuleSetBuild.run(MavenModuleSetBuild.java:477) at hudson.model.ResourceController.execute(ResourceController.java:88) at hudson.model.Executor.run(Executor.java:236) Build step 'Deploy artifacts to Artifactory' changed build result to FAILURE Finished: FAILURE {noformat} if capture build info option of the artifactory jenkins plugin is enabled. If I don't enable this option, the plugin successfully deploys to my artifactory repository.
    via by Francisco Lozano,
  • I'm getting: {noformat} [INFO] ------------------------------------------------------------------------ [INFO] ------------------------------------------------------------------------ [INFO] BUILD SUCCESSFUL [INFO] ------------------------------------------------------------------------ [INFO] Total time: 1 minute 15 seconds [INFO] Finished at: Thu Dec 06 09:02:02 UTC 2012 [INFO] Final Memory: 51M/473M [INFO] ------------------------------------------------------------------------ Waiting for Jenkins to finish collecting data channel stopped ERROR: null java.lang.NullPointerException at org.jfrog.hudson.AbstractBuildInfoDeployer.addBuildInfoProperties(AbstractBuildInfoDeployer.java:148) at org.jfrog.hudson.AbstractBuildInfoDeployer.createBuildInfo(AbstractBuildInfoDeployer.java:99) at org.jfrog.hudson.maven2.MavenBuildInfoDeployer.<init>(MavenBuildInfoDeployer.java:62) at org.jfrog.hudson.ArtifactoryRedeployPublisher.perform(ArtifactoryRedeployPublisher.java:312) at hudson.tasks.BuildStepMonitor$1.perform(BuildStepMonitor.java:19) at hudson.model.AbstractBuild$AbstractBuildExecution.perform(AbstractBuild.java:804) at hudson.model.AbstractBuild$AbstractBuildExecution.performAllBuildSteps(AbstractBuild.java:779) at hudson.maven.MavenModuleSetBuild$MavenModuleSetBuildExecution.post2(MavenModuleSetBuild.java:939) at hudson.model.AbstractBuild$AbstractBuildExecution.post(AbstractBuild.java:726) at hudson.model.Run.execute(Run.java:1543) at hudson.maven.MavenModuleSetBuild.run(MavenModuleSetBuild.java:477) at hudson.model.ResourceController.execute(ResourceController.java:88) at hudson.model.Executor.run(Executor.java:236) Build step 'Deploy artifacts to Artifactory' changed build result to FAILURE Finished: FAILURE {noformat} if capture build info option of the artifactory jenkins plugin is enabled. If I don't enable this option, the plugin successfully deploys to my artifactory repository.
    via by Francisco Lozano,
    • java.lang.NullPointerException at org.jfrog.hudson.AbstractBuildInfoDeployer.addBuildInfoProperties(AbstractBuildInfoDeployer.java:148) at org.jfrog.hudson.AbstractBuildInfoDeployer.createBuildInfo(AbstractBuildInfoDeployer.java:99) at org.jfrog.hudson.generic.GenericBuildInfoDeployer.<init>(GenericBuildInfoDeployer.java:61) at org.jfrog.hudson.generic.ArtifactoryGenericConfigurator$1.tearDown(ArtifactoryGenericConfigurator.java:251) at hudson.model.Build$BuildExecution.doRun(Build.java:171) at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:592) at hudson.model.Run.execute(Run.java:1543) at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:46) at hudson.model.ResourceController.execute(ResourceController.java:88) at hudson.model.Executor.run(Executor.java:236)
    No Bugmate found.