org.osgi.framework.BundleException

Unresolved constraint in bundle org.springframework.roo.classpath.javaparser [37]: package; (&(package=org.springframework.roo.classpath.details.annotations)(version>=1.1.0)(!(version>=2.0.0)))

Solutions on the web6211

  • via SpringSource Issue Tracker by Steffen Pingel, 1 year ago
    Unresolved constraint in bundle org.springframework.roo.classpath.javaparser [37]: package; (&(package=org.springframework.roo.classpath.details.annotations)(version>=1.1.0)(!(version>=2.0.0)))
  • via SpringSource Issue Tracker by Steffen Pingel, 1 year ago
    Unresolved constraint in bundle org.springframework.roo.classpath.javaparser [37]: package; (&(package=org.springframework.roo.classpath.details.annotations)(version>=1.1.0)(!(version>=2.0.0)))
  • via Spring JIRA by Martin Lippert, 1 year ago
    Unresolved constraint in bundle org.springframework.roo.classpath.javaparser [37]: Unable to resolve 37.0: missing requirement [37.0] package; (&(package=org.springframework.roo.classpath)(version>=1.1.0)(!(version>=2.0.0))) [caused by: Unable to
  • Stack trace

    • org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.classpath.javaparser [37]: package; (&(package=org.springframework.roo.classpath.details.annotations)(version>=1.1.0)(!(version>=2.0.0))) at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3295) at org.apache.felix.framework.Felix.startBundle(Felix.java:1653) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1124) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:264) at java.lang.Thread.run(Thread.java:619)

    Write tip

    You have a different solution? A short tip here would help you and many other users who saw this issue last week.

    Users with the same issue

    2 times, 5 months ago
    Unknown user
    Once, 1 year ago
    Unknown user
    Once, 1 year ago
    Unknown user
    Once, 1 year ago
    Unknown user
    Once, 11 months ago
    2 more bugmates