java.lang.NoClassDefFoundError

There are no available Samebug tips for this exception. Do you have an idea how to solve this issue? A short tip would help users who saw this issue last week.

  • I upgrade from STS 2.8.0 RELEASE to 2.8.1.RELEASE a few days ago. Everything's been working fine. But today, suddenly, I've got an error with description "null" in my Problems view for the pom.xml of all of my projects. My Error Log is showing these errors: Message: Problems occurred when invoking code from plug-in: "org.eclipse.core.resources". java.lang.NoClassDefFoundError: com/springsource/sts/maven/MavenCorePlugin$PomResourceChangeListener$PomResourceVisitor at com.springsource.sts.maven.MavenCorePlugin$PomResourceChangeListener.getVisitor(MavenCorePlugin.java:203) at com.springsource.sts.maven.MavenCorePlugin$PomResourceChangeListener.resourceChanged(MavenCorePlugin.java:174) at org.eclipse.core.internal.events.NotificationManager$1.run(NotificationManager.java:291) at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:42) at org.eclipse.core.internal.events.NotificationManager.notify(NotificationManager.java:285) at org.eclipse.core.internal.events.NotificationManager.broadcastChanges(NotificationManager.java:149) at org.eclipse.core.internal.resources.Workspace.broadcastPostChange(Workspace.java:395) at org.eclipse.core.internal.resources.Workspace.endOperation(Workspace.java:1530) at org.eclipse.core.internal.events.AutoBuildJob.doBuild(AutoBuildJob.java:156) at org.eclipse.core.internal.events.AutoBuildJob.run(AutoBuildJob.java:241) at org.eclipse.core.internal.jobs.Worker.run(Worker.java:54) Session Data: eclipse.buildId=2.8.1.201111221000-RELEASE java.version=1.7.0_01 java.vendor=Oracle Corporation BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=en_US Framework arguments: -product com.springsource.sts.ide Command-line arguments: -os win32 -ws win32 -arch x86_64 -product com.springsource.sts.ide
    via by Patrick Taylor,
  • I upgrade from STS 2.8.0 RELEASE to 2.8.1.RELEASE a few days ago. Everything's been working fine. But today, suddenly, I've got an error with description "null" in my Problems view for the pom.xml of all of my projects. My Error Log is showing these errors: Message: Problems occurred when invoking code from plug-in: "org.eclipse.core.resources". java.lang.NoClassDefFoundError: com/springsource/sts/maven/MavenCorePlugin$PomResourceChangeListener$PomResourceVisitor at com.springsource.sts.maven.MavenCorePlugin$PomResourceChangeListener.getVisitor(MavenCorePlugin.java:203) at com.springsource.sts.maven.MavenCorePlugin$PomResourceChangeListener.resourceChanged(MavenCorePlugin.java:174) at org.eclipse.core.internal.events.NotificationManager$1.run(NotificationManager.java:291) at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:42) at org.eclipse.core.internal.events.NotificationManager.notify(NotificationManager.java:285) at org.eclipse.core.internal.events.NotificationManager.broadcastChanges(NotificationManager.java:149) at org.eclipse.core.internal.resources.Workspace.broadcastPostChange(Workspace.java:395) at org.eclipse.core.internal.resources.Workspace.endOperation(Workspace.java:1530) at org.eclipse.core.internal.events.AutoBuildJob.doBuild(AutoBuildJob.java:156) at org.eclipse.core.internal.events.AutoBuildJob.run(AutoBuildJob.java:241) at org.eclipse.core.internal.jobs.Worker.run(Worker.java:54) Session Data: eclipse.buildId=2.8.1.201111221000-RELEASE java.version=1.7.0_01 java.vendor=Oracle Corporation BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=en_US Framework arguments: -product com.springsource.sts.ide Command-line arguments: -os win32 -ws win32 -arch x86_64 -product com.springsource.sts.ide
    via by Patrick Taylor,
    • java.lang.NoClassDefFoundError: com/springsource/sts/maven/MavenCorePlugin$PomResourceChangeListener$PomResourceVisitor at com.springsource.sts.maven.MavenCorePlugin$PomResourceChangeListener.getVisitor(MavenCorePlugin.java:203) at com.springsource.sts.maven.MavenCorePlugin$PomResourceChangeListener.resourceChanged(MavenCorePlugin.java:174) at org.eclipse.core.internal.events.NotificationManager$1.run(NotificationManager.java:291) at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:42) at org.eclipse.core.internal.events.NotificationManager.notify(NotificationManager.java:285) at org.eclipse.core.internal.events.NotificationManager.broadcastChanges(NotificationManager.java:149) at org.eclipse.core.internal.resources.Workspace.broadcastPostChange(Workspace.java:395) at org.eclipse.core.internal.resources.Workspace.endOperation(Workspace.java:1530) at org.eclipse.core.internal.events.AutoBuildJob.doBuild(AutoBuildJob.java:156) at org.eclipse.core.internal.events.AutoBuildJob.run(AutoBuildJob.java:241) at org.eclipse.core.internal.jobs.Worker.run(Worker.java:54)
    No Bugmate found.